aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nefu/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-04-07 11:49:00 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-04-07 11:49:00 +0000
commit3c2bcf7ec246614a87419deab9b0dd93dce78a2e (patch)
tree8a48811c74a8079b43199d043866643dc3b8e8ea /net-mgmt/nefu/Makefile
parent2e4b118f40c2b44d0c2d48ad0071232967885480 (diff)
downloadports-3c2bcf7ec246614a87419deab9b0dd93dce78a2e.tar.gz
ports-3c2bcf7ec246614a87419deab9b0dd93dce78a2e.zip
- Use fix uid and gid
- Fix broken --without-html with patches - Add OPTIONS for HTML - Add rc script - Pass maintainership to submitter PR: ports/126787 Submitted by: decke at bluelife.at
Notes
Notes: svn path=/head/; revision=231770
Diffstat (limited to 'net-mgmt/nefu/Makefile')
-rw-r--r--net-mgmt/nefu/Makefile35
1 files changed, 32 insertions, 3 deletions
diff --git a/net-mgmt/nefu/Makefile b/net-mgmt/nefu/Makefile
index 5982aa3b0e2f..27a242f00e05 100644
--- a/net-mgmt/nefu/Makefile
+++ b/net-mgmt/nefu/Makefile
@@ -7,27 +7,36 @@
PORTNAME= nefu
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://rsug.itd.umich.edu/software/nefu/files/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= decke@bluelife.at
COMMENT= A network monitoring daemon
+USE_RC_SUBR= nefu
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
YACC=${YACC} \
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE} --without-html \
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE} \
+ --without-sasl \
+ --without-zlib \
--without-shelltests
+NEFU_USER= nefu
+NEFU_GROUP= nefu
+
USE_OPENSSL= yes
-OPTIONS= LDAP "Enable OpenLDAP support" off
+OPTIONS= LDAP "Enable OpenLDAP support" off \
+ HTML "Enable HTML support" off
MAN1= nefu.1
MAN4= nefu.conf.4
+DBDIR= /var/db/nefu
PLIST_FILES= bin/nefu
.include <bsd.port.pre.mk>
@@ -39,15 +48,35 @@ CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}/lib
CONFIGURE_ARGS+= --without-ldap
.endif
+.if defined(WITH_HTML)
+CONFIGURE_ARGS+=--with-html=${WWWDIR}
+PLIST_FILES+= "@unexec rm -rf "%D/%%WWWDIR%%" 2> /dev/null || true"
+.else
+CONFIGURE_ARGS+=--without-html
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lsasl2||' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-lssl|-lssl -lcrypto|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|== x_|= x_|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|== x_|= x_|' \
+ ${WRKSRC}/libsnet/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nefu.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/nefu.conf.4 ${PREFIX}/man/man4
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if defined(WITH_HTML)
+ ${MKDIR} ${WWWDIR}
+ ${CHOWN} -R ${NEFU_USER}:${NEFU_GROUP} ${WWWDIR}
+.endif
+ ${MKDIR} ${DBDIR}
+ ${CHOWN} -R ${NEFU_USER}:${NEFU_GROUP} ${DBDIR}
+
.include <bsd.port.post.mk>