aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-09-08 12:20:36 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-09-08 12:20:36 +0000
commit438528a8414e7c6cb33f4932429130a345c3f190 (patch)
treef2b77170489bc572178feecbc4f1433023d85499 /net-mgmt/net-snmp/Makefile
parentebed0d45d4969c1598359076f0656f6a374fcfa9 (diff)
downloadports-438528a8414e7c6cb33f4932429130a345c3f190.tar.gz
ports-438528a8414e7c6cb33f4932429130a345c3f190.zip
- Fix build when PREFIX != PKG_PREFIX
PR: 193358 Submitted by: dinox@
Notes
Notes: svn path=/head/; revision=367619
Diffstat (limited to 'net-mgmt/net-snmp/Makefile')
-rw-r--r--net-mgmt/net-snmp/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index dfc0532fa2fa..c8dfac8a8213 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -39,7 +39,7 @@ USE_LDCONFIG= yes
USES= perl5 libtool
USE_PERL5= build run fixpacklist
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -I${PKG_PREFIX}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= PERLPROG="${PERL}" PSPROG="${PS_CMD}" SED="${SED}"
CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
@@ -49,7 +49,7 @@ CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
--with-logfile="${NET_SNMP_LOGFILE}" \
--with-persistent-directory="${NET_SNMP_PERSISTENTDIR}" \
--with-gnu-ld --with-libwrap \
- --with-ldflags="-lm -lkvm -ldevstat -lpkg -L${LOCALBASE}/lib ${LCRYPTO}"
+ --with-ldflags="-lm -lkvm -ldevstat -lpkg -L${LOCALBASE}/lib -L${PKG_PREFIX}/lib ${LCRYPTO}"
SUB_FILES= pkg-message
.if defined(BATCH)