aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2018-02-07 18:11:27 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2018-02-07 18:11:27 +0000
commit800a9293b0051541cf446a0e0fd3932504a31596 (patch)
treefcd8f920f76e326c2ffa07092f124a674a8562a9 /net-mgmt/net-snmp
parent42f77ab84132fb2ef12c52e15abc7c41a5f6e7f4 (diff)
downloadports-800a9293b0051541cf446a0e0fd3932504a31596.tar.gz
ports-800a9293b0051541cf446a0e0fd3932504a31596.zip
- Do not try to build under mips/mips64 as SSP is broken per r306364
Reported by: sbruno
Notes
Notes: svn path=/head/; revision=461161
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 21a578f1a85f..d3013316af89 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -18,6 +18,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpkg.so:ports-mgmt/pkg
+NOT_FOR_ARCHS= mips mips64
+NOT_FOR_ARCHS_REASON= SSP is currently broken on MIPS
+
OPTIONS_DEFINE= IPV6 MFD_REWRITES PERL PERL_EMBEDDED PYTHON DUMMY TKMIB \
MYSQL AX_SOCKONLY UNPRIVILEGED SMUX DOCS JAIL AX_DISABLE_TRAP \
TLS
@@ -28,7 +31,6 @@ MFD_REWRITES_DESC= Use new MFD rewrites of mib modules
PERL_EMBEDDED_DESC= Build embedded perl
DUMMY_DESC= Enable dummy values as placeholders
TKMIB_DESC= Install graphical MIB browser
-#DMALLOC_DESC= Enable dmalloc debug memory allocator
AX_SOCKONLY_DESC= Disable UDP/TCP transports for agentx
AX_DISABLE_TRAP_DESC= Disable agentx subagent code in snmptrapd
UNPRIVILEGED_DESC= Allow unprivileged users to execute net-snmp
@@ -118,13 +120,6 @@ PLIST_SUB+= WITH_PERL_EMBEDDED="@comment "
PLIST_SUB+= WITH_PERL="@comment "
.endif
-#.if ${PORT_OPTIONS:MDMALLOC}
-#LIB_DEPENDS+= libdmalloc.so:devel/dmalloc
-#CONFIGURE_ARGS+=--with-dmalloc=${LOCALBASE}
-#.else
-#CONFIGURE_ARGS+=--without-dmalloc
-#.endif
-
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql