aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netbox/Makefile
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2024-04-23 11:34:59 +0000
committerKai Knoblich <kai@FreeBSD.org>2024-04-23 11:59:16 +0000
commitd4adc005cbdb7d83ad2ef2ee92a6017cf94080b7 (patch)
tree7ee93dbb7476940a9219b340a7313ab3d2e67930 /net-mgmt/netbox/Makefile
parent3647b0d87e70dbb49202aacaadbd4aa0276af2a7 (diff)
downloadports-d4adc005cbdb7d83ad2ef2ee92a6017cf94080b7.tar.gz
ports-d4adc005cbdb7d83ad2ef2ee92a6017cf94080b7.zip
net-mgmt/netbox: Update 3.7.6
Changelog: Enhancements: * Improve rendering of JSON data in configuration form * Enable compatibility with non-Amazon S3 providers for remote data sources * Add global search support for L2VPN identifiers * Introduce new configuration parameters for enabling HTTP Strict Transport Security (HSTS) Bug Fixes: * Restore ability to modify assigned component template when adding/modifying an inventory item template * Fix permission constraints for synchronization of remote data sources * Correct OpenAPI schema definitions for read-only fields which may return null values * Extend plugin removal instruction to include reindexing the global search cache * Fix AttributeError exception when attempting to save an incomplete tunnel termination * Fix permission required to display virtual disks tab on virtual machine UI view * Allow filtering cables by decimal values using UI filter form * Add missing ike_policy & ike_policy_id filters for IKE proposals * Include id in list of supported fields for all bulk import forms * Fix live preview support for EventRule comments https://github.com/netbox-community/netbox/releases/tag/v3.7.6 MFH: 2024Q2
Diffstat (limited to 'net-mgmt/netbox/Makefile')
-rw-r--r--net-mgmt/netbox/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-mgmt/netbox/Makefile b/net-mgmt/netbox/Makefile
index 1b88446af897..dc32398c2d77 100644
--- a/net-mgmt/netbox/Makefile
+++ b/net-mgmt/netbox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= netbox
DISTVERSIONPREFIX= v
-DISTVERSION= 3.7.5
+DISTVERSION= 3.7.6
CATEGORIES= net-mgmt python
MAINTAINER= kai@FreeBSD.org
@@ -45,8 +45,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=4.2.11<4.3:www/py-django42@${PY_FL
${PYTHON_PKGNAMEPREFIX}feedparser>=6.0.11<7:textproc/py-feedparser@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.1.3<4:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown>=3.5.2<3.7:textproc/py-markdown@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mkdocs-material>=9.5.17<10:textproc/py-mkdocs-material@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mkdocstrings>=0.24.2<1:textproc/py-mkdocstrings@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mkdocs-material>=9.5.18<10:textproc/py-mkdocs-material@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mkdocstrings>=0.24.3<1:textproc/py-mkdocstrings@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocstrings-python-legacy>0:textproc/py-mkdocstrings-python-legacy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}netaddr>=1.2.1<2:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=10.3.0:graphics/py-pillow@${PY_FLAVOR} \
@@ -58,7 +58,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=4.2.11<4.3:www/py-django42@${PY_FL
${PYTHON_PKGNAMEPREFIX}tablib>=3.6.1<4:textproc/py-tablib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tzdata>=2024.1:devel/py-tzdata@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=6.0.1<7:devel/py-yaml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}gunicorn>=21.2.0<22:www/py-gunicorn@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}gunicorn>=21.2.0<23:www/py-gunicorn@${PY_FLAVOR}
USES= cpe pgsql:12+ python
CPE_VENDOR= netbox