aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netbox/Makefile
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-10-28 04:27:55 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-10-28 04:34:06 +0000
commite795689cbf32b3db0f9e3d414aee420b5285fb3e (patch)
tree4172835b43a143ff16436caa0ced8623c36473eb /net-mgmt/netbox/Makefile
parent6aafb2486b25988103b448e1ace6d0d7deb5d023 (diff)
downloadports-e795689cbf32b3db0f9e3d414aee420b5285fb3e.tar.gz
ports-e795689cbf32b3db0f9e3d414aee420b5285fb3e.zip
net-mgmt/netbox: Update to 3.6.4
Changelog: Enhancements * Include circuit description in cable trace SVG image * Introduce the DATA_UPLOAD_MAX_MEMORY_SIZE configuration parameter * Display custom choice field labels rather than values in UI * Add DNS name filter on IP addresses list * Add a copy-to-clipboard button for API tokens * Introduce a filter to find unterminated cables Bug Fixes * Fix validation of bulk cable updates via bulk import form * Ensure generic foreign key relationships are populated in REST API serializations of objects * Employ PostgreSQL advisory locks to avoid duplicate MPTT tree IDs when bulk creating objects * Fix resetting of checkbox fields triggered by HTMX form re-rendering * Fix support for assigning a tenant when creating "next available" VLANs via the REST API * Fix support for setting custom field values when creating "next available" IP addresses via the REST API * Add CSV delimiter field to file upload tab under bulk object upload views * Fix support for assigning an interface when creating "next available" IP addresses via the REST API * Correct "add device" button link under platform view * Correct serialization of several report attributes in the REST API * Restore "last login" column on users table * Fix device role filter choices under inventory items list filters * Fix exception when bulk disconnecting interfaces connected to the same cable * Fix exception when viewing a script that begins with the same name as another * Optimize the automatic creation of available IP addresses for large prefixes * Fix duplicated child object count decrements when removing objects in bulk https://github.com/netbox-community/netbox/releases/tag/v3.6.4 MFH: 2023Q4
Diffstat (limited to 'net-mgmt/netbox/Makefile')
-rw-r--r--net-mgmt/netbox/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-mgmt/netbox/Makefile b/net-mgmt/netbox/Makefile
index 14798d0055be..93007fabd36b 100644
--- a/net-mgmt/netbox/Makefile
+++ b/net-mgmt/netbox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= netbox
DISTVERSIONPREFIX= v
-DISTVERSION= 3.6.3
+DISTVERSION= 3.6.4
CATEGORIES= net-mgmt python
MAINTAINER= kai@FreeBSD.org
@@ -23,36 +23,37 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
# - www/py-dj42-django-tables2
# - www/py-dj42-djangorestframework
#
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=4.2.5<4.3:www/py-django42@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dj42-django-cors-headers>=4.2.0<5:www/py-dj42-django-cors-headers@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=4.2.6<4.3:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj42-django-cors-headers>=4.3.0<5:www/py-dj42-django-cors-headers@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-debug-toolbar>=4.2.0<5:www/py-dj42-django-debug-toolbar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-filter>=23.3<24:www/py-dj42-django-filter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-graphiql-debug-toolbar>=0.2.0<1:www/py-dj42-django-graphiql-debug-toolbar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-mptt>=0.14.0<0.15:www/py-dj42-django-mptt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-prometheus>=2.3.1<2.4:www/py-dj42-django-prometheus@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dj42-django-redis>=5.3.0<6:www/py-dj42-django-redis@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dj42-django-rich>=1.7.0<2:www/py-dj42-django-rich@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj42-django-redis>=5.4.0<6:www/py-dj42-django-redis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj42-django-rich>=1.8.0<2:www/py-dj42-django-rich@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-rq>=2.8.1<2.9:devel/py-dj42-django-rq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-tables2>=2.6<2.7:www/py-dj42-django-tables2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-taggit>=4.0.0<5:www/py-dj42-django-taggit@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-django-timezone-field>=6.0.1<7:www/py-dj42-django-timezone-field@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-djangorestframework>=3.14.0<3.15.0:www/py-dj42-djangorestframework@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dj42-drf-spectacular>=0.26.4<1:www/py-dj42-drf-spectacular@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dj42-drf-spectacular-sidecar>=2023.9.1:www/py-dj42-drf-spectacular-sidecar@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj42-drf-spectacular>=0.26.5<1:www/py-dj42-drf-spectacular@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj42-drf-spectacular-sidecar>=2023.10.1:www/py-dj42-drf-spectacular-sidecar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dj42-graphene-django>=3.0.0<3.0.0_99:devel/py-dj42-graphene-django@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-pglocks>=1.0.4<1.1:www/py-django-pglocks@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bleach>=6.0.0<7:www/py-bleach@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}feedparser>=6.0.8<7:textproc/py-feedparser@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.1.2<4:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown>=3.3.7<3.4:textproc/py-markdown@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mkdocs-material>=9.4.2<10:textproc/py-mkdocs-material@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mkdocs-material>=9.4.6<10:textproc/py-mkdocs-material@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocstrings>=0.23.0<1:textproc/py-mkdocstrings@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocstrings-python-legacy>0:textproc/py-mkdocstrings-python-legacy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}netaddr>=0.9.0<1:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=10.0.1:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psycopg>=3.1.10<4:databases/py-psycopg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.31.0<3:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sentry-sdk>=1.21.1<2:devel/py-sentry-sdk@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}social-auth-app-django>=5.3.0<6:www/py-social-auth-app-django@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}social-auth-app-django>=5.4.0<6:www/py-social-auth-app-django@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}social-auth-core>=4.4.2<5:security/py-social-auth-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}svgwrite>=1.4.3<2:graphics/py-svgwrite@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tablib>=3.5.0<4:textproc/py-tablib@${PY_FLAVOR} \