aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nrpe
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-04-28 19:33:27 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-04-28 19:33:27 +0000
commit8feb17ea57342a273ea2fb424e8c690942618e34 (patch)
tree4b964c95e6e1930a094d584d9f89e6810a394384 /net-mgmt/nrpe
parentc42648a9f3da10d72e3d1b5f08f05f85f25f21a4 (diff)
downloadports-8feb17ea57342a273ea2fb424e8c690942618e34.tar.gz
ports-8feb17ea57342a273ea2fb424e8c690942618e34.zip
net-mgmt/nrpe: Use 2048-bit DH params
- Add patch for DH-param generation in configure - Update patch switching dh512 to dh2048 for server - Add LICENSE - Fixes runtime issue when nrpe-ssl built with LibreSSL 2.5 PR: 218930 Approved by: zeising (maintainer)
Notes
Notes: svn path=/head/; revision=439625
Diffstat (limited to 'net-mgmt/nrpe')
-rw-r--r--net-mgmt/nrpe/Makefile2
-rw-r--r--net-mgmt/nrpe/files/patch-configure11
-rw-r--r--net-mgmt/nrpe/files/patch-src-nrpe.c13
3 files changed, 24 insertions, 2 deletions
diff --git a/net-mgmt/nrpe/Makefile b/net-mgmt/nrpe/Makefile
index d2482fc4b3d0..17e365219d64 100644
--- a/net-mgmt/nrpe/Makefile
+++ b/net-mgmt/nrpe/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/nagios/${PORTNAME}-2.x/${PORTNAME}-${PORTVERSION}
MAINTAINER= zeising@FreeBSD.org
COMMENT?= Nagios Remote Plugin Executor
+LICENSE= GPLv2
+
CONFLICTS= nrpe-ssl-2.*
USES= perl5
diff --git a/net-mgmt/nrpe/files/patch-configure b/net-mgmt/nrpe/files/patch-configure
new file mode 100644
index 000000000000..ed8ebc215191
--- /dev/null
+++ b/net-mgmt/nrpe/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-09-06 15:27:13 UTC
++++ configure
+@@ -6745,7 +6745,7 @@ _ACEOF
+ sslbin=$ssldir/bin/openssl
+ fi
+ # awk to strip off meta data at bottom of dhparam output
+- $sslbin dhparam -C 512 | awk '/^-----/ {exit} {print}' > include/dh.h
++ $sslbin dhparam -C 2048 | awk '/^-----/ {exit} {print}' > include/dh.h
+ fi
+ fi
+
diff --git a/net-mgmt/nrpe/files/patch-src-nrpe.c b/net-mgmt/nrpe/files/patch-src-nrpe.c
index f00488055437..b8066697c1a3 100644
--- a/net-mgmt/nrpe/files/patch-src-nrpe.c
+++ b/net-mgmt/nrpe/files/patch-src-nrpe.c
@@ -1,5 +1,5 @@
---- ./src/nrpe.c.orig 2013-09-06 17:27:13.000000000 +0200
-+++ ./src/nrpe.c 2013-10-05 17:15:33.000000000 +0200
+--- src/nrpe.c.orig 2013-09-06 15:27:13 UTC
++++ src/nrpe.c
@@ -30,6 +30,8 @@
#include "utils.h"
#include "acl.h"
@@ -19,6 +19,15 @@
int main(int argc, char **argv){
+@@ -266,7 +270,7 @@ int main(int argc, char **argv){
+
+ /* use anonymous DH ciphers */
+ SSL_CTX_set_cipher_list(ctx,"ADH");
+- dh=get_dh512();
++ dh=get_dh2048();
+ SSL_CTX_set_tmp_dh(ctx,dh);
+ DH_free(dh);
+ if(debug==TRUE)
@@ -969,8 +973,14 @@
continue;