aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nsca-ng
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-04 16:03:47 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-04 16:03:47 +0000
commitdc77ec12ea27549447c0148b84fedf849b97caff (patch)
tree4018bdae11f0f4747e780350d5aec3aefbeda42f /net-mgmt/nsca-ng
parent31e0a5979d76d88cff39005c898758f81b053894 (diff)
downloadports-dc77ec12ea27549447c0148b84fedf849b97caff.tar.gz
ports-dc77ec12ea27549447c0148b84fedf849b97caff.zip
net-mgmt/nsca-ng: Update to 1.6
This is not broken anymore in 12 and 13 ChangeLog: https://github.com/weiss/nsca-ng/blob/master/NEWS#changes-in-release-16-2019-03-19 Accumulated changes from 1.4: * Work around TLSv1.3 PSK bug in (at least) OpenSSL 1.1.1b. * Fix static linking against recent OpenSSL versions. * Update our copy of libev from version 4.22 to version 4.25. The new release provides a few platform compatibilty fixes and small enhancements. * Apply a few minor improvements. * Include an experimental NSCA-ng client module for Perl. * Link against libsystemd instead of libsystemd-daemon when using systemd version 210 or newer, where the latter library has been merged into the former. * Include the systemd.service(5) and systemd.socket(5) files with the release tarball. * Update our copy of libev from version 4.15 to version 4.22. The new release provides a number of bug fixes and small enhancements. While here, update WWW in pkg-descr PR: 247145 Submitted by: knan-bfo@modirum.com Reviewed by: pi, fernape Approved by: alexander@sulfrian.net (maintainer, timeout > 1 month) Differential Revision: https://reviews.freebsd.org/D25208
Notes
Notes: svn path=/head/; revision=541222
Diffstat (limited to 'net-mgmt/nsca-ng')
-rw-r--r--net-mgmt/nsca-ng/Makefile22
-rw-r--r--net-mgmt/nsca-ng/distinfo5
-rw-r--r--net-mgmt/nsca-ng/files/patch-src_common_tls.c20
-rw-r--r--net-mgmt/nsca-ng/pkg-descr2
4 files changed, 13 insertions, 36 deletions
diff --git a/net-mgmt/nsca-ng/Makefile b/net-mgmt/nsca-ng/Makefile
index 67637e38d754..854003ccc244 100644
--- a/net-mgmt/nsca-ng/Makefile
+++ b/net-mgmt/nsca-ng/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nsca-ng
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 1.6
+DISTVERSIONPREFIX=v
CATEGORIES= net-mgmt
-MASTER_SITES= https://www.nsca-ng.org/download/ http://www.nsca-ng.org/download/
MAINTAINER= alexander@sulfrian.net
COMMENT= Nagios Service Check Acceptor
@@ -14,37 +13,34 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libev.so:devel/libev
-
.if !defined(PKGNAMESUFFIX)
LIB_DEPENDS+= libconfuse.so:devel/libconfuse
.endif
-CONFLICTS?= nsca-2.* nsca27-2.*
-
-USES= ssl
+USES= ssl autoreconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/spool/nagios
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+USE_GITHUB= true
+GH_ACCOUNT= weiss
+
.if !defined(PKGNAMESUFFIX)
USE_RC_SUBR= nsca-ng
CONFIGURE_ARGS+= --enable-server
.endif
+CONFLICTS?= nsca-2.* nsca27-2.*
+
PORTDOCS= NEWS COPYING README PROTOCOL TODO
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT} == base
-BROKEN_FreeBSD_12= cannot link with OpenSSL
-BROKEN_FreeBSD_13= cannot link with OpenSSL
-.endif
-
.if ${SSL_DEFAULT:Mlibressl*}
-IGNORE= Requires PSK which is unsupported by the selected LibreSSL
+IGNORE+= requires PSK which is unsupported by the selected LibreSSL
.endif
post-install:
diff --git a/net-mgmt/nsca-ng/distinfo b/net-mgmt/nsca-ng/distinfo
index 9f9a7ec1843a..57dccbc007fc 100644
--- a/net-mgmt/nsca-ng/distinfo
+++ b/net-mgmt/nsca-ng/distinfo
@@ -1,2 +1,3 @@
-SHA256 (nsca-ng-1.4.tar.gz) = 25f8e0439104e72443325e5f2503ed39329dccb7928de162dbb7fe6df7196a29
-SIZE (nsca-ng-1.4.tar.gz) = 354012
+TIMESTAMP = 1591782852
+SHA256 (weiss-nsca-ng-v1.6_GH0.tar.gz) = 215e9e06293e46ca825d6dbc9f57e74180dc928d98d3f24b234086d3face75c2
+SIZE (weiss-nsca-ng-v1.6_GH0.tar.gz) = 233563
diff --git a/net-mgmt/nsca-ng/files/patch-src_common_tls.c b/net-mgmt/nsca-ng/files/patch-src_common_tls.c
deleted file mode 100644
index 250dd9ffbc0e..000000000000
--- a/net-mgmt/nsca-ng/files/patch-src_common_tls.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/common/tls.c.orig 2018-10-10 00:47:13 UTC
-+++ src/common/tls.c
-@@ -102,6 +102,7 @@
- #include <ev.h>
- #include <openssl/conf.h>
- #include <openssl/err.h>
-+#include <openssl/opensslv.h>
- #include <openssl/ssl.h>
-
- #include "log.h"
-@@ -419,7 +420,9 @@ initialize_openssl(const SSL_METHOD *method, const cha
-
- (void)SSL_library_init();
- SSL_load_error_strings();
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- (void)atexit(ERR_free_strings);
-+#endif
-
- /*
- * In earlier versions, we called
diff --git a/net-mgmt/nsca-ng/pkg-descr b/net-mgmt/nsca-ng/pkg-descr
index 686c98a894aa..cba6c676c382 100644
--- a/net-mgmt/nsca-ng/pkg-descr
+++ b/net-mgmt/nsca-ng/pkg-descr
@@ -16,4 +16,4 @@ asynchronously written files.
NSCA clients cannot talk to NSCA-ng servers (nor vice versa), but NSCA
and NSCA-ng servers can happily run side by side.
-WWW: http://www.nsca-ng.org/
+WWW: https://github.com/weiss/nsca-ng