aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:32:26 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:32:26 +0000
commit56a276bcb592def6d3ac8b2f16125ad9785cf703 (patch)
tree6e8ca08efd8d80b0d4916b338ca901095277d97b /net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
parent159ab3967ccc82309b1bd90d4fe010ad373979a0 (diff)
downloadports-56a276bcb592def6d3ac8b2f16125ad9785cf703.tar.gz
ports-56a276bcb592def6d3ac8b2f16125ad9785cf703.zip
Nagios::Plugins::Memcached - Nagios plugin to observe memcached.
WWW: http://search.cpan.org/dist/Nagios-Plugins-Memcached/ PR: ports/118907 Submitted by: Philip M. Gollucci <pgollucci@p6m7g8.com> Approved by: itetcu (mentor, implicit)
Notes
Notes: svn path=/head/; revision=207462
Diffstat (limited to 'net-mgmt/p5-Nagios-Plugins-Memcached/Makefile')
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile b/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
new file mode 100644
index 000000000000..4352dfac79fd
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Nagios-Plugins-Memcached
+# Date created: 18 Dec 2007
+# Whom: Philp M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nagios-Plugins-Memcached
+PORTVERSION= 0.02
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/Z/ZI/ZIGOROU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@p6m7g8.com
+COMMENT= Module to check memcached via nagios
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS+= ${SITE_PERL}/Nagios/Plugin.pm:${PORTSDIR}/net-mgmt/p5-Nagios-Plugin \
+ ${SITE_PERL}/Cache/Memcached.pm:${PORTSDIR}/databases/p5-Cache-Memcached \
+ ${SITE_PERL}/Carp/Clan.pm:${PORTSDIR}/devel/p5-Carp-Clan
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Nagios::Plugins::Memcached.3
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${LOCALBASE}/libexec/nagios
+ ${INSTALL} ${WRKSRC}/bin/check_memcached ${LOCALBASE}/libexec/nagios/check_memcached
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>