aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Net-IP
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2009-08-14 20:12:39 +0000
committerDoug Barton <dougb@FreeBSD.org>2009-08-14 20:12:39 +0000
commit9b1119296b7004dcb1170de544c0a8f2cd5ba569 (patch)
tree99b21034c96caa97d7a7d3bb06094532746eccd1 /net-mgmt/p5-Net-IP
parent1526b0a3bed731bc99c55a9e5b99e7900c679c20 (diff)
downloadports-9b1119296b7004dcb1170de544c0a8f2cd5ba569.tar.gz
ports-9b1119296b7004dcb1170de544c0a8f2cd5ba569.zip
Apply a patch to make the ipcount script work.
Without the attached patch ipcount generates the following when using the -d option: ipcount -d 24 192.168.0.0/20 Invalid chars in IP 192.168.0.0+255 at /usr/local/bin/ipcount line 83. Take over maintainership of the port since the original mail to lth about this issue was back in March and I've had no reply to that mail or to the PR. PR: ports/137314 Submitted by: dougb Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=239565
Diffstat (limited to 'net-mgmt/p5-Net-IP')
-rw-r--r--net-mgmt/p5-Net-IP/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-mgmt/p5-Net-IP/Makefile b/net-mgmt/p5-Net-IP/Makefile
index b44c96a23fc9..a1891aea8fe0 100644
--- a/net-mgmt/p5-Net-IP/Makefile
+++ b/net-mgmt/p5-Net-IP/Makefile
@@ -7,11 +7,12 @@
PORTNAME= Net-IP
PORTVERSION= 1.25
+PORTREVISION= 1
CATEGORIES= net-mgmt perl5 ipv6
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= lth@FreeBSD.org
+MAINTAINER= dougb@FreeBSD.org
COMMENT= Perl extension for manipulating IPv4/IPv6 addresses
RUN_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
@@ -24,4 +25,9 @@ MAN3= Net::IP.3
post-configure:
${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/Makefile
+post-patch:
+ @${CP} ${WRKSRC}/IP.pm ${WRKSRC}/IP.pm.presed
+ @${SED} -e "1853s#\\s+#\s*#g" ${WRKSRC}/IP.pm.presed > \
+ ${WRKSRC}/IP.pm
+
.include <bsd.port.mk>