aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pmacct
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-03-21 19:51:33 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-03-21 19:51:33 +0000
commiteb09736c24ed1d717f117de7bb32aa67efd1805c (patch)
treea7399e1225f346a1fd7fa42da7e637eec6f5a8a6 /net-mgmt/pmacct
parentc4fca44453de2e9ecbc6a8abf96f134a168f1257 (diff)
downloadports-eb09736c24ed1d717f117de7bb32aa67efd1805c.tar.gz
ports-eb09736c24ed1d717f117de7bb32aa67efd1805c.zip
net-mgmt/pmacct: provide plabel configure flags if option is selected
Notes
Notes: svn path=/head/; revision=436630
Diffstat (limited to 'net-mgmt/pmacct')
-rw-r--r--net-mgmt/pmacct/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index dd08fcbd3c97..1ccd2a88cabc 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -83,6 +83,12 @@ CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ARGS+=--disable-ipv6
.endif
+.if ${PORT_OPTIONS:MPLABEL}
+CONFIGURE_ARGS+=--enable-plabel
+.else
+CONFIGURE_ARGS+=--disable-plabel
+.endif
+
.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+=--enable-threads
.else
@@ -93,9 +99,11 @@ CONFIGURE_ARGS+=--disable-threads
CONFIGURE_ARGS+=--enable-debug
.endif
-#.if ${PORT_OPTIONS:MMONGO}
+.if ${PORT_OPTIONS:MMONGO}
#CONFIGURE_ARGS+=--enable-mongodb
-#.endif
+.else
+CONFIGURE_ARGS+=--disable-mongodb
+.endif
.if ${PORT_OPTIONS:MRABBITMQ}
.if ${PORT_OPTIONS:MJANSSON}
@@ -127,13 +135,13 @@ LIB_DEPENDS+= libavro.so:devel/avro-c
CONFIGURE_ARGS+=--enable-avro
.endif
-#.if ${PORT_OPTIONS:MNFLOG}
+.if ${PORT_OPTIONS:MNFLOG}
#CONFIGURE_ARGS+=--enable-nflog
#PLIST_SUB+=WITH_NFLOG=""
-#.else
+.else
CONFIGURE_ARGS+=--disable-nflog
PLIST_SUB+=WITH_NFLOG="@comment "
-#.endif
+.endif
.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= libGeoIP.so:net/GeoIP