aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/riemann
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-11-11 05:53:44 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-11-11 05:53:44 +0000
commit6b071f4df73cda2c2dd4a675f0c10cfedc7a6070 (patch)
tree1b224f0f5a33ae68c978a2c2fc3d58a80c209fbf /net-mgmt/riemann
parentbf05b4a6ea27a6acbd3714708ed61259895864b7 (diff)
downloadports-6b071f4df73cda2c2dd4a675f0c10cfedc7a6070.tar.gz
ports-6b071f4df73cda2c2dd4a675f0c10cfedc7a6070.zip
net-mgmt/riemann: several changes to the port itself
- fix reload under daemon(8) using pkill - use new upstream master site - add conf.d for more complex configurations - add named daemon(8) process info PR: 212671 Submitted by: Dave Cottlehuber <dch@skunkwerks.at> (maintainer)
Notes
Notes: svn path=/head/; revision=425861
Diffstat (limited to 'net-mgmt/riemann')
-rw-r--r--net-mgmt/riemann/Makefile5
-rw-r--r--net-mgmt/riemann/distinfo1
-rw-r--r--net-mgmt/riemann/files/riemann.in9
-rw-r--r--net-mgmt/riemann/pkg-plist1
4 files changed, 12 insertions, 4 deletions
diff --git a/net-mgmt/riemann/Makefile b/net-mgmt/riemann/Makefile
index 4db143fc3126..ac99b8ce889d 100644
--- a/net-mgmt/riemann/Makefile
+++ b/net-mgmt/riemann/Makefile
@@ -3,9 +3,9 @@
PORTNAME= riemann
PORTVERSION= 0.2.11
+PORTREVISION= 1
CATEGORIES= net-mgmt java
-MASTER_SITES= https://wintermute.skunkwerks.at/${PORTNAME}/releases/${PORTVERSION}/ \
- http://aphyr.com/${PORTNAME}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
MAINTAINER= dch@skunkwerks.at
COMMENT= Monitors distributed systems
@@ -50,6 +50,7 @@ do-install:
${MKDIR} \
${STAGEDIR}${JAVAJARDIR} \
${STAGEDIR}${ETCDIR} \
+ ${STAGEDIR}${ETCDIR}/conf.d \
${STAGEDIR}${RIEMANN_LOGDIR}
${INSTALL_DATA} \
${WRKSRC}/lib/${PORTNAME}.jar \
diff --git a/net-mgmt/riemann/distinfo b/net-mgmt/riemann/distinfo
index ae42050744aa..e789dc4d52bf 100644
--- a/net-mgmt/riemann/distinfo
+++ b/net-mgmt/riemann/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1473805695
SHA256 (riemann-0.2.11.tar.bz2) = 5e7982002685f6fa7716782c57e227e4b4eeaa4c14a77ab586aac5ecf114e933
SIZE (riemann-0.2.11.tar.bz2) = 40503519
diff --git a/net-mgmt/riemann/files/riemann.in b/net-mgmt/riemann/files/riemann.in
index 6c833aa2cd99..73b53f07bc93 100644
--- a/net-mgmt/riemann/files/riemann.in
+++ b/net-mgmt/riemann/files/riemann.in
@@ -56,7 +56,7 @@ load_rc_config $name
pidfile="%%RIEMANN_PIDFILE%%"
command="/usr/sbin/daemon"
-command_args="-f -c -r -P ${pidfile} \
+command_args="-f -t ${name} -c -r -P ${pidfile} \
${riemann_java_home}/bin/java \
${riemann_java_opts} \
-jar ${riemann_jarfile} ${riemann_config}"
@@ -66,6 +66,11 @@ riemann_prestart()
{
install -o ${riemann_user} /dev/null ${pidfile}
}
-start_precmd=${name}_prestart
+start_precmd="${name}_prestart"
+
+# support SIGHUP to reload config file using pkill. parent pid
+# is that of daemon(8) and not of riemann's JVM instance
+extra_commands="reload"
+reload_cmd="pkill -SIGHUP -U ${riemann_user} -G ${riemann_group} -f Dapp=riemann"
run_rc_command "$1"
diff --git a/net-mgmt/riemann/pkg-plist b/net-mgmt/riemann/pkg-plist
index 539ec01e64d6..a9fd6e23292e 100644
--- a/net-mgmt/riemann/pkg-plist
+++ b/net-mgmt/riemann/pkg-plist
@@ -1,3 +1,4 @@
%%JAVAJARDIR%%/riemann.jar
@sample %%ETCDIR%%/riemann.config.sample
@dir(%%RIEMANN_USER%%,%%RIEMANN_GROUP%%,0750) %%RIEMANN_LOGDIR%%
+@dir(%%RIEMANN_USER%%,%%RIEMANN_GROUP%%,0750) %%ETCDIR%%/conf.d