aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/seafile-server/Makefile
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-01-27 03:23:40 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-01-27 03:23:40 +0000
commit7e06e3a3a7552471f24a83a73f3e50db7cadcda0 (patch)
treed47824cb5a59224f6bee4e77d1bb710210bc1608 /net-mgmt/seafile-server/Makefile
parent48f70e76d8e8e856e6e3fb945a073f9f7d0efecc (diff)
downloadports-7e06e3a3a7552471f24a83a73f3e50db7cadcda0.tar.gz
ports-7e06e3a3a7552471f24a83a73f3e50db7cadcda0.zip
net-mgmt/seafile-server - bugfixes
This is a bug fix release update. stat command call with incorrect options has been fixed to work on *bsd. Readded the sqlite scripts to run seafile under sqlite. Previously they were removed due to being broken, this was fixed upstream. * PORTREVISION bump * Added sqlite scripts * Fixed stat PR: 216474 Submitted by: ultima1252@gmail.com (maintainer) Reviewed by: matthew Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D9350
Notes
Notes: svn path=/head/; revision=432545
Diffstat (limited to 'net-mgmt/seafile-server/Makefile')
-rw-r--r--net-mgmt/seafile-server/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index 314e96bf3c36..f558a3afe5b6 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -4,6 +4,7 @@ PORTNAME= seafile-server
PORTVERSION= 6.0.7
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -server
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= ultima1252@gmail.com
@@ -93,6 +94,7 @@ post-patch:
${WRKSRC}/scripts/seaf-cli-wrapper.sh
${REINPLACE_CMD} 's/<evhtp.h>/<evhtp\/evhtp.h>/' ${WRKSRC}/server/upload-file.c \
${WRKSRC}/server/access-file.c ${WRKSRC}/server/http-server.c
+ ${REINPLACE_CMD} -E 's/stat.+\$$/stat -f %Su $$/' ${WRKSRC}/scripts/seafile.sh
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${SEABIN} ${STAGEDIR}${PREFIX}/${SEALIB} \
${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/seafile/share/doc/seafile \
@@ -111,8 +113,6 @@ post-install:
(cd ${STAGEDIR}${PREFIX}/lib && \
${COPYTREE_SHARE} ${PYTHON_VERSION} ${STAGEDIR}${PREFIX}/${SEALIB})
@${RM} -rf ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION} \
- ${WRKSRC}/scripts/sqlite2mysql.[ps][yh] \
- ${WRKSRC}/scripts/setup-seafile.sh \
${STAGEDIR}${PREFIX}/bin/seafile-admin
${INSTALL_SCRIPT} ${WRKSRC}/scripts/*.[ps][yh] ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}
${INSTALL_SCRIPT} ${WRKSRC}/scripts/upgrade/*.[ps][yh] \