aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/seafile-server/Makefile
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2021-02-01 02:26:28 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2021-02-01 02:26:28 +0000
commitdae6c0bb079336edab81eb1b2d919aa0c3124120 (patch)
treee0806fb35904833979e394c3945abd802f0e0e85 /net-mgmt/seafile-server/Makefile
parentc9b55bd9c90bc84d956679a47291a0342bec5d1e (diff)
downloadports-dae6c0bb079336edab81eb1b2d919aa0c3124120.tar.gz
ports-dae6c0bb079336edab81eb1b2d919aa0c3124120.zip
Updated Seafile/Seahub to 8.0.3
Changed to -server branch, some errors were creeping over from the pro version not being compatible with the community edition. Previously this was never an issue as you must manually upgrade to the pro version for the new features. Disabled seafile-controller config checking prior to startup. The check only ran on ccnet previously and this was changed to seafile which never implemented the function. https://forum.seafile.com/t/seafile-controller-t-functionality-broken-on-8-x/13738 This version adds compatible with Django 2.2, this will require coordination with multiple port devs to migrate this over properly. Changes: https://manual.seafile.com/changelog/server-changelog/ PR: 252715
Notes
Notes: svn path=/head/; revision=563541
Diffstat (limited to 'net-mgmt/seafile-server/Makefile')
-rw-r--r--net-mgmt/seafile-server/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index 00e77b703131..680452860a05 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -4,7 +4,6 @@ PORTNAME= seafile-server
DISTVERSIONPREFIX= v
DISTVERSION= ${SEAFILE_VER}
DISTVERSIONSUFFIX= -server
-PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= ultima@FreeBSD.org
@@ -19,7 +18,6 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libzdb.so:databases/libzdb \
libcurl.so:ftp/curl \
libinotify.so:devel/libinotify \
- libccnet.so:net-mgmt/ccnet-server \
libevent.so:devel/libevent \
libuuid.so:misc/e2fsprogs-libuuid \
libjansson.so:devel/jansson \
@@ -79,7 +77,7 @@ post-patch:
${REINPLACE_CMD} 's/python3\.[0-9]/${PYTHON_VERSION}/g; s/python3 /${PYTHON_VERSION} / ; \
s/PYTHON=python3/PYTHON=${PYTHON_VERSION}/' \
${WRKSRC}/controller/seafile-controller.c ${WRKSRC}/scripts/reset-admin.sh \
- ${WRKSRC}/scripts/upgrade/upgrade_7.0_7.1.sh \
+ ${WRKSRC}/scripts/upgrade/upgrade_[7-9].[0-9]_[7-9].[0-9].sh \
${WRKSRC}/scripts/seahub.sh ${WRKSRC}/scripts/setup-seafile.sh \
${WRKSRC}/scripts/setup-seafile-mysql.sh \
${WRKSRC}/scripts/setup-seafile-mysql.py
@@ -127,7 +125,7 @@ post-install:
${COPYTREE_SHARE} "sql upgrade/sql" ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER})
makesum-all:
-.for PORT in net-mgmt/ccnet-server net-mgmt/seafile-server www/py-seafdav www/py-seafobj www/seahub
+.for PORT in net-mgmt/seafile-server www/py-seafdav www/py-seafobj www/seahub
${MAKE} -C "${PORTSDIR}/${PORT}" makesum
.endfor