aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/send
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-08-20 17:56:58 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-08-20 17:56:58 +0000
commitc3159c5b1f68f22e79f7cd93b669402fba1302e1 (patch)
tree67b83ac7d8dc1d6563188e6c862d5127e130baea /net-mgmt/send
parent4c48040b0d78d6a595936d17e90c4a3e019f6c0c (diff)
downloadports-c3159c5b1f68f22e79f7cd93b669402fba1302e1.tar.gz
ports-c3159c5b1f68f22e79f7cd93b669402fba1302e1.zip
Resurrect net-mgmt/send and fix build errors.
Notes
Notes: svn path=/head/; revision=365494
Diffstat (limited to 'net-mgmt/send')
-rw-r--r--net-mgmt/send/Makefile53
-rw-r--r--net-mgmt/send/distinfo2
-rw-r--r--net-mgmt/send/files/patch-Makefile.install15
-rw-r--r--net-mgmt/send/files/patch-include-cga_keyutils.h12
-rw-r--r--net-mgmt/send/files/patch-include-pkixip_ext_asn.h13
-rw-r--r--net-mgmt/send/files/patch-libs-Makefile.lib.common9
-rw-r--r--net-mgmt/send/files/patch-sendd-Makefile13
-rw-r--r--net-mgmt/send/files/patch-sendd-os-Makefile18
-rw-r--r--net-mgmt/send/files/pkg-message.in5
-rw-r--r--net-mgmt/send/files/sendd.in14
-rw-r--r--net-mgmt/send/pkg-descr14
-rw-r--r--net-mgmt/send/pkg-plist8
12 files changed, 176 insertions, 0 deletions
diff --git a/net-mgmt/send/Makefile b/net-mgmt/send/Makefile
new file mode 100644
index 000000000000..898b768b7160
--- /dev/null
+++ b/net-mgmt/send/Makefile
@@ -0,0 +1,53 @@
+# Created by: Janos Mohacsi <mohacsi@niif.hu>
+# $FreeBSD$
+
+PORTNAME= send
+PORTVERSION= 0.3
+PORTREVISION= 1
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= hrs
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Secure Neighbor Discovery implementation for IPv6
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libdnet.so:${PORTSDIR}/net/libdnet
+
+USES= gmake readline
+USE_RC_SUBR= sendd
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PORTDOCS= README UserGuide.pdf
+MAKE_JOBS_UNSAFE=yes
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900042
+IGNORE= is supported only on 9.0 and later
+.endif
+
+post-extract:
+ ${INSTALL_DATA} ${WRKSRC}/examples/ipext/ipext_verify.conf \
+ ${WRKSRC}/examples/ipext/ca/ipext.conf \
+ ${WRKSRC}/examples/
+ ${INSTALL_DATA} ${WRKSRC}/docs/UserGuide.pdf \
+ ${WRKSRC}/UserGuide.pdf
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/sendd
+ for F in sendd.conf params.conf ipext.conf ipext_verify.conf; do \
+ ${INSTALL_DATA} ${WRKSRC}/examples/$$F \
+ ${STAGEDIR}${PREFIX}/etc/sendd/$${F}-dist; \
+ done
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/send/distinfo b/net-mgmt/send/distinfo
new file mode 100644
index 000000000000..00774ec1ad09
--- /dev/null
+++ b/net-mgmt/send/distinfo
@@ -0,0 +1,2 @@
+SHA256 (send_0.3.tar.gz) = abe217c24f8f711124da74eb24342ee27a195e8102bed3e60d426607532ff76b
+SIZE (send_0.3.tar.gz) = 1272983
diff --git a/net-mgmt/send/files/patch-Makefile.install b/net-mgmt/send/files/patch-Makefile.install
new file mode 100644
index 000000000000..471850f48296
--- /dev/null
+++ b/net-mgmt/send/files/patch-Makefile.install
@@ -0,0 +1,15 @@
+--- Makefile.install.orig 2010-08-28 17:58:05.000000000 +0900
++++ Makefile.install 2014-08-20 04:27:44.000000000 +0900
+@@ -1,9 +1,9 @@
+-INSSBIN= $(PREFIXSBIN)/$(PROG)
++INSSBIN= $(DESTDIR)$(PREFIXSBIN)/$(PROG)
+
+ $(INSSBIN): $(PROG)
+- install $< $@
++ $(BSD_INSTALL_PROGRAM) $< $@
+
+-install: all $(PREFIXSBIN) $(INSSBIN) $(EXTRAINSTALL)
++install: all $(DESTDIR)$(PREFIXSBIN) $(INSSBIN) $(DESTDIR)$(EXTRAINSTALL)
+
+ $(PREFIXSBIN):
+ mkdir -p $@
diff --git a/net-mgmt/send/files/patch-include-cga_keyutils.h b/net-mgmt/send/files/patch-include-cga_keyutils.h
new file mode 100644
index 000000000000..4b7465e08f98
--- /dev/null
+++ b/net-mgmt/send/files/patch-include-cga_keyutils.h
@@ -0,0 +1,12 @@
+--- include/cga_keyutils.h.orig 2014-08-20 04:17:35.000000000 +0900
++++ include/cga_keyutils.h 2014-08-20 04:17:58.000000000 +0900
+@@ -36,6 +36,9 @@
+ #include <openssl/x509.h>
+ #include <openssl/evp.h>
+ #include <openssl/stack.h>
++#ifndef STACK
++#define STACK _STACK
++#endif
+ #include <cga.h>
+
+ extern int cga_add_key(cga_ctx_t *, EVP_PKEY *, int, uint16_t);
diff --git a/net-mgmt/send/files/patch-include-pkixip_ext_asn.h b/net-mgmt/send/files/patch-include-pkixip_ext_asn.h
new file mode 100644
index 000000000000..145fcd909d5f
--- /dev/null
+++ b/net-mgmt/send/files/patch-include-pkixip_ext_asn.h
@@ -0,0 +1,13 @@
+--- include/pkixip_ext_asn.h.orig 2014-08-20 04:16:53.000000000 +0900
++++ include/pkixip_ext_asn.h 2014-08-20 04:17:09.000000000 +0900
+@@ -33,6 +33,10 @@
+ #ifndef _PKIXIP_EXT_ASN_H
+ #define _PKIXIP_EXT_ASN_H
+
++#include <openssl/stack.h>
++#ifndef STACK
++#define STACK _STACK
++#endif
+ #include <openssl/asn1t.h>
+ #include <openssl/err.h>
+ #include <openssl/x509v3.h>
diff --git a/net-mgmt/send/files/patch-libs-Makefile.lib.common b/net-mgmt/send/files/patch-libs-Makefile.lib.common
new file mode 100644
index 000000000000..f46f98d161b8
--- /dev/null
+++ b/net-mgmt/send/files/patch-libs-Makefile.lib.common
@@ -0,0 +1,9 @@
+--- libs/Makefile.lib.common.orig 2014-08-20 04:21:08.000000000 +0900
++++ libs/Makefile.lib.common 2014-08-20 04:21:27.000000000 +0900
+@@ -1,5 +1,5 @@
+
+-CFLAGS += -Wall -O3
++CFLAGS?= -Wall -O3
+
+ ifeq ($(DEBUG_POLICY),DEBUG)
+ CPPFLAGS += -g # enable for general debugging
diff --git a/net-mgmt/send/files/patch-sendd-Makefile b/net-mgmt/send/files/patch-sendd-Makefile
new file mode 100644
index 000000000000..3f45c41efe36
--- /dev/null
+++ b/net-mgmt/send/files/patch-sendd-Makefile
@@ -0,0 +1,13 @@
+--- sendd/Makefile.orig 2014-08-20 04:19:01.000000000 +0900
++++ sendd/Makefile 2014-08-20 04:19:39.000000000 +0900
+@@ -6,8 +6,8 @@
+ sendd.o sigmeth.o sig_rfc3971.o
+ INC= sendd_local.h snd_proto.h snd_config.h
+
+-CFLAGS= -Wall -O3
+-CPPFLAGS= -I../include -I../../src/sys
++CFLAGS?= -Wall -O3
++CPPFLAGS+= -I../include -I../../src/sys
+ YFLAGS= -d -p params_
+ LFLAGS= -Pparams_
+
diff --git a/net-mgmt/send/files/patch-sendd-os-Makefile b/net-mgmt/send/files/patch-sendd-os-Makefile
new file mode 100644
index 000000000000..601bca0ac4bf
--- /dev/null
+++ b/net-mgmt/send/files/patch-sendd-os-Makefile
@@ -0,0 +1,18 @@
+--- sendd/os/Makefile.orig 2010-08-28 17:58:04.000000000 +0900
++++ sendd/os/Makefile 2014-08-20 04:33:33.000000000 +0900
+@@ -1,13 +1,5 @@
+
+ OBJS += os/addr.o os/snd_freebsd.o os-linux/rand.o
+-CPPFLAGS += -I/usr/local/include
+-
+-OSLIBS= -L/usr/local/lib -l$(DNET)
+-
+-OSEXTRA= os/sendd
+-EXTRAINSTALL= /usr/local/etc/rc.d/sendd
+-EXTRAUNINSTALL=$(EXTRAINSTALL)
+-
+-/usr/local/etc/rc.d/%: os/%
+- install $< $@
++CPPFLAGS += -I${LOCALBASE}/include
+
++OSLIBS= -L${LOCALBASE}/lib -l$(DNET)
diff --git a/net-mgmt/send/files/pkg-message.in b/net-mgmt/send/files/pkg-message.in
new file mode 100644
index 000000000000..3191d44b9680
--- /dev/null
+++ b/net-mgmt/send/files/pkg-message.in
@@ -0,0 +1,5 @@
+-------------------------------------------------------------------------------
+To run sendd from startup, add sendd_enable="YES"
+in your /etc/rc.conf.
+Configiration options can be found in %%PREFIX%%/etc/sendd
+-------------------------------------------------------------------------------
diff --git a/net-mgmt/send/files/sendd.in b/net-mgmt/send/files/sendd.in
new file mode 100644
index 000000000000..533ace60f0fb
--- /dev/null
+++ b/net-mgmt/send/files/sendd.in
@@ -0,0 +1,14 @@
+# $FreeBSD$
+#
+# PROVIDE sendd
+# REQUIRE NETWORKING
+
+. /etc/rc.subr
+
+name=sendd
+rcvar="${name}_enable"
+command="%%PREFIX%%/sbin/$name"
+required_files="%%PREFIX%%/etc/${name}/${name}.conf"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net-mgmt/send/pkg-descr b/net-mgmt/send/pkg-descr
new file mode 100644
index 000000000000..c0ea7d33747a
--- /dev/null
+++ b/net-mgmt/send/pkg-descr
@@ -0,0 +1,14 @@
+SEND is the implementation of RFC3971 Secure Neighbor Discovery
+(SEND). SEND cryptographically secures the IPv6 neighbor discovery
+protocol, countering the threats discussed in RFC3756 (IPv6 Neighbor
+Discovery (ND) Trust Models and Threats).
+
+The implementation is a new version of DoCoMo's SEND (send_0.2) that
+was implemented completely in user space. Novelty in send_0.3 is the
+native SEND API that avoids the need for the use of netgraph and BPF,
+which makes send_0.3 portable over different BSD platforms and
+significantlly more efficient.
+
+Also included in the distribution are implementations of RFC3972
+Cryptographically Generated Addresses (CGAs) and RFC3779 X.509
+Extensions for IP Addresses and AS Identifiers.
diff --git a/net-mgmt/send/pkg-plist b/net-mgmt/send/pkg-plist
new file mode 100644
index 000000000000..f1a2654ac412
--- /dev/null
+++ b/net-mgmt/send/pkg-plist
@@ -0,0 +1,8 @@
+sbin/cgatool
+sbin/ipexttool
+sbin/sendd
+etc/sendd/sendd.conf-dist
+etc/sendd/params.conf-dist
+etc/sendd/ipext.conf-dist
+etc/sendd/ipext_verify.conf-dist
+@dirrmtry etc/sendd