aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/sysmon
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 18:27:44 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 18:45:16 +0000
commit63869654cb0293fa588e5d0a0346fc89629a8346 (patch)
tree56fc30209c0aa6e7201d1d6eeefac6816289e158 /net-mgmt/sysmon
parent06ba005bc58fcaece016f7a3b8542b12d8166a55 (diff)
downloadports-63869654cb0293fa588e5d0a0346fc89629a8346.tar.gz
ports-63869654cb0293fa588e5d0a0346fc89629a8346.zip
net-mgmt/sysmon: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'net-mgmt/sysmon')
-rw-r--r--net-mgmt/sysmon/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-mgmt/sysmon/Makefile b/net-mgmt/sysmon/Makefile
index ac4dd1f64942..cba5b6485a22 100644
--- a/net-mgmt/sysmon/Makefile
+++ b/net-mgmt/sysmon/Makefile
@@ -11,9 +11,10 @@ WWW= https://puck.nether.net/sysmon/
LICENSE= GPLv2
-GNU_CONFIGURE= yes
USES= alias ssl
+GNU_CONFIGURE= yes
+
OPTIONS_DEFINE= DOCS
DOCS= Changes.html binaries.html config.html docs.html index.html \
@@ -21,6 +22,12 @@ DOCS= Changes.html binaries.html config.html docs.html index.html \
sysmon.man.html reporting.xml-spec.txt
MANPAGE= sysmon.man.8 sysmon.conf.man.8
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/sysmon ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/sysmond ${STAGEDIR}${PREFIX}/bin
@@ -30,6 +37,8 @@ do-install:
.for man in ${MANPAGE}
${INSTALL_MAN} ${WRKSRC}/docs/${man:S/.8//} ${STAGEDIR}${MANPREFIX}/man/man8/${man}
.endfor
+
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/docs/${doc} ${STAGEDIR}${DOCSDIR}