aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/tcpreplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-12 21:01:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-12 21:02:13 +0000
commit30d37dceedd9b3a75e25a45a8ae584925dcc222a (patch)
tree62a1914528c1bc875c8ab374a93826133eb9d779 /net-mgmt/tcpreplay
parentb904062e277f750c3a12b9a8cd8af97c3230fbe4 (diff)
downloadports-30d37dceedd9b3a75e25a45a8ae584925dcc222a.tar.gz
ports-30d37dceedd9b3a75e25a45a8ae584925dcc222a.zip
net-mgmt/tcpreplay: Update to 4.4.1
- Update to 4.4.1 - Use upstream release archive - Partially fix "make test" PR: 261738
Diffstat (limited to 'net-mgmt/tcpreplay')
-rw-r--r--net-mgmt/tcpreplay/Makefile17
-rw-r--r--net-mgmt/tcpreplay/distinfo6
-rw-r--r--net-mgmt/tcpreplay/files/patch-Makefile.in11
3 files changed, 21 insertions, 13 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 1e2f749525ee..65ab1c9f6489 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -1,9 +1,9 @@
# Created by: cnh@ivmg.net
PORTNAME= tcpreplay
-PORTVERSION= 4.4.0
-DISTVERSIONPREFIX= v
+DISTVERSION= 4.4.1
CATEGORIES= net-mgmt
+MASTER_SITES= https://github.com/appneta/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Tool to replay saved packet capture files
@@ -14,14 +14,15 @@ BUILD_DEPENDS= pcapnav-config:net/libpcapnav
LIB_DEPENDS= libdnet.so:net/libdnet \
libopts.so:devel/autogen
-USES= autoreconf cpe gmake libtool pkgconfig
+USES= cpe gmake libtool pkgconfig tar:xz
CPE_VENDOR= appneta
-USE_GITHUB= yes
-GH_ACCOUNT= appneta
GNU_CONFIGURE= yes
+# libopts options are required when using autogen
CONFIGURE_ARGS= --program-transform-name='s|.*\(tcp.*\)|\1|' \
- --with-pcapnav-config=${LOCALBASE}/bin/pcapnav-config
+ --with-pcapnav-config=${LOCALBASE}/bin/pcapnav-config \
+ --disable-libopts-install \
+ --disable-local-libopts
TEST_TARGET= test
@@ -29,10 +30,6 @@ OPTIONS_DEFAULT= LIBPCAP_BASE
OPTIONS_SINGLE= LIBPCAP
OPTIONS_SINGLE_LIBPCAP= LIBPCAP_BASE LIBPCAP_PORTS
-# required when using autogen
-CONFIGURE_ARGS+= --disable-libopts-install \
- --disable-local-libopts
-
LIBPCAP_BASE_DESC= Build with libpcap from the base OS
LIBPCAP_PORTS_DESC= Build with net/libpcap
diff --git a/net-mgmt/tcpreplay/distinfo b/net-mgmt/tcpreplay/distinfo
index ad3ec383b481..6c4a17b42d2d 100644
--- a/net-mgmt/tcpreplay/distinfo
+++ b/net-mgmt/tcpreplay/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643654497
-SHA256 (appneta-tcpreplay-v4.4.0_GH0.tar.gz) = b54f5dcc866556b1f581318fb9e01f8a749f3272f769a4b7312e408f804c7de3
-SIZE (appneta-tcpreplay-v4.4.0_GH0.tar.gz) = 3735129
+TIMESTAMP = 1644698816
+SHA256 (tcpreplay-4.4.1.tar.xz) = 51f70ed14be5913f19c25cdfa530e98c14cedab1c76fbdd26eca7b61b57344f2
+SIZE (tcpreplay-4.4.1.tar.xz) = 751036
diff --git a/net-mgmt/tcpreplay/files/patch-Makefile.in b/net-mgmt/tcpreplay/files/patch-Makefile.in
new file mode 100644
index 000000000000..2c1aeee9e5e1
--- /dev/null
+++ b/net-mgmt/tcpreplay/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2022-02-05 21:30:36 UTC
++++ Makefile.in
+@@ -892,7 +892,7 @@ autoopts:
+
+ test:
+ echo Making test in $(TEST_DIR)
+- cd $(TEST_DIR) && make test
++ cd $(TEST_DIR) && gmake test
+
+ dlt_names:
+ cat @SAVEFILE_C@ | $(top_builddir)/scripts/dlt2name.pl src/dlt_names.h