aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix54-frontend
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2022-01-27 20:18:17 +0000
committerJuraj Lutter <otis@FreeBSD.org>2022-01-27 20:34:29 +0000
commit2ef2ad9e861701a3a40718a52ebadd9202e84509 (patch)
tree79e6356bdf1996c1d41658eae88753ef82347f40 /net-mgmt/zabbix54-frontend
parenta24015553266c8f5e48e345856c8ae1bd04f30b8 (diff)
downloadports-2ef2ad9e861701a3a40718a52ebadd9202e84509.tar.gz
ports-2ef2ad9e861701a3a40718a52ebadd9202e84509.zip
net-mgmt/zabbix54-frontend: Build as php74-flavored only
As php 8.x is not supported with zabbix 5.x frontend, make it to only build with php 7.4 and convert to using flavors. And while here, also portfmt and portclippy a bit. Reported by: alexvpetrov@gmail.com
Diffstat (limited to 'net-mgmt/zabbix54-frontend')
-rw-r--r--net-mgmt/zabbix54-frontend/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-mgmt/zabbix54-frontend/Makefile b/net-mgmt/zabbix54-frontend/Makefile
index b70eaac36074..dad663b9a9fb 100644
--- a/net-mgmt/zabbix54-frontend/Makefile
+++ b/net-mgmt/zabbix54-frontend/Makefile
@@ -1,28 +1,28 @@
PORTNAME= zabbix54
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-mgmt
-PKGNAMESUFFIX= -frontend
+PKGNAMESUFFIX= -frontend${PHP_PKGNAMESUFFIX}
-MASTERDIR= ${.CURDIR}/../${PORTNAME}-server
+USES+= php:web,flavors
+USE_PHP= bcmath ctype dom fileinfo filter gd gettext hash json ldap \
+ mbstring openssl pcre session simplexml snmp sockets xml \
+ xmlreader xmlwriter
+IGNORE_WITH_PHP= 80 81
-NO_BUILD= yes
-NO_ARCH= yes
+MASTERDIR= ${.CURDIR}/../${PORTNAME}-server
PATCHDIR=
-PLIST= ${PKGDIR}/pkg-plist.frontend
+NO_ARCH= yes
+NO_BUILD= yes
-USE_PHP= bcmath ctype dom fileinfo filter gd gettext hash json ldap mbstring \
- openssl pcre session simplexml snmp sockets xml xmlreader xmlwriter
-USES+= php:web
+PLIST= ${PKGDIR}/pkg-plist.frontend
-OPTIONS_DEFINE= MYSQLI PGSQL ORACLE
+OPTIONS_DEFINE= MYSQLI ORACLE PGSQL
OPTIONS_DEFAULT= MYSQLI
MYSQLI_DESC= MySQLI backend
-MYSQLI_USE= PHP=mysqli
-
-PGSQL_USE= PHP=pgsql
-
+MYSQLI_USE= PHP=mysqli
ORACLE_CONFIGURE_WITH= oracle
+PGSQL_USE= PHP=pgsql
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}