aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-19 10:29:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-19 10:29:43 +0000
commit02b60cf0a7524f08a9e7e5856f5a8307bbf9b184 (patch)
tree407edb1458ddfd5d2d0253c0d068d66c79b759df /net-mgmt
parent3bd62c59ce7a7004f43ecdfe9e8e7e91b2bf6a1c (diff)
downloadports-02b60cf0a7524f08a9e7e5856f5a8307bbf9b184.tar.gz
ports-02b60cf0a7524f08a9e7e5856f5a8307bbf9b184.zip
Use CMAKE_BOOL, CMAKE_ON and CMAKE_OFF
Notes
Notes: svn path=/head/; revision=462292
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ettercap/Makefile32
1 files changed, 12 insertions, 20 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 05edbca0b99e..ce37559c1d4c 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -23,12 +23,12 @@ NCURSES_DESC= Ncurses interface
PCRE_DESC= Use PCRE in filters
SSL_DESC= SSH1 and SSL decryption support
-CMAKE_ARGS= -DBUNDLED_LIBS=OFF \
- -DHAVE_DLOPEN=ON \
- -DHAVE_PCAP=${LIBDIR} \
+CMAKE_ARGS= -DHAVE_PCAP=${LIBDIR} \
-DHAVE_RESOLV=${LIBDIR} \
-DINSTALL_SYSCONFDIR=${PREFIX}/etc \
-DMAN_INSTALLDIR=${PREFIX}/man
+CMAKE_OFF= BUNDLED_LIBS
+CMAKE_ON= HAVE_DLOPEN
LDFLAGS+= ${ICONV_LIB} -lnet -lpcap
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
@@ -43,31 +43,23 @@ CPE_VENDOR= ${PORTNAME}_project
GH_ACCOUNT= Ettercap
USE_GITHUB= yes
-DESKTOP_CMAKE_OFF= -DINSTALL_DESKTOP=OFF
-DESKTOP_CMAKE_ON= -DINSTALL_DESKTOP=ON
+DESKTOP_CMAKE_BOOL= INSTALL_DESKTOP
DESKTOP_USES= desktop-file-utils
-NCURSES_CMAKE_OFF= -DENABLE_CURSES=OFF
-NCURSES_CMAKE_ON= -DENABLE_CURSES=ON
+NCURSES_CMAKE_BOOL= ENABLE_CURSES
NCURSES_USES= ncurses
-GTK2_CMAKE_OFF= -DENABLE_GTK=OFF
-GTK2_CMAKE_ON= -DENABLE_GTK=ON
+GTK2_CMAKE_BOOL= ENABLE_GTK
GTK2_USE= GNOME=gtk20
GTK2_USES= gnome
-IPV6_CMAKE_OFF= -DENABLE_IPV6=OFF
-IPV6_CMAKE_ON= -DENABLE_IPV6=ON
-PCRE_CMAKE_OFF= -DHAVE_PCRE=OFF
-PCRE_CMAKE_ON= -DHAVE_PCRE=ON
+IPV6_CMAKE_BOOL= ENABLE_IPV6
+PCRE_CMAKE_BOOL= HAVE_PCRE
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PLUGINS_BUILD_DEPENDS= curl>=7.26.0:ftp/curl
-PLUGINS_CMAKE_OFF= -DENABLE_PLUGINS=OFF
-PLUGINS_CMAKE_ON= -DENABLE_PLUGINS=ON
+PLUGINS_CMAKE_BOOL= ENABLE_PLUGINS
PLUGINS_LIB_DEPENDS= libcurl.so:ftp/curl
-SSL_CMAKE_OFF= -DENABLE_SSL=OFF
-SSL_CMAKE_ON= -DENABLE_SSL=ON
+SSL_CMAKE_BOOL= ENABLE_SSL
SSL_USES= ssl
-UTF8_CMAKE_OFF= -DHAVE_UTF8=OFF
-UTF8_CMAKE_ON= -DHAVE_UTF8=ON \
- -DHAVE_ICONV=${ICONV_PREFIX}
+UTF8_CMAKE_BOOL= HAVE_UTF8
+UTF8_CMAKE_ON= -DHAVE_ICONV=${ICONV_PREFIX}
UTF8_USES= iconv
post-install: