aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-05 14:35:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-05 14:35:21 +0000
commit0f839cd669efa658f7a2b643cfd93385f3c9b5db (patch)
treeafa0bd430507230916023e9d9fa051bd565eaa38 /net-mgmt
parent124049d6c3e95473eb52386650ecf9608b62d578 (diff)
downloadports-0f839cd669efa658f7a2b643cfd93385f3c9b5db.tar.gz
ports-0f839cd669efa658f7a2b643cfd93385f3c9b5db.zip
Unbreak the build on Tier-2 architectures.
Tested on: flame (sparc64), pluto (ia64), local Mac mini G4 (powerpc)
Notes
Notes: svn path=/head/; revision=396176
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/spectools/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 08d702d33d70..f3e0415b8e12 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -15,10 +15,6 @@ COMMENT= Tools for the Wi-Spy spectrum analyzers from MetaGeek LLC
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL
-BROKEN_ia64= does not build: duplicate definition of malloc
-BROKEN_powerpc= does not build: duplicate definition of malloc
-BROKEN_sparc64= does not build: duplicate definition of malloc
-
USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -35,6 +31,15 @@ GTK2_ALL_TARGET= spectool_gtk
GTK2_USE= GNOME=gtk20
NCURSES_ALL_TARGET= spectool_curses
+post-patch:
+# Provide the prototype for malloc(3)
+ @${REINPLACE_CMD} -e '/<pthread\.h>/ \
+ { x; s/.*/#include <stdlib.h>/; G; }' \
+ ${WRKSRC}/ubertooth_hw_u1.c \
+ ${WRKSRC}/wispy_hw_24x.c \
+ ${WRKSRC}/wispy_hw_dbx.c \
+ ${WRKSRC}/wispy_hw_gen1.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${STAGEDIR}/${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${STAGEDIR}/${PREFIX}/bin