aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
commit34fa6c853efa04ca648d3d4187d4aec40a00fc0d (patch)
tree3445b3e9b6e7650fd127ec078394a0d7a8e79076 /net-mgmt
parentae2c26ad44dba87dd1377d70dfb1906132114c7b (diff)
downloadports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.tar.gz
ports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Notes
Notes: svn path=/head/; revision=127737
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios/Makefile2
-rw-r--r--net-mgmt/nagios12/Makefile2
-rw-r--r--net-mgmt/nagios2/Makefile2
-rw-r--r--net-mgmt/netsaint/Makefile3
-rw-r--r--net-mgmt/pmacct/Makefile2
-rw-r--r--net-mgmt/zabbix/Makefile2
-rw-r--r--net-mgmt/zabbix2/Makefile2
8 files changed, 8 insertions, 10 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 7419791fcb1b..4c1663f1fbf0 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -81,8 +81,7 @@ PLIST_SUB+= SUB_MYSQL="@comment "
.endif
.if defined(WITH_PGSQL)
-POSTGRESQL_PORT?=databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
PLIST_SUB+= SUB_PGSQL=""
.else
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 58d5af39282d..9c89111ae5b5 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/nagios12/Makefile b/net-mgmt/nagios12/Makefile
index 58d5af39282d..9c89111ae5b5 100644
--- a/net-mgmt/nagios12/Makefile
+++ b/net-mgmt/nagios12/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index 58d5af39282d..9c89111ae5b5 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/netsaint/Makefile b/net-mgmt/netsaint/Makefile
index 9328db12de78..c998c3c98de2 100644
--- a/net-mgmt/netsaint/Makefile
+++ b/net-mgmt/netsaint/Makefile
@@ -46,8 +46,7 @@ CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
.endif
.if defined(WITH_POSTGRES)
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/lib \
--with-pgsql-inc=${LOCALBASE}/include \
--with-pgsql-xdata
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index d33e30b2ec2b..bb35d9eef90a 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -23,7 +23,7 @@ PLIST_SUB+= WITH_MYSQL="@comment "
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--enable-pgsql
PLIST_SUB+= WITH_PGSQL=""
.else
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 347cfd271cf5..c5b62da6c941 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -45,8 +45,8 @@ IGNORE= You should configure to use either a MySQL or PostgreSQL backend
.endif
.ifdef(WITH_PGSQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
.endif
.ifndef(WITHOUT_MYSQL)
USE_MYSQL= yes
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 347cfd271cf5..c5b62da6c941 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -45,8 +45,8 @@ IGNORE= You should configure to use either a MySQL or PostgreSQL backend
.endif
.ifdef(WITH_PGSQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
.endif
.ifndef(WITHOUT_MYSQL)
USE_MYSQL= yes