aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2019-09-06 16:13:44 +0000
committerDan Langille <dvl@FreeBSD.org>2019-09-06 16:13:44 +0000
commit371f00fd5cace42d20928923c12666f79d03928a (patch)
treebb04cb16c2d9dcab917265f6f08250f52c6884e4 /net-mgmt
parente6f200df1385d2239152031e716add5b83a2a604 (diff)
downloadports-371f00fd5cace42d20928923c12666f79d03928a.tar.gz
ports-371f00fd5cace42d20928923c12666f79d03928a.zip
Unbreak by converting to GITLAB and a specfic commit.
The upstream project updates the tarball with hotfixes. This is why the distfile was unfetchable. Add LICENSE_FILE Take maintainership. I might soon regret this.
Notes
Notes: svn path=/head/; revision=511325
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagiosql/Makefile20
-rw-r--r--net-mgmt/nagiosql/distinfo6
-rw-r--r--net-mgmt/nagiosql/pkg-descr2
-rw-r--r--net-mgmt/nagiosql/pkg-plist2
4 files changed, 16 insertions, 14 deletions
diff --git a/net-mgmt/nagiosql/Makefile b/net-mgmt/nagiosql/Makefile
index b091ac31759a..98bb6f609499 100644
--- a/net-mgmt/nagiosql/Makefile
+++ b/net-mgmt/nagiosql/Makefile
@@ -3,16 +3,14 @@
PORTNAME= nagiosql
PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NagiosQL%20${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dvl@FreeBSD.org
COMMENT= Web based administration tool for Nagios
LICENSE= GPLv2
-
-BROKEN= unfetchable
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= nagios:net-mgmt/nagios \
${PEARDIR}/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR}
@@ -20,13 +18,17 @@ RUN_DEPENDS= nagios:net-mgmt/nagios \
USES= cpe gettext mysql php:web tar:bzip2
USE_PHP= filter gettext mysqli session simplexml
+USE_GITLAB= yes
+GL_ACCOUNT= wizonet
+GL_COMMIT= 0f1c063740b4d3dae98d74f293c53234f341b06e
+
USERS?= nagios
GROUPS?= nagios
NAGIOSUSER?= nagios
NO_BUILD= yes
NO_ARCH= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GL_COMMIT}-${GL_COMMIT}
SUB_FILES= pkg-message
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP} NAGIOSUSER=${NAGIOSUSER}
@@ -50,10 +52,10 @@ post-patch:
-e "s|nagiosql/etc/|${ETCDIR}/|" \
-e "s|>/etc/nagiosql|>${ETCDIR}|g" \
-e "s|>/etc/nagios/|>${LOCALBASE}/etc/nagios/|g" \
- ${WRKSRC}-${PORTVERSION}/install/sql/nagiosQL_v32_db_mysql.sql
+ ${WRKSRC}/install/sql/nagiosQL_v32_db_mysql.sql
${REINPLACE_CMD} -e "s|\"/etc/|\"${LOCALBASE}/etc/|" \
- ${WRKSRC}-${PORTVERSION}/install/install.php
+ ${WRKSRC}/install/install.php
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
@@ -65,6 +67,6 @@ do-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}/backup/hosts
@${MKDIR} ${STAGEDIR}${ETCDIR}/backup/services
@${MKDIR} ${STAGEDIR}${ETCDIR}/backup/ssh
- (cd ${WRKSRC}-${PORTVERSION} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} "! ( -name *\.orig -o -name *\.bak )")
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} "! ( -name *\.orig -o -name *\.bak )")
.include <bsd.port.mk>
diff --git a/net-mgmt/nagiosql/distinfo b/net-mgmt/nagiosql/distinfo
index a7aba7cc6304..db39312cf474 100644
--- a/net-mgmt/nagiosql/distinfo
+++ b/net-mgmt/nagiosql/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539089848
-SHA256 (nagiosql-3.4.0.tar.bz2) = b03a8ef59785cf52ec9cce152c49198a7ae2ac14c54120740d53df834156d403
-SIZE (nagiosql-3.4.0.tar.bz2) = 1032592
+TIMESTAMP = 1567783899
+SHA256 (wizonet-nagiosql-0f1c063740b4d3dae98d74f293c53234f341b06e_GL0.tar.gz) = 6de025f9cf79c199e0a6e37df76c82f0318e11f141f1dde603a74d9b1ba0ceea
+SIZE (wizonet-nagiosql-0f1c063740b4d3dae98d74f293c53234f341b06e_GL0.tar.gz) = 1466412
diff --git a/net-mgmt/nagiosql/pkg-descr b/net-mgmt/nagiosql/pkg-descr
index 123218aa42b7..2b95c3e41f95 100644
--- a/net-mgmt/nagiosql/pkg-descr
+++ b/net-mgmt/nagiosql/pkg-descr
@@ -3,4 +3,4 @@ It helps you to easily build a complex configuration with all options,
manage and use them. NagiosQL is based on a webserver with PHP, MySQL and
file access to the Nagios configuration files.
-WWW: https://sourceforge.net/projects/nagiosql/
+WWW: https://gitlab.com/wizonet/nagiosql
diff --git a/net-mgmt/nagiosql/pkg-plist b/net-mgmt/nagiosql/pkg-plist
index 30dfb479ef5a..dc237f1519f8 100644
--- a/net-mgmt/nagiosql/pkg-plist
+++ b/net-mgmt/nagiosql/pkg-plist
@@ -1,3 +1,4 @@
+%%WWWDIR%%/LICENSE
%%WWWDIR%%/admin.php
%%WWWDIR%%/admin/administration.php
%%WWWDIR%%/admin/alarming.php
@@ -106,7 +107,6 @@
%%WWWDIR%%/doc/CHANGELOG
%%WWWDIR%%/doc/INSTALLATION_deDE.txt
%%WWWDIR%%/doc/INSTALLATION_enGB.txt
-%%WWWDIR%%/doc/LICENSE
%%WWWDIR%%/doc/README_SSH_KEY
%%WWWDIR%%/favicon.ico
%%WWWDIR%%/functions/Autoloader.php