aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2013-08-10 17:00:46 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2013-08-10 17:00:46 +0000
commitae7f3b735c26055595d3482c2bb4267d3f6a4f75 (patch)
tree3e9b8fbf5d3cced4add44d2663e39e32757d915d /net-mgmt
parent317c75031ff7bcde21776b64f02dbbc21cfcae44 (diff)
downloadports-ae7f3b735c26055595d3482c2bb4267d3f6a4f75.tar.gz
ports-ae7f3b735c26055595d3482c2bb4267d3f6a4f75.zip
- Added new options NOTIFYDESKTOP and NOTIFYEMAIL
- Bump portrevision - BIND removed from default because depended by CURL option PR: ports/181103 Submitted by: Krzysztof Stryjek <ports@bsdserwis.com> Approved by: eadler (mentor)
Notes
Notes: svn path=/head/; revision=324556
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile19
-rw-r--r--net-mgmt/collectd/files/patch-src__Makefile.am13
-rw-r--r--net-mgmt/collectd/pkg-plist4
3 files changed, 28 insertions, 8 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index af7077684e17..2519a867633a 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 4.10.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -19,12 +19,12 @@ WANT_GNOME= yes
OPTIONS_DEFINE= CGI BIND DEBUG GCRYPT LIBVIRT
OPTIONS_GROUP= INPUT OUTPUT
-OPTIONS_GROUP_OUTPUT= RRDTOOL RRDCACHED WRITE_HTTP NOTIFYEMAIL
+OPTIONS_GROUP_OUTPUT= RRDTOOL RRDCACHED WRITE_HTTP NOTIFYEMAIL NOTIFYDESKTOP
OPTIONS_GROUP_INPUT= APACHE APCUPS CURL CURL_JSON CURL_XML DBI DISK \
NUTUPS INTERFACE MBMON MEMCACHED MYSQL NGINX \
OPENVPN PDNS PGSQL PING PYTHON ROUTEROS SNMP \
TOKYOTYRANT XMMS
-OPTIONS_DEFAULT= BIND INTERFACE PING SNMP RRDTOOL RRDCACHED
+OPTIONS_DEFAULT= INTERFACE PING SNMP RRDTOOL RRDCACHED
CGI_DESC= Install collection.cgi (requires RRDTOOL)
BIND_DESC= Enable BIND 9.5+ statistics
@@ -41,7 +41,8 @@ INTERFACE_DESC= Network interfaces (libstatgrab)
MBMON_DESC= MBMon
MEMCACHED_DESC= Memcached
NGINX_DESC= Nginx
-NOTIFYEMAIL_DESC= Email notifications (libesmtp, libnotify)
+NOTIFYEMAIL_DESC= Email notifications (libesmtp)
+NOTIFYDESKTOP_DESC= Email notifications (libnotify)
OPENVPN_DESC= OpenVPN statistics
PDNS_DESC= PowerDNS
PING_DESC= Network latency (liboping)
@@ -102,7 +103,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-netapp \
--disable-netlink \
--disable-nfs \
- --disable-notify_desktop \
--disable-olsrd \
--disable-onewire \
--disable-oracle \
@@ -299,9 +299,16 @@ CONFIGURE_ARGS+=--disable-nginx
PLIST_SUB+= NGINX="@comment "
.endif
+.if ${PORT_OPTIONS:MNOTIFYDESKTOP}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+CONFIGURE_ARGS+=--enable-notify_desktop \
+PLIST_SUB+= NOTIFYDESKTOP=""
+.else
+CONFIGURE_ARGS+=--disable-notify_desktop
+PLIST_SUB+= NOTIFYDESKTOP="@comment "
+.endif
.if ${PORT_OPTIONS:MNOTIFYEMAIL}
LIB_DEPENDS+= esmtp:${PORTSDIR}/mail/libesmtp
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-notify_email
CONFIGURE_ARGS+=--with-libesmtp=${PREFIX}
PLIST_SUB+= NOTIFYEMAIL=""
diff --git a/net-mgmt/collectd/files/patch-src__Makefile.am b/net-mgmt/collectd/files/patch-src__Makefile.am
index a1d4dc17ec62..753477bc92c8 100644
--- a/net-mgmt/collectd/files/patch-src__Makefile.am
+++ b/net-mgmt/collectd/files/patch-src__Makefile.am
@@ -1,5 +1,5 @@
---- src/Makefile.am.orig 2012-11-11 11:43:05.000000000 +0100
-+++ src/Makefile.am 2012-12-30 23:34:44.000000000 +0100
+--- src/Makefile.am.orig 2013-04-08 08:26:17.000000000 +0200
++++ src/Makefile.am 2013-08-07 00:23:31.036813410 +0200
@@ -7,7 +7,7 @@
endif
@@ -9,6 +9,15 @@
endif
AM_CPPFLAGS = -DPREFIX='"${prefix}"'
+@@ -720,7 +720,7 @@
+ pkglib_LTLIBRARIES += notify_email.la
+ notify_email_la_SOURCES = notify_email.c
+ notify_email_la_LDFLAGS = -module -avoid-version
+-notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread -ldl
++notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread
+ collectd_LDADD += "-dlopen" notify_email.la
+ collectd_DEPENDENCIES += notify_email.la
+ endif
@@ -1198,7 +1198,7 @@
zfs_arc_la_SOURCES = zfs_arc.c
zfs_arc_la_CFLAGS = $(AM_CFLAGS)
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 6542e500a00c..31fed6fc1820 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -61,6 +61,10 @@ lib/collectd/memory.so
%%NGINX%%lib/collectd/nginx.so
lib/collectd/network.la
lib/collectd/network.so
+%%NOTIFYDESKTOP%%/notify_desktop.la
+%%NOTIFYDESKTOP%%/notify_desktop.so
+%%NOTIFYEMAIL%%/notify_email.la
+%%NOTIFYEMAIL%%/notify_email.so
%%NUTUPS%%lib/collectd/nut.la
%%NUTUPS%%lib/collectd/nut.so
lib/collectd/ntpd.la