aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2022-02-19 16:29:30 +0000
committerKai Knoblich <kai@FreeBSD.org>2022-02-19 16:29:30 +0000
commitd4c912e63bbf3b71b171e26f59ad04238bd4ca0d (patch)
treed4d8b917ac19f7922999ebbf2c60bf1de73c5026 /net-mgmt
parent430553c1f1c7c0dc5e4910174fec5d025b794789 (diff)
downloadports-d4c912e63bbf3b71b171e26f59ad04238bd4ca0d.tar.gz
ports-d4c912e63bbf3b71b171e26f59ad04238bd4ca0d.zip
net-mgmt/py-phonebox-plugin: Add new port
This NetBox plugin is intented for Telephone Number Management. It currently implements a Number abstraction representing a single telephone number of an arbitrary format. A Number can consist of valid DTMF characters and leading plus sign for E.164 support: * Leading Plus ("+") sign (optional) * Digits 0-9 * Characters A, B, C, D * Pound sign ("#") * Asterisk sign ("*") Support for Bulk Edit/Delete operations for Numbers and the following voice circuit types is included as well: * SIP Trunk. * Digital Voice Circuit (PRI/BRI/etc). * Analog Voice Circuit (CO lines/etc). The plugin also introduces a NetBox REST API extension which is compatible with pynetbox. WWW: https://github.com/iDebugAll/phonebox_plugin Requested by: Mike Geiger (via e-mail)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-phonebox-plugin/Makefile22
-rw-r--r--net-mgmt/py-phonebox-plugin/distinfo3
-rw-r--r--net-mgmt/py-phonebox-plugin/files/pkg-message.in20
-rw-r--r--net-mgmt/py-phonebox-plugin/pkg-descr22
5 files changed, 68 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index d37e9d4f5213..64c91603a4be 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -315,6 +315,7 @@
SUBDIR += py-opn-cli
SUBDIR += py-pdagent
SUBDIR += py-pdagent-integrations
+ SUBDIR += py-phonebox-plugin
SUBDIR += py-prometheus-client
SUBDIR += py-pyIOSXR
SUBDIR += py-pyang
diff --git a/net-mgmt/py-phonebox-plugin/Makefile b/net-mgmt/py-phonebox-plugin/Makefile
new file mode 100644
index 000000000000..d91971a1ec96
--- /dev/null
+++ b/net-mgmt/py-phonebox-plugin/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= phonebox-plugin
+DISTVERSION= 0.0.3b8
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= phonebox_plugin-${DISTVERSION}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Phone numbers management plugin for NetBox
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= PYTHON_VER=${PYTHON_VER}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-phonebox-plugin/distinfo b/net-mgmt/py-phonebox-plugin/distinfo
new file mode 100644
index 000000000000..ceb288b5702b
--- /dev/null
+++ b/net-mgmt/py-phonebox-plugin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1645275628
+SHA256 (phonebox_plugin-0.0.3b8.tar.gz) = 71e15839cf1e1eaf48e53bf21f5db7e6bf8c4bf0abcd1d72a5911af6879368ac
+SIZE (phonebox_plugin-0.0.3b8.tar.gz) = 18949
diff --git a/net-mgmt/py-phonebox-plugin/files/pkg-message.in b/net-mgmt/py-phonebox-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..0fef741da966
--- /dev/null
+++ b/net-mgmt/py-phonebox-plugin/files/pkg-message.in
@@ -0,0 +1,20 @@
+[
+{ type: install
+ message: <<EOD
+To enable the plugin please do the following steps:
+
+1. Add/update the following line in the netbox configuration (usually
+ %%LOCALBASE%%/share/netbox/netbox/configuration.py):
+
+ PLUGINS = ['phonebox_plugin']
+
+2. Run NetBox migrations and collect static files:
+
+ # cd %%LOCALBASE%%/share/netbox
+ # python%%PYTHON_VER%% manage.py migrate
+ # python%%PYTHON_VER%% manage.py collectstatic --no-input
+
+3. Restart WSGI/httpd environment (supervisord/apache/nginx/etc.)
+EOD
+}
+]
diff --git a/net-mgmt/py-phonebox-plugin/pkg-descr b/net-mgmt/py-phonebox-plugin/pkg-descr
new file mode 100644
index 000000000000..e859e56d4d29
--- /dev/null
+++ b/net-mgmt/py-phonebox-plugin/pkg-descr
@@ -0,0 +1,22 @@
+This NetBox plugin is intented for Telephone Number Management. It currently
+implements a Number abstraction representing a single telephone number of an
+arbitrary format. A Number can consist of valid DTMF characters and leading
+plus sign for E.164 support:
+
+* Leading Plus ("+") sign (optional)
+* Digits 0-9
+* Characters A, B, C, D
+* Pound sign ("#")
+* Asterisk sign ("*")
+
+Support for Bulk Edit/Delete operations for Numbers and the following voice
+circuit types is included as well:
+
+* SIP Trunk.
+* Digital Voice Circuit (PRI/BRI/etc).
+* Analog Voice Circuit (CO lines/etc).
+
+The plugin also introduces a NetBox REST API extension which is compatible
+with pynetbox.
+
+WWW: https://github.com/iDebugAll/phonebox_plugin