aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2006-11-08 19:42:21 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2006-11-08 19:42:21 +0000
commitec1eeaab391117dac1b4868aa40865f5a5e3e8e7 (patch)
treee9f5d9c037227f32f501eaa181a6f8985499ffc1 /net-mgmt
parent32c3f287454f30429ddb52bbd9f8bb3777fc955b (diff)
downloadports-ec1eeaab391117dac1b4868aa40865f5a5e3e8e7.tar.gz
ports-ec1eeaab391117dac1b4868aa40865f5a5e3e8e7.zip
Sjitter is a command line client/server to measure jitter
(based on RFC 1889), one way UDP delay and bandwidth. PR: ports/104898 Submitted by: self Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=176848
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/sjitter/Makefile32
-rw-r--r--net-mgmt/sjitter/distinfo3
-rw-r--r--net-mgmt/sjitter/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 64e170004b12..886cb713517d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -189,6 +189,7 @@
SUBDIR += sendip
SUBDIR += sing
SUBDIR += sipcalc
+ SUBDIR += sjitter
SUBDIR += slate
SUBDIR += snmptt
SUBDIR += softflowd
diff --git a/net-mgmt/sjitter/Makefile b/net-mgmt/sjitter/Makefile
new file mode 100644
index 000000000000..1938290b921f
--- /dev/null
+++ b/net-mgmt/sjitter/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: sjitter
+# Date created: 2006-10-29
+# Whom: babak@farrokhi.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= sjitter
+PORTVERSION= 0.14b
+CATEGORIES= net-mgmt net
+MASTER_SITES= http://www.alcasat.net/dev/sjitter/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= A client/server jitter measurement utility
+
+WRKSRC= ${WRKDIR}
+USE_GMAKE= yes
+MAN1= sjitter.1
+PLIST_FILES= sbin/sjitters sbin/sjitterc
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
+ s,^LDFLAGS,LDFLAGS+,g ; \
+ s,^CFLAGS,CFLAGS+,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sjitters ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sjitterc ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/sjitter.1.gz ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/sjitter/distinfo b/net-mgmt/sjitter/distinfo
new file mode 100644
index 000000000000..a00f75f07d71
--- /dev/null
+++ b/net-mgmt/sjitter/distinfo
@@ -0,0 +1,3 @@
+MD5 (sjitter-0.14b.tgz) = d2ca93bfc6edd3f9818aeb75d2bde65a
+SHA256 (sjitter-0.14b.tgz) = f06fc65afcbebd27db901b77f2c0c75da580b862b65f7bc35cd16a46391d4f5b
+SIZE (sjitter-0.14b.tgz) = 8070
diff --git a/net-mgmt/sjitter/pkg-descr b/net-mgmt/sjitter/pkg-descr
new file mode 100644
index 000000000000..57e1cf06ec8e
--- /dev/null
+++ b/net-mgmt/sjitter/pkg-descr
@@ -0,0 +1,4 @@
+Sjitter is a command line client/server to measure jitter
+(based on RFC 1889), one way UDP delay and bandwidth.
+
+WWW: http://www.alcasat.net/dev/sjitter/