aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin-utils
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-02-24 11:10:23 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-02-24 11:10:23 +0000
commit24c1a3701d7cbbe58070f2eebae7bf5b62030fc7 (patch)
tree197932b4c88ae6fc4b34669c98ac790b97ce6c2f /net-p2p/bitcoin-utils
parent50434bc41363f5d60027532ba03a3142e379eb14 (diff)
downloadports-24c1a3701d7cbbe58070f2eebae7bf5b62030fc7.tar.gz
ports-24c1a3701d7cbbe58070f2eebae7bf5b62030fc7.zip
net-p2p/bitcoin: Update to 0.10.0, split bitcoin-utils, LOTS MORE
- Update to 0.10.0 - Split out bitcoin-cli and bitcoin-tx into net-p2p/bitcoin-utils - Slave out bitcoin-utils and bitcoin-daemon properly - Canonicalize MASTER_SITES to what USE_GITHUB uses - Update COMMENT so each port is unique - protobuf/protoc is GUI-only dependency, remove it from unconditional {BUILD,LIB}_DEPENDS. - Group and sort USES/USE_* - Deprecate USE_AUTOTOOLS in favour of USES=autoreconf - Remove {AUTOMAKE,ACLOCAL}_ARGS accordingly - Remove unconditional *FLAGS and replace then with OPTIONS-conditional ones. - Remove unnecessary CXXFLAGS - Add HARDENING and TESTS options, add them to OPTIONS_DEFAULT - Add DBUS and DEBUG options - Define OPTIONS only where they're relevant for each port - Rejig OPTIONS descriptions for greater clarity - Replace hard-coded SSL inc/lib flags with USE_OPENSSL variables to allow for switching between Base and Ports OpenSSL's. - Use OPTIONS helpers - Remove post-patch target - Canonicalize CONFIGURE_ARGS, with slave port specific overrides. - Verbosify builds (V=1) - Remove upstreamed patches - Add regression-test targets (requires TESTS option) - Add --disable-reduce-exports to CONFIGURE_ARGS until upstream PR #5819 lands, which caused sanity test failure at run-time [1] P.S We now pass the test suite (not including python test, which has an error) Based on patch Submitted by: - Andriy Voskoboinyk <s3erios gmail.com> - Robert Backhaus <robbak gmail.com> [1] https://github.com/bitcoin/bitcoin/pull/5819 PR: 193424 Reviewed by: maintainer Approved by: maintainer
Notes
Notes: svn path=/head/; revision=379779
Diffstat (limited to 'net-p2p/bitcoin-utils')
-rw-r--r--net-p2p/bitcoin-utils/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
new file mode 100644
index 000000000000..f6a9fffcecb8
--- /dev/null
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../bitcoin
+PKGNAMESUFFIX= -utils
+
+COMMENT= Virtual Peer-to-Peer Currency (CLI and Utilities)
+SLAVE_PORT= yes
+
+OPTIONS_DEFINE= DEBUG HARDENING TESTS
+OPTIONS_DEFAULT= HARDENING TESTS
+
+CONFIGURE_ARGS= --without-daemon \
+ --without-gui \
+ --without-libs \
+ --without-qrencode \
+ --with-utils \
+ --disable-wallet \
+ --disable-reduce-exports
+
+PLIST_FILES= bin/bitcoin-cli bin/bitcoin-tx
+
+.include "${MASTERDIR}/Makefile"