aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitflu
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-28 16:06:02 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-28 16:06:02 +0000
commit1a4d47bb32a2dc6dac03f11b30a117d908c7c43f (patch)
tree2b6c3e6c8b346bcc1e51ebef8820e89db85162be /net-p2p/bitflu
parent0c5ac1fc37f38124f72368ce0a7674c2459e5b62 (diff)
downloadports-1a4d47bb32a2dc6dac03f11b30a117d908c7c43f.tar.gz
ports-1a4d47bb32a2dc6dac03f11b30a117d908c7c43f.zip
Add port net-p2p/bitflu:
Bitflu is a free BitTorrent client. The client was written in Perl and is designed to run as a daemon (7x24h , like mlnet) on Linux, *BSD and maybe even OSX. * Multiple downloads * Designed to run as a daemon/No GUI: You can connect to the client using the telnet or HTTP interface * Security: The client can chroot itself and drop privileges * Bandwith shaping (currently only upload) * Crash-Proof design: Crashes or a full filesystem will never corrupt your downloads again :-) * Non-Threading/(almost)Non-Forking design: All connections are handled in non-blocking state using a dynamic select loop WWW: http://bitflu.workaround.ch/ Author: Adrian Ulrich <adrian@blinkenlights.ch>
Notes
Notes: svn path=/head/; revision=183551
Diffstat (limited to 'net-p2p/bitflu')
-rw-r--r--net-p2p/bitflu/Makefile30
-rw-r--r--net-p2p/bitflu/distinfo3
-rw-r--r--net-p2p/bitflu/pkg-descr15
3 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/bitflu/Makefile b/net-p2p/bitflu/Makefile
new file mode 100644
index 000000000000..83ed2d13a1b6
--- /dev/null
+++ b/net-p2p/bitflu/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: bitflu
+# Date created: 28 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bitflu
+PORTVERSION= 0.31
+CATEGORIES= net-p2p
+MASTER_SITES= http://bitflu.workaround.ch/bitflu/ CSME
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= BitTorrent client written in Perl
+
+RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+PLIST_FILES= bin/bitflu %%EXAMPLESDIR%%/bitflu.config
+PLIST_DIRS= %%EXAMPLESDIR%%
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.config.example ${EXAMPLESDIR}/${PORTNAME}.config
+
+.include <bsd.port.mk>
diff --git a/net-p2p/bitflu/distinfo b/net-p2p/bitflu/distinfo
new file mode 100644
index 000000000000..01a27600cafd
--- /dev/null
+++ b/net-p2p/bitflu/distinfo
@@ -0,0 +1,3 @@
+MD5 (bitflu-0.31.tgz) = bf3f43cf238d7296ef0a1eb7dd10b868
+SHA256 (bitflu-0.31.tgz) = a2397c532c177289bf3b21a70e9502f053059eb38e7a1506dc5eb659ab2d7954
+SIZE (bitflu-0.31.tgz) = 52293
diff --git a/net-p2p/bitflu/pkg-descr b/net-p2p/bitflu/pkg-descr
new file mode 100644
index 000000000000..51e18b49ca42
--- /dev/null
+++ b/net-p2p/bitflu/pkg-descr
@@ -0,0 +1,15 @@
+Bitflu is a free BitTorrent client. The client was written in Perl and
+is designed to run as a daemon (7x24h , like mlnet) on Linux, *BSD and
+maybe even OSX.
+* Multiple downloads
+* Designed to run as a daemon/No GUI: You can connect to the client
+ using the telnet or HTTP interface
+* Security: The client can chroot itself and drop privileges
+* Bandwith shaping (currently only upload)
+* Crash-Proof design: Crashes or a full filesystem will never corrupt
+ your downloads again :-)
+* Non-Threading/(almost)Non-Forking design: All connections are handled
+ in non-blocking state using a dynamic select loop
+
+WWW: http://bitflu.workaround.ch/
+Author: Adrian Ulrich <adrian@blinkenlights.ch>