aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitflu
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:27:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:27:55 +0000
commit1c44c762169a3f174c6435af9349ad5156c8ec45 (patch)
tree05fc08d6e7829b967b3a3d1628c2e39d18540b9f /net-p2p/bitflu
parentcc5a2c90d873fb42aa15ffe6120088af39a2e22d (diff)
downloadports-1c44c762169a3f174c6435af9349ad5156c8ec45.tar.gz
ports-1c44c762169a3f174c6435af9349ad5156c8ec45.zip
- Update to 2009-04-19
PR: 134013 Submitted by: Martin Kammerhofer <dada@sbox.tu-graz.ac.at> (maintainer)
Notes
Notes: svn path=/head/; revision=232799
Diffstat (limited to 'net-p2p/bitflu')
-rw-r--r--net-p2p/bitflu/Makefile30
-rw-r--r--net-p2p/bitflu/distinfo6
-rw-r--r--net-p2p/bitflu/files/pkg-message.in35
-rw-r--r--net-p2p/bitflu/pkg-plist21
4 files changed, 51 insertions, 41 deletions
diff --git a/net-p2p/bitflu/Makefile b/net-p2p/bitflu/Makefile
index adc4f9dd6a0f..7af3f6ca2dd4 100644
--- a/net-p2p/bitflu/Makefile
+++ b/net-p2p/bitflu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bitflu
-PORTVERSION= 0.70
+PORTVERSION= 0.81
CATEGORIES= net-p2p
MASTER_SITES= http://bitflu.workaround.ch/bitflu/ CENKES
EXTRACT_SUFX= .tgz
@@ -17,17 +17,28 @@ COMMENT= BitTorrent client written in Perl
RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-PLUGINSDIR= ${PREFIX}/lib/${PORTNAME}
+PLUGINSDIR= lib/perl5/Bitflu
USE_PERL5= yes
NO_BUILD= yes
SUB_FILES= pkg-message
SUB_LIST= DOCSDIR=${DOCSDIR} PLUGINSDIR=${PLUGINSDIR}
-PLIST_SUB= PLUGINSDIR=lib/${PORTNAME}
+PLIST_SUB= PLUGINSDIR=${PLUGINSDIR}
+
+PORTDOCS= ChangeLog.txt README.txt README_IPv6.txt
+
+OPTIONS= IPV6 "Enable functionality over IPv6 transport" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IPV6)
+RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-INET6
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|'\''.bitflu.config'\''|"$$ENV{HOME}/.bitflu.config"|; \
- s|\./plugins|${PLUGINSDIR}|; s|\./workdir|$$ENV{HOME}/.bitflu.workdir|; \
+ s|\./plugins|${PREFIX}/${PLUGINSDIR}|; \
+ s|\./workdir|$$ENV{HOME}/.bitflu.workdir|; \
s|--config=\.bitflu.config|--config=~/.bitflu.config|' \
${WRKSRC}/bitflu.pl
@@ -36,18 +47,21 @@ do-install:
${PREFIX}/bin/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/tools/fluconvert.pl \
${PREFIX}/bin/fluconvert.pl
- ${INSTALL} -d ${PLUGINSDIR}/Bitflu
- ${INSTALL_DATA} ${WRKSRC}/plugins/Bitflu/*.pm ${PLUGINSDIR}/Bitflu/
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/dumptorrent.pl \
+ ${PREFIX}/bin/dumptorrent.pl
+ ${MKDIR} ${PREFIX}/${PLUGINSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/plugins/Bitflu/*.pm ${PREFIX}/${PLUGINSDIR}/
.if !defined(NOPORTEXAMPLES)
${INSTALL} -d ${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.config.example \
${EXAMPLESDIR}/${PORTNAME}.config
.endif
.if !defined(NOPORTDOCS)
- ${INSTALL} -d ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/tools/fluconvert-README.txt \
${DOCSDIR}/fluconvert-README.txt
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/bitflu/distinfo b/net-p2p/bitflu/distinfo
index d19c26576949..943045a4a4e1 100644
--- a/net-p2p/bitflu/distinfo
+++ b/net-p2p/bitflu/distinfo
@@ -1,3 +1,3 @@
-MD5 (bitflu-0.70.tgz) = 03e58b83e8852055a2c1042052ea8cc4
-SHA256 (bitflu-0.70.tgz) = 0593e052177f0fb405d718e1a1937a947a5f26ef8e09d50e7df3caee6d891377
-SIZE (bitflu-0.70.tgz) = 122943
+MD5 (bitflu-0.81.tgz) = 02f2f4fa09dc20c5f75a62b8d9f75932
+SHA256 (bitflu-0.81.tgz) = 6a460ba21a747c0e746830c063ec21fac1f2e51e799039a73ae58c06a8ca5322
+SIZE (bitflu-0.81.tgz) = 129085
diff --git a/net-p2p/bitflu/files/pkg-message.in b/net-p2p/bitflu/files/pkg-message.in
index 86f5088df0bc..c8f9dda9376c 100644
--- a/net-p2p/bitflu/files/pkg-message.in
+++ b/net-p2p/bitflu/files/pkg-message.in
@@ -1,19 +1,16 @@
-To use bitflu with the plugins installed by this package, configure
-your ~/.bitflu.config to search for plugins here (instead of the
-default ./plugins):
-
- %%PLUGINSDIR%%
-
-If you have previously used a version of bitflu prior to 0.4x, you may
-want to convert your data to the new storage plugin (which was
-introduced along with the upstream bitflu re-write). Such conversions
-can be done using fluconvert. If the package is build with
-documentation, the upstream instructions for using fluconvert is
-installed at:
-
- %%DOCSDIR%%/fluconvert-README.txt
-
-When installed by this port, the bitflu workdir is located under
-~/.bitflu.workdir by default rather than ./bitflu.workdir (you may
-want to use --config=./bitflu.workdir to produce the behavior used by
-the upstream version).
+*************************************************************************
+* To use bitflu with the plugins installed by this package, configure *
+* your ~/.bitflu.config to search for plugins here (instead of the *
+* default ./plugins): *
+* *
+* %%PREFIX%%/lib/perl5 (New location as of 0.80) *
+* *
+* If you have previously used a version of bitflu prior to 0.4x, you *
+* may want to convert your data to the new storage plugin (which was *
+* introduced along with the upstream bitflu re-write). Such conversions *
+* can be done using fluconvert. If the package is built with *
+* documentation, the instructions are installed at: *
+* *
+* %%DOCSDIR%%/fluconvert-README.txt *
+* *
+*************************************************************************
diff --git a/net-p2p/bitflu/pkg-plist b/net-p2p/bitflu/pkg-plist
index 616315cbc6d0..9abfd4304dd2 100644
--- a/net-p2p/bitflu/pkg-plist
+++ b/net-p2p/bitflu/pkg-plist
@@ -1,17 +1,16 @@
bin/bitflu
bin/fluconvert.pl
+bin/dumptorrent.pl
%%PORTDOCS%%%%DOCSDIR%%/fluconvert-README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bitflu.config
-%%PLUGINSDIR%%/Bitflu/00_StorageFarabDb.pm
-%%PLUGINSDIR%%/Bitflu/00_StorageVFS.pm
-%%PLUGINSDIR%%/Bitflu/10_AdminHTTP.pm
-%%PLUGINSDIR%%/Bitflu/10_AdminTelnet.pm
-%%PLUGINSDIR%%/Bitflu/20_DownloadBitTorrent.pm
-%%PLUGINSDIR%%/Bitflu/20_DownloadHTTP.pm
-%%PLUGINSDIR%%/Bitflu/30_SourcesBitTorrent.pm
-%%PLUGINSDIR%%/Bitflu/30_SourcesBitTorrentKademlia.pm
-%%PLUGINSDIR%%/Bitflu/99_Cron.pm
-@dirrm %%PLUGINSDIR%%/Bitflu
+%%PLUGINSDIR%%/00_StorageFarabDb.pm
+%%PLUGINSDIR%%/00_StorageVFS.pm
+%%PLUGINSDIR%%/10_AdminHTTP.pm
+%%PLUGINSDIR%%/10_AdminTelnet.pm
+%%PLUGINSDIR%%/20_DownloadBitTorrent.pm
+%%PLUGINSDIR%%/20_DownloadHTTP.pm
+%%PLUGINSDIR%%/30_SourcesBitTorrent.pm
+%%PLUGINSDIR%%/30_SourcesBitTorrentKademlia.pm
+%%PLUGINSDIR%%/99_Cron.pm
@dirrm %%PLUGINSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%