aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/cpuminer
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-02-19 08:41:56 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-02-19 08:41:56 +0000
commitc116e8213fff874ab199fe2e58a6df0e249c2a86 (patch)
tree8d16b2f230ed2e0eb155e060a137f68f37bb227e /net-p2p/cpuminer
parent863b8bcb8390e5cfd35b6901491ef7492154677a (diff)
downloadports-c116e8213fff874ab199fe2e58a6df0e249c2a86.tar.gz
ports-c116e8213fff874ab199fe2e58a6df0e249c2a86.zip
Fix CPU affinity of net-p2p/cpuminer port threads
Submitted by: ache@FreeBSD.org
Notes
Notes: svn path=/head/; revision=345023
Diffstat (limited to 'net-p2p/cpuminer')
-rw-r--r--net-p2p/cpuminer/Makefile2
-rw-r--r--net-p2p/cpuminer/files/patch-cpu-miner.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/cpuminer/Makefile b/net-p2p/cpuminer/Makefile
index 3cf760b2e8a5..84c01fea6ca7 100644
--- a/net-p2p/cpuminer/Makefile
+++ b/net-p2p/cpuminer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cpuminer
PORTVERSION= 2.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-p2p math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= cpuminer
diff --git a/net-p2p/cpuminer/files/patch-cpu-miner.c b/net-p2p/cpuminer/files/patch-cpu-miner.c
new file mode 100644
index 000000000000..cbd6058670f8
--- /dev/null
+++ b/net-p2p/cpuminer/files/patch-cpu-miner.c
@@ -0,0 +1,11 @@
+--- cpu-miner.c.bak 2014-02-19 09:20:56.187720557 +0100
++++ cpu-miner.c 2014-02-19 09:21:15.296719054 +0100
+@@ -75,7 +75,7 @@
+ cpuset_t set;
+ CPU_ZERO(&set);
+ CPU_SET(cpu, &set);
+- cpuset_setaffinity(CPU_LEVEL_WHICH, CPU_WHICH_CPUSET, -1, sizeof(cpuset_t), &set);
++ cpuset_setaffinity(CPU_LEVEL_WHICH, CPU_WHICH_TID, -1, sizeof(cpuset_t), &set);
+ }
+ #else
+ static inline void drop_policy(void)