aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge-cli
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2018-03-13 20:44:18 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2018-03-13 20:44:18 +0000
commit57b7a75075525fb8946395f76bd7cc00e827f7db (patch)
tree7786664221128a3ff1a9dc6ce242754071c83765 /net-p2p/deluge-cli
parent0746a51922d2e59f6c174957a0faf4cc203e57df (diff)
downloadports-57b7a75075525fb8946395f76bd7cc00e827f7db.tar.gz
ports-57b7a75075525fb8946395f76bd7cc00e827f7db.zip
net-p2p/deluge-cli: fix runtime
Add upstream patch to fix bug with opening preferences window. This patch closing https://dev.deluge-torrent.org/ticket/3039 PR: 226443 Submitted by: Rainbow <rainbow@sanitylinux.org> MFH: 2018Q1
Notes
Notes: svn path=/head/; revision=464430
Diffstat (limited to 'net-p2p/deluge-cli')
-rw-r--r--net-p2p/deluge-cli/Makefile2
-rw-r--r--net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index 71d401d149fa..1ef525cedfcb 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= deluge
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 1.3.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p python
PKGNAMESUFFIX= -cli
diff --git a/net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py b/net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py
new file mode 100644
index 000000000000..8d73e83d5e21
--- /dev/null
+++ b/net-p2p/deluge-cli/files/patch-deluge_ui_gtkui_preferences.py
@@ -0,0 +1,20 @@
+Closing upstream bug-report: https://dev.deluge-torrent.org/ticket/3039
+
+Index: deluge/ui/gtkui/preferences.py
+===================================================================
+--- deluge/ui/gtkui/preferences.py.orig 2017-05-12 12:57:19 UTC
++++ deluge/ui/gtkui/preferences.py
+@@ -318,11 +318,8 @@ class Preferences(component.Component):
+ }
+ # Add proxy stuff
+
+- # Display workaround for single proxy in libtorrent >v0.16
+- try:
+- lt_single_proxy = component.get("PreferencesManager").LT_SINGLE_PROXY
+- except AttributeError:
+- lt_single_proxy = False
++ # Display workaround for single proxy in libtorrent >= v0.16
++ lt_single_proxy = True
+
+ for t in ("peer", "web_seed", "tracker", "dht"):
+ if lt_single_proxy and not t == "peer":