aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-07-06 04:44:26 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-07-06 04:44:26 +0000
commitdaa9b8917901ac4f997dd36a6ce1b43c3f4e8040 (patch)
treec09fe235f6309a67f378386970d2ce72e949fd77 /net-p2p/deluge
parentc0034bd853f926acfd9a863d3cae6d9ff29f5d65 (diff)
downloadports-daa9b8917901ac4f997dd36a6ce1b43c3f4e8040.tar.gz
ports-daa9b8917901ac4f997dd36a6ce1b43c3f4e8040.zip
Update to 0.5.2.
Notes
Notes: svn path=/head/; revision=195045
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/Makefile3
-rw-r--r--net-p2p/deluge/distinfo6
-rw-r--r--net-p2p/deluge/files/patch-setup.py33
-rw-r--r--net-p2p/deluge/files/patch-socket_ops.hpp20
-rw-r--r--net-p2p/deluge/files/patch-src_interface.py6
-rw-r--r--net-p2p/deluge/pkg-plist43
6 files changed, 68 insertions, 43 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 4d3ef47d0192..121acd386783 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= deluge
-PORTVERSION= 0.5.1.1
-PORTREVISION= 1
+PORTVERSION= 0.5.2
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/stable/
diff --git a/net-p2p/deluge/distinfo b/net-p2p/deluge/distinfo
index 0584d30bae9c..efb74038340c 100644
--- a/net-p2p/deluge/distinfo
+++ b/net-p2p/deluge/distinfo
@@ -1,3 +1,3 @@
-MD5 (deluge-0.5.1.1.tar.gz) = dc35e5272a26d2b6d010ca0614f94b44
-SHA256 (deluge-0.5.1.1.tar.gz) = 50e0576fd7969030259819b43e5edc975214a1d33a56ff1968ee66403814c5ce
-SIZE (deluge-0.5.1.1.tar.gz) = 620622
+MD5 (deluge-0.5.2.tar.gz) = 9a33f6b3d7cec3b27cd3044064c10d31
+SHA256 (deluge-0.5.2.tar.gz) = c1073ded5d6cc95bb6e9aa9847109a0d33ad06baaeb399e24ca400f833d91130
+SIZE (deluge-0.5.2.tar.gz) = 672369
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index 6c14fb6018da..42711e85d2dc 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,15 +1,24 @@
---- setup.py.orig Sat Jun 9 12:16:40 2007
-+++ setup.py Sat Jun 9 12:19:31 2007
-@@ -100,7 +100,7 @@
+--- setup.py.orig Thu Jul 5 22:49:16 2007
++++ setup.py Thu Jul 5 22:55:47 2007
+@@ -105,7 +105,7 @@
+
+ includedirs = ['./libtorrent', './libtorrent/include',
+ './libtorrent/include/libtorrent',
+- '/usr/include/python' + python_version]
++ '%%LOCALBASE%%/include']
+
+ if OS == "linux":
+ if os.WEXITSTATUS(os.system('grep -iq "Debian GNU/Linux 4.0\|Ubuntu 7.04\|Ubuntu 6.06\|Ubuntu 6.10\|Fedora Core release 6\|openSUSE 10.2\|Mandriva Linux release 2007.1\|Fedora release 7" /etc/issue')) == 0:
+@@ -117,7 +117,7 @@
else:
boosttype = 'mt'
- removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
+ removals = ['-g', '-Wstrict-prototypes']
- additions = ['-DNDEBUG', '-O2']
+ additions = ['-DNDEBUG']
if python_version == '2.5':
cv_opt = sysconfig.get_config_vars()["CFLAGS"]
-@@ -131,19 +131,21 @@
+@@ -152,11 +152,11 @@
# Ubuntu possible.
if boosttype == "nomt":
librariestype = ['boost_filesystem', 'boost_date_time',
@@ -22,15 +31,15 @@
+ 'boost_thread-mt', 'z', 'ssl']
print 'Libraries mt'
+ def fetchCpp():
+@@ -175,8 +175,10 @@
+
deluge_core = Extension('deluge_core',
- include_dirs = ['./libtorrent', './libtorrent/include',
- './libtorrent/include/libtorrent',
-- '/usr/include/python' + python_version],
-+ '%%LOCALBASE%%/include'],
+ include_dirs = includedirs,
+ library_dirs = ['%%LOCALBASE%%/lib'],
libraries = librariestype,
extra_compile_args = EXTRA_COMPILE_ARGS,
+ extra_link_args = ['%%PTHREAD_LIBS%%'],
- sources = ['src/deluge_core.cpp',
- 'libtorrent/src/alert.cpp',
- 'libtorrent/src/allocate_resources.cpp',
+ sources = sources)
+ # Thanks to Iain Nicol for code to save the location for installed prefix
+ # At runtime, we need to know where we installed the data to.
diff --git a/net-p2p/deluge/files/patch-socket_ops.hpp b/net-p2p/deluge/files/patch-socket_ops.hpp
deleted file mode 100644
index bffd0c853a3d..000000000000
--- a/net-p2p/deluge/files/patch-socket_ops.hpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- libtorrent/include/libtorrent/asio/detail/socket_ops.hpp.orig Sun May 27 17:11:11 2007
-+++ libtorrent/include/libtorrent/asio/detail/socket_ops.hpp Sun Jun 10 11:58:14 2007
-@@ -63,7 +63,7 @@
- socket_addr_len_type* addrlen, asio::error_code& ec)
- {
- clear_error(ec);
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type new_s = error_wrapper(::accept(s, addr, addrlen), ec);
- if (new_s == invalid_socket)
- return new_s;
-@@ -295,7 +295,7 @@
- }
-
- return s;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type s = error_wrapper(::socket(af, type, protocol), ec);
- if (s == invalid_socket)
- return s;
diff --git a/net-p2p/deluge/files/patch-src_interface.py b/net-p2p/deluge/files/patch-src_interface.py
index b878c7def432..959e3cb7d95c 100644
--- a/net-p2p/deluge/files/patch-src_interface.py
+++ b/net-p2p/deluge/files/patch-src_interface.py
@@ -1,6 +1,6 @@
---- src/interface.py.orig Sat Jun 9 12:20:35 2007
-+++ src/interface.py Sat Jun 9 12:20:54 2007
-@@ -75,9 +75,9 @@
+--- src/interface.py.orig Thu Jul 5 22:48:09 2007
++++ src/interface.py Thu Jul 5 22:48:21 2007
+@@ -43,9 +43,9 @@
def __init__(self):
APP = 'deluge'
DIR = os.path.join(common.INSTALL_PREFIX, 'share', 'locale')
diff --git a/net-p2p/deluge/pkg-plist b/net-p2p/deluge/pkg-plist
index 235d37810741..0f241f8b0245 100644
--- a/net-p2p/deluge/pkg-plist
+++ b/net-p2p/deluge/pkg-plist
@@ -34,34 +34,59 @@ share/applications/deluge.desktop
%%DATADIR%%/glade/aboutdialog.glade
%%DATADIR%%/glade/delugegtk.glade
%%DATADIR%%/glade/dgtkpopups.glade
+%%DATADIR%%/glade/edit_trackers.glade
%%DATADIR%%/glade/file_tab_menu.glade
%%DATADIR%%/glade/plugin_dialog.glade
%%DATADIR%%/glade/preferences_dialog.glade
%%DATADIR%%/glade/torrent_menu.glade
+%%DATADIR%%/glade/tray_menu.glade
%%DATADIR%%/pixmaps/deluge-about.png
%%DATADIR%%/pixmaps/deluge128.png
%%DATADIR%%/pixmaps/deluge192.png
%%DATADIR%%/pixmaps/deluge22.png
%%DATADIR%%/pixmaps/deluge256.png
%%DATADIR%%/pixmaps/deluge32.png
+%%DATADIR%%/pixmaps/downloading16.png
+%%DATADIR%%/pixmaps/inactive16.png
+%%DATADIR%%/pixmaps/seeding16.png
+%%DATADIR%%/plugins/BlocklistImport/__init__.py
+%%DATADIR%%/plugins/BlocklistImport/listfile1.txt
+%%DATADIR%%/plugins/BlocklistImport/listfile2.txt
+%%DATADIR%%/plugins/BlocklistImport/nipfilter.dat.gz
+%%DATADIR%%/plugins/BlocklistImport/peerguardian.py
+%%DATADIR%%/plugins/BlocklistImport/pg.txt
+%%DATADIR%%/plugins/BlocklistImport/splist.txt
+%%DATADIR%%/plugins/BlocklistImport/test.py
+%%DATADIR%%/plugins/BlocklistImport/text.py
+%%DATADIR%%/plugins/BlocklistImport/ui.py
+%%DATADIR%%/plugins/DesiredRatio/__init__.py
+%%DATADIR%%/plugins/ExamplePlugin/__init__.py
%%DATADIR%%/plugins/ExamplePlugin/example-plugin.png
%%DATADIR%%/plugins/ExamplePlugin/example.glade
%%DATADIR%%/plugins/ExamplePlugin/plugin.py
-%%DATADIR%%/plugins/HelloWorld/plugin.py
+%%DATADIR%%/plugins/HelloWorld/__init__.py
+%%DATADIR%%/plugins/NetworkGraph/__init__.py
%%DATADIR%%/plugins/NetworkGraph/plugin.py
+%%DATADIR%%/plugins/NetworkHealth/__init__.py
%%DATADIR%%/plugins/NetworkHealth/plugin.py
-%%DATADIR%%/plugins/TorrentCreator/plugin.py
-%%DATADIR%%/plugins/TorrentCreator/tcreator.glade
+%%DATADIR%%/plugins/Scheduler/__init__.py
+%%DATADIR%%/plugins/Scheduler/plugin.py
+%%DATADIR%%/plugins/TorrentCreator/__init__.py
+%%DATADIR%%/plugins/TorrentCreator/torrentcreator.glade
+%%DATADIR%%/plugins/TorrentSearch/__init__.py
%%DATADIR%%/plugins/TorrentSearch/plugin.py
%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
+share/locale/ar/LC_MESSAGES/deluge.mo
+share/locale/ast/LC_MESSAGES/deluge.mo
share/locale/bg/LC_MESSAGES/deluge.mo
share/locale/ca/LC_MESSAGES/deluge.mo
share/locale/cs/LC_MESSAGES/deluge.mo
share/locale/da/LC_MESSAGES/deluge.mo
share/locale/de/LC_MESSAGES/deluge.mo
share/locale/el/LC_MESSAGES/deluge.mo
+share/locale/en_AU/LC_MESSAGES/deluge.mo
share/locale/en_CA/LC_MESSAGES/deluge.mo
share/locale/en_GB/LC_MESSAGES/deluge.mo
share/locale/es/LC_MESSAGES/deluge.mo
@@ -73,6 +98,7 @@ share/locale/gl/LC_MESSAGES/deluge.mo
share/locale/he/LC_MESSAGES/deluge.mo
share/locale/hr/LC_MESSAGES/deluge.mo
share/locale/hu/LC_MESSAGES/deluge.mo
+share/locale/id/LC_MESSAGES/deluge.mo
share/locale/it/LC_MESSAGES/deluge.mo
share/locale/ja/LC_MESSAGES/deluge.mo
share/locale/ko/LC_MESSAGES/deluge.mo
@@ -84,24 +110,35 @@ share/locale/nl/LC_MESSAGES/deluge.mo
share/locale/pl/LC_MESSAGES/deluge.mo
share/locale/pt/LC_MESSAGES/deluge.mo
share/locale/pt_BR/LC_MESSAGES/deluge.mo
+share/locale/ro/LC_MESSAGES/deluge.mo
share/locale/ru/LC_MESSAGES/deluge.mo
share/locale/sk/LC_MESSAGES/deluge.mo
share/locale/sl/LC_MESSAGES/deluge.mo
share/locale/sr/LC_MESSAGES/deluge.mo
share/locale/sv/LC_MESSAGES/deluge.mo
+share/locale/ta/LC_MESSAGES/deluge.mo
+share/locale/tlh/LC_MESSAGES/deluge.mo
share/locale/tr/LC_MESSAGES/deluge.mo
+share/locale/uk/LC_MESSAGES/deluge.mo
share/locale/zh_CN/LC_MESSAGES/deluge.mo
share/locale/zh_TW/LC_MESSAGES/deluge.mo
share/pixmaps/deluge.xpm
+@dirrmtry share/locale/tlh/LC_MESSAGES
+@dirrmtry share/locale/tlh
@dirrmtry share/locale/la/LC_MESSAGES
@dirrmtry share/locale/la
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/plugins/TorrentSearch
@dirrm %%DATADIR%%/plugins/TorrentCreator
+@dirrm %%DATADIR%%/plugins/Scheduler
@dirrm %%DATADIR%%/plugins/NetworkHealth
@dirrm %%DATADIR%%/plugins/NetworkGraph
@dirrm %%DATADIR%%/plugins/HelloWorld
@dirrm %%DATADIR%%/plugins/ExamplePlugin
+@dirrm %%DATADIR%%/plugins/DesiredRatio
+@dirrm %%DATADIR%%/plugins/BlocklistImport
@dirrmtry %%DATADIR%%/plugins
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/glade