aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-09 05:36:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-09 05:53:28 +0000
commit0c0dc5cf7df4c4faecca4487d6f3e5a8690ba5a2 (patch)
treeb9b174a1ea1095863f54153dd9a30063712751e9 /net-p2p/libtorrent-rasterbar
parent55b0acea661a19c762d6678a88e847e673ba6ccb (diff)
downloadports-0c0dc5cf7df4c4faecca4487d6f3e5a8690ba5a2.tar.gz
ports-0c0dc5cf7df4c4faecca4487d6f3e5a8690ba5a2.zip
net-p2p/libtorrent-rasterbar: Re-add USE_CXXSTD=c++17 to fix runtime crash
Diffstat (limited to 'net-p2p/libtorrent-rasterbar')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 6863eb32daed..6a7b1916887d 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libtorrent-rasterbar
DISTVERSION= 1.2.16 # 2.x is unusable until memory problems are resolved, see https://github.com/arvidn/libtorrent/issues/6781
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/v${DISTVERSION}/
@@ -20,6 +21,8 @@ USES= cmake compiler:c++11-lib iconv:wchar_t libtool localbase:ldflags pathfix
SHEBANG_FILES= test/socks.py test/web_server.py
USE_LDCONFIG= yes
+USE_CXXSTD= c++17 # prevent boost-related SEGV, see bug#264278
+
LDFLAGS+= ${ICONV_LIB}
SHLIB_VER= 10