aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/lopster
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:45:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:45:24 +0000
commit130e7ca4212eccd260ef32aa398a08bbaf5e8396 (patch)
tree5c6edeb75489695845ea327ad4945d5e0b84983b /net-p2p/lopster
parent2d8a3c6d08a38542dc128602fbecf4bf33b2a879 (diff)
downloadports-130e7ca4212eccd260ef32aa398a08bbaf5e8396.tar.gz
ports-130e7ca4212eccd260ef32aa398a08bbaf5e8396.zip
- Fix build with gcc 4.2
PR: 117203 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com>
Notes
Notes: svn path=/head/; revision=201607
Diffstat (limited to 'net-p2p/lopster')
-rw-r--r--net-p2p/lopster/Makefile6
-rw-r--r--net-p2p/lopster/files/patch-src-log.c12
2 files changed, 13 insertions, 5 deletions
diff --git a/net-p2p/lopster/Makefile b/net-p2p/lopster/Makefile
index d555642f9745..c8cc3fec4e38 100644
--- a/net-p2p/lopster/Makefile
+++ b/net-p2p/lopster/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lopster
PORTVERSION= 1.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://lopster.sourceforge.net/download/
@@ -25,10 +25,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
.if exists(${LOCALBASE}/lib/libogg.so.4)
WITH_OGG= yes
.endif
diff --git a/net-p2p/lopster/files/patch-src-log.c b/net-p2p/lopster/files/patch-src-log.c
new file mode 100644
index 000000000000..93312d4ee4f8
--- /dev/null
+++ b/net-p2p/lopster/files/patch-src-log.c
@@ -0,0 +1,12 @@
+--- src/log.c.orig Mon Oct 15 07:33:46 2007
++++ src/log.c Mon Oct 15 07:33:46 2007
+@@ -148,7 +148,8 @@
+ g_free(log);
+ }
+ g_list_free(net?net->logs:other_logs);
+- net?net->logs:other_logs = NULL;
++ if (net) net->logs = NULL;
++ else other_logs = NULL;
+ }
+
+ void log_file_destroy(log_file_t* lf) {