aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/minder
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:07:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:07:44 +0000
commit30a485e20d88ff1c13132efee6d710a45b7def57 (patch)
tree89bd8655410834677a41bb6a9c2f029c1b2f78e1 /net-p2p/minder
parent506708ce32e8b9b0d049a25f26ca2789a163339b (diff)
downloadports-30a485e20d88ff1c13132efee6d710a45b7def57.tar.gz
ports-30a485e20d88ff1c13132efee6d710a45b7def57.zip
New port minder version 1.1: A small network application for automatic
maintenance of peer lists
Notes
Notes: svn path=/head/; revision=126547
Diffstat (limited to 'net-p2p/minder')
-rw-r--r--net-p2p/minder/Makefile58
-rw-r--r--net-p2p/minder/distinfo2
-rw-r--r--net-p2p/minder/files/patch-Makefile20
-rw-r--r--net-p2p/minder/files/patch-MyTcpSocket.cpp11
-rw-r--r--net-p2p/minder/pkg-descr20
5 files changed, 111 insertions, 0 deletions
diff --git a/net-p2p/minder/Makefile b/net-p2p/minder/Makefile
new file mode 100644
index 000000000000..564930ccd05b
--- /dev/null
+++ b/net-p2p/minder/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: minder
+# Date created: Sun Jan 16 01:16:28 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= minder
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= http://www.alhem.net/project/minder/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A small network application for automatic maintenance of peer lists
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSockets.a:${PORTSDIR}/net/Sockets
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+WITH_OPENSSL_BASE= yes
+MAKE_ENV= CXX="${CXX}"
+USE_REINPLACE= yes
+
+# ssl support
+CFLAGS+= ${PTHREAD_CFLAGS} -DHAVE_OPENSSL
+
+PLIST_DIRS= \
+ %%EXAMPLESDIR%%
+PLIST_FILES= \
+ bin/${PORTNAME} \
+ %%EXAMPLESDIR%%/minder.cfg
+
+post-patch:
+# CXX safeness
+# CXXFLAGS safeness
+# SSL include safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|-O2||' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|^INCLUDE.+$$|INCLUDE=-I${OPENSSLINC} -I${LOCALBASE}/include/Sockets|' \
+ -e 's|^LIBS.+$$|LIBS=-L${OPENSSLLIB} ${PTHREAD_LIBS} -L${LOCALBASE}/lib \\|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -E \
+ -e 's|\(__sighandler_t\)||' \
+ ${WRKSRC}/minder.cpp
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/minder.cfg ${EXAMPLESDIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
+ for building
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/minder/distinfo b/net-p2p/minder/distinfo
new file mode 100644
index 000000000000..370d5e7df823
--- /dev/null
+++ b/net-p2p/minder/distinfo
@@ -0,0 +1,2 @@
+MD5 (minder-1.1.tar.gz) = acc19c86e65fb48b98cb8863b53a0297
+SIZE (minder-1.1.tar.gz) = 5772
diff --git a/net-p2p/minder/files/patch-Makefile b/net-p2p/minder/files/patch-Makefile
new file mode 100644
index 000000000000..3092f680b7d7
--- /dev/null
+++ b/net-p2p/minder/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Sat Jan 15 23:23:22 2005
++++ Makefile Sat Jan 15 23:27:38 2005
+@@ -4,7 +4,7 @@
+ CFLAGS = -Wall -g -O2 $(INCLUDE) -MD
+ CPPFLAGS = $(CFLAGS)
+ LIBS = -L/usr/devel/lib -lSockets \
+- -lssl -lcrypto -luuid -lpthread
++ -lSockets -lssl -lcrypto
+
+ PROGS = minder
+ all: $(PROGS)
+@@ -19,7 +19,7 @@
+ rm -f *.o *~ *.d slask $(PROGS)
+
+ install: all
+- install --strip $(PROGS) /usr/local/bin
++ @${BSD_INSTALL_PROGRAM} $(PROGS) /usr/local/bin
+
+ -include *.d
+
diff --git a/net-p2p/minder/files/patch-MyTcpSocket.cpp b/net-p2p/minder/files/patch-MyTcpSocket.cpp
new file mode 100644
index 000000000000..3acce5a73dcd
--- /dev/null
+++ b/net-p2p/minder/files/patch-MyTcpSocket.cpp
@@ -0,0 +1,11 @@
+--- MyTcpSocket.cpp.orig Sun Jan 16 01:07:56 2005
++++ MyTcpSocket.cpp Sun Jan 16 01:09:39 2005
+@@ -85,7 +85,7 @@
+
+ // we ignore whatever ip the minion sends us
+ // we only use the ip from the connection endpoint
+- ipaddr_t ip2 = GetRemoteIP();
++ ipaddr_t ip2 = GetRemoteIP4();
+ DEB( printf("Incoming: id '%s' %s:%d cmd '%s'\n",id.c_str(),GetRemoteAddress().c_str(),port,cmd.c_str());)
+ if (cmd == "Goodbye")
+ {
diff --git a/net-p2p/minder/pkg-descr b/net-p2p/minder/pkg-descr
new file mode 100644
index 000000000000..39c481e41ada
--- /dev/null
+++ b/net-p2p/minder/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's web site ]
+
+The minder is a small network application for automatic maintenance
+of peer lists. The application accepts connections from other network
+entities ("minions") and returns a list of other identitical minions.
+
+When a minion contacts the minder, the minion supplies its type,
+network port and address, and its unique node identification.
+
+The framework for building a minion is included in the C++ Sockets
+Library. The framework consists of classes representing connections
+between minion-minder and minion-minion, and also a controller class
+for them both.
+
+The minder itself is also built with the C++ Sockets Library as its
+foundation.
+
+WWW: http://www.alhem.net/project/minder/index.html
+
+-- lioux@FreeBSD.org