aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/monero-cli/Makefile
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-10-13 17:57:27 +0000
committerVasil Dimov <vd@FreeBSD.org>2018-10-13 17:57:27 +0000
commit26e9da0ea01a20920ea2d9c84badcb0aaff37204 (patch)
treebd3cd429d205ab151109a0590c626a3dc97fe8bc /net-p2p/monero-cli/Makefile
parent12f8effcc8e2eee36340f0b0e4b9588cc6bd1154 (diff)
downloadports-26e9da0ea01a20920ea2d9c84badcb0aaff37204.tar.gz
ports-26e9da0ea01a20920ea2d9c84badcb0aaff37204.zip
net-p2p/monero-cli: fix compilation on FreeBSD < 12
-DMANUAL_SUBMODULES:BOOL=ON was mistakenly provided only on 12.x, should be used always. While I am here, pet portlint.
Notes
Notes: svn path=/head/; revision=482004
Diffstat (limited to 'net-p2p/monero-cli/Makefile')
-rw-r--r--net-p2p/monero-cli/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 2851512f0961..478c318a0c84 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= monero-cli
-# To build from an arbitrary git commit comment the following two lines
+# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
PORTVERSION= 0.13.0.2
-PORTREVISION= 0
DISTVERSIONPREFIX= v
# and uncomment the following two lines
#PORTVERSION= 0
@@ -42,6 +41,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
USES= cmake compiler:c++11-lib pkgconfig readline ssl
USE_GITHUB= yes
+
GH_ACCOUNT= monero-project
GH_PROJECT= monero
.if defined(PKGNAMESUFFIX)
@@ -62,7 +62,6 @@ DOXYGEN_CMAKE_BOOL= BUILD_DOCUMENTATION
# See Bug 226996 - net-p2p/monero-cli: fails to link with lld as the system linker
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226996
.if ${OSVERSION} >= 1200000
-ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64
.if ${ARCH} == aarch64
LD_EMULATION= aarch64elf
@@ -76,10 +75,12 @@ LD_EMULATION= elf32ppc
LD_EMULATION= elf64ppc
.endif
-CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION} \
- -DMANUAL_SUBMODULES:BOOL=ON
+CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
+
.endif
+CMAKE_ARGS+= -DMANUAL_SUBMODULES:BOOL=ON
+
USE_RC_SUBR= monerod
USERS= monero