aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/namecoin/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-06-11 05:42:58 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-06-11 05:42:58 +0000
commit62c7c30f2d557fefb1c72e1141a1d90ade633ec6 (patch)
treee1c1b64100613726e045dad0ddc0092dd7109421 /net-p2p/namecoin/Makefile
parent959d1cf9a62e0e9e76aa14d78836439d460cc241 (diff)
downloadports-62c7c30f2d557fefb1c72e1141a1d90ade633ec6.tar.gz
ports-62c7c30f2d557fefb1c72e1141a1d90ade633ec6.zip
net-p2p/namecoin: 0.3.72 -> 0.3.80, adding slaveport -daemon
Changes: https://github.com/namecoin/namecoin/blob/namecoinq-release/changelog.md PR: 193534 Submitted by: Chad J. Milios <milios@ccsys.com>
Notes
Notes: svn path=/head/; revision=389159
Diffstat (limited to 'net-p2p/namecoin/Makefile')
-rw-r--r--net-p2p/namecoin/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index 1733e8078a2f..10327a43dfed 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= namecoin
-PORTVERSION= Q.3.72
-DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTVERSION= 0.3.80
+DISTVERSIONPREFIX= nc
+PORTEPOCH= 1
CATEGORIES= net-p2p dns
MAINTAINER= milios@ccsys.com
COMMENT= Decentralized, open DNS system and general purpose key/value store
+LICENSE= MIT
+
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
OPTIONS_DEFINE= X11 UPNP QRCODES DBUS
@@ -19,10 +21,11 @@ UPNP_DESC= Build with UPNP support
QRCODES_DESC= Build with QR code display
USE_GITHUB= yes
-GH_ACCOUNT= namecoinq
-GH_PROJECT= namecoinq
+GH_ACCOUNT= namecoin
+GH_PROJECT= namecoin
USES= gmake compiler:c++11-lib
+MAKE_JOBS_UNSAFE=yes
USE_OPENSSL= yes
USE_BDB= yes
WANT_BDB_VER= 48
@@ -62,6 +65,7 @@ PLIST_FILES+= bin/${BINARY}
.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= libminiupnpc.so:${PORTSDIR}/net/miniupnpc
+CXXFLAGS+= -I${LOCALBASE}/include/miniupnpc
QMAKE_USE_UPNP= 1
.else
QMAKE_USE_UPNP= -