aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ncdc/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-12-26 17:37:42 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-12-26 17:37:42 +0000
commit13b6f55f994870887278b862dab5cc51ac1bff37 (patch)
treeaf06f95533b7efc2472d0f0cde775baba45e6183 /net-p2p/ncdc/Makefile
parent95cd43d1a7a37ab8b5c5d35edffd855ca36e32e3 (diff)
downloadports-13b6f55f994870887278b862dab5cc51ac1bff37.tar.gz
ports-13b6f55f994870887278b862dab5cc51ac1bff37.zip
- Update to verion 1.6
- Project database library switched from GDBM to SQLite - Add option to build ncdc-db-upgrade PR: ports/163626 Submitted by: Dmitriy Limonov <earl1k@mail.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=288061
Diffstat (limited to 'net-p2p/ncdc/Makefile')
-rw-r--r--net-p2p/ncdc/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/net-p2p/ncdc/Makefile b/net-p2p/ncdc/Makefile
index bdeafd3a0b59..ced4bad8cd37 100644
--- a/net-p2p/ncdc/Makefile
+++ b/net-p2p/ncdc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ncdc
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://dev.yorhel.nl/download/
@@ -15,18 +15,35 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= earl1k@mail.ru
COMMENT= Lightweight direct connect client with ncurses interface
-LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm \
+LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
xml2:${PORTSDIR}/textproc/libxml2
+OPTIONS= GDBM "Build ncdc-db-upgrade" off
+
USE_GNOME= glib20
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
-MAN1= ncdc.1 ncdc-gen-cert.1
+MAN1= ncdc.1 ncdc-gen-cert.1 ncdc-db-upgrade.1
PLIST_FILES= bin/ncdc bin/ncdc-gen-cert
#force base compiler,linker flags to avoid linking to ncurses from ports
CFLAGS+= -I/usr/include -I${LOCALBASE}/include
LDFLAGS+= -L/usr/lib -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GDBM)
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+PLIST_FILES+= bin/ncdc-db-upgrade
+.else
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/#include <gdbm.h>/d' \
+ ${WRKSRC}/src/fl_local.c
+ @${REINPLACE_CMD} \
+ -e '/have_gdbm=yes/d' \
+ ${WRKSRC}/configure
+.endif
+
.include <bsd.port.mk>