aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/p5-Net-BitTorrent-File
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-02-06 08:28:38 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-02-06 08:28:38 +0000
commit1e29f08d0bb6ba2a703a4146dd83fb7ee2fab0fe (patch)
tree5fd7b398b6f5715d7be4a8fcac492d95105263ac /net-p2p/p5-Net-BitTorrent-File
parente19da5f45570c3da551b0439481cb708015eebf7 (diff)
downloadports-1e29f08d0bb6ba2a703a4146dd83fb7ee2fab0fe.tar.gz
ports-1e29f08d0bb6ba2a703a4146dd83fb7ee2fab0fe.zip
This module handles loading and saveing of .torrent files as well as
providing a convenient way to store torrent file info in memory. Most users of the module will most likely just call the new method with the name of a existing torrent file and use the data from that
Notes
Notes: svn path=/head/; revision=155310
Diffstat (limited to 'net-p2p/p5-Net-BitTorrent-File')
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/Makefile29
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/distinfo3
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/pkg-descr6
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/p5-Net-BitTorrent-File/Makefile b/net-p2p/p5-Net-BitTorrent-File/Makefile
new file mode 100644
index 000000000000..44891551fb44
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-File/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Net-BitTorrent-File
+# Date created: February 06th 2006
+# Whom: Oleg R. Muhutdinov <mor@WhiteLuna.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-BitTorrent-File
+PORTVERSION= 1.02
+CATEGORIES= net-p2p perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-fix
+
+MAINTAINER= mor@WhiteLuna.com
+COMMENT= Perl5 module for handles loading and saveing of .torrent file
+
+BUILD_DEPENDS= ${SITE_PERL}/Convert/Bencode.pm:${PORTSDIR}/converters/p5-Convert-Bencode \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-fix//}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::BitTorrent::File.3
+
+.include <bsd.port.mk>
diff --git a/net-p2p/p5-Net-BitTorrent-File/distinfo b/net-p2p/p5-Net-BitTorrent-File/distinfo
new file mode 100644
index 000000000000..e7ddc0894775
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-File/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-BitTorrent-File-1.02-fix.tar.gz) = 8379335dc0a09e22904f914ca5448842
+SHA256 (Net-BitTorrent-File-1.02-fix.tar.gz) = 5327b9ea29f35285c7b79e5552500aaa660bc2a7463fc782b927964e11db951e
+SIZE (Net-BitTorrent-File-1.02-fix.tar.gz) = 13554
diff --git a/net-p2p/p5-Net-BitTorrent-File/pkg-descr b/net-p2p/p5-Net-BitTorrent-File/pkg-descr
new file mode 100644
index 000000000000..c063313fccca
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-File/pkg-descr
@@ -0,0 +1,6 @@
+This module handles loading and saveing of .torrent files as well as
+providing a convenient way to store torrent file info in memory. Most
+users of the module will most likely just call the new method with the
+name of a existing torrent file and use the data from that.
+
+WWW: http://search.cpan.org/dist/Net-BitTorrent-File/
diff --git a/net-p2p/p5-Net-BitTorrent-File/pkg-plist b/net-p2p/p5-Net-BitTorrent-File/pkg-plist
new file mode 100644
index 000000000000..69dda328ced9
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-File/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/mach/auto/Net/BitTorrent/File/.packlist
+%%SITE_PERL%%/Net/BitTorrent/File.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/BitTorrent/File
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent