aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/py-vertex/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-20 01:22:31 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-20 01:22:31 +0000
commitaf78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a (patch)
tree1fdd1cedc285d715bdeb43a619517f321e512014 /net-p2p/py-vertex/Makefile
parent0f8c1cf11b4be95fb990b0f3e9d68e1a775f4d19 (diff)
downloadports-af78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a.tar.gz
ports-af78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a.zip
Vertex is an implementation of the Q2Q protocol (sort of like P2P, but one
better). There are a few moving parts in Vertex: * PTCP: a protocol which is nearly identical to TCP, but which runs over UDP. This lets Q2Q penetrate most NAT configurations. * JUICE ([JU]ice [I]s [C]oncurrent [E]vents): a very simple but immensely flexible protocol which forms the basis of the high-level aspects of Q2Q * vertex: a command line tool which exposes a few features useful in many situations (such as registration and authentication) The Q2Q network has some decentralized features (there is no one server or company which can control all Q2Q addresses) and features of centralization (addresses beneath a particular domain are issued by a server for that domain; once issued, some activities require the server to be contacted again, while others do not). Vertex includes an identity server capable of hosting Q2Q addresses. WWW: http://divmod.org/trac/wiki/DivmodVertex PR: ports/97506 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com> Approved by: lawrance (mentor)
Notes
Notes: svn path=/head/; revision=162846
Diffstat (limited to 'net-p2p/py-vertex/Makefile')
-rw-r--r--net-p2p/py-vertex/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/py-vertex/Makefile b/net-p2p/py-vertex/Makefile
new file mode 100644
index 000000000000..1d441f38ef5a
--- /dev/null
+++ b/net-p2p/py-vertex/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-vertex
+# Date created: 19 May 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vertex
+PORTVERSION= 0.1
+CATEGORIES= net-p2p python
+MASTER_SITES= http://divmod.org/static/projects/vertex/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Vertex-${PORTVERSION}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Vertex is an implementation of the Q2Q protocol
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsilon \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsilon \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_TWISTED= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>