aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-04-24 17:43:08 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-04-24 17:43:08 +0000
commit460a0d8a1cdea35874a355dd20ea1d4ebe305e33 (patch)
tree7672c767c12819733d47e85f8f4c094151fe4a25 /net-p2p/qbittorrent
parent65a62eafebc1acb04271cb23a7b342125b867c27 (diff)
downloadports-460a0d8a1cdea35874a355dd20ea1d4ebe305e33.tar.gz
ports-460a0d8a1cdea35874a355dd20ea1d4ebe305e33.zip
Update to 3.3.12
PR: 218817 Approved by: yuri@rawbw.com (maintainer), swills (mentor) Differential Revision: https://reviews.freebsd.org/D10464
Notes
Notes: svn path=/head/; revision=439338
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile3
-rw-r--r--net-p2p/qbittorrent/distinfo6
-rw-r--r--net-p2p/qbittorrent/files/patch-src_base_http_server.cpp25
-rw-r--r--net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp35
4 files changed, 8 insertions, 61 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index e4e6063a8a5b..404f4b409781 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.3.11
-PORTREVISION= 1
+PORTVERSION= 3.3.12
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index ef6eec52390b..9c397c216e5c 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1488638509
-SHA256 (qbittorrent-3.3.11.tar.xz) = 4892ac5ed4bde2ed325fb67456698e703bb933b9eb1d146598259f4e2154a760
-SIZE (qbittorrent-3.3.11.tar.xz) = 2986312
+TIMESTAMP = 1492894034
+SHA256 (qbittorrent-3.3.12.tar.xz) = 56528c47f09b316ecf682e3896157c76c18898ef996728b0c5186e05a711466f
+SIZE (qbittorrent-3.3.12.tar.xz) = 2989604
diff --git a/net-p2p/qbittorrent/files/patch-src_base_http_server.cpp b/net-p2p/qbittorrent/files/patch-src_base_http_server.cpp
deleted file mode 100644
index 287e8b4d18a7..000000000000
--- a/net-p2p/qbittorrent/files/patch-src_base_http_server.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
-# Missing header; upstream patch shuffles them a bit
-#
---- src/base/http/server.cpp.orig 2017-03-03 23:20:21 UTC
-+++ src/base/http/server.cpp
-@@ -28,14 +28,18 @@
- * exception statement from your version.
- */
-
-+#include "server.h"
-+
-+#include <QNetworkProxy>
-+#include <QStringList>
-+
- #ifndef QT_NO_OPENSSL
- #include <QSslSocket>
- #else
- #include <QTcpSocket>
- #endif
--#include <QNetworkProxy>
-+
- #include "connection.h"
--#include "server.h"
-
- using namespace Http;
-
diff --git a/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
index f401c5bf742b..72f4a55523d9 100644
--- a/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
+++ b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
@@ -1,10 +1,8 @@
# Avoid use of thread local storage on versions prior to which it was supported.
#
-# Qt::escape is part of QtGui, upstream patch replaces it for webui
-#
---- src/base/utils/string.cpp.orig 2017-03-03 23:20:21 UTC
+--- src/base/utils/string.cpp.orig 2017-04-06 16:53:25 UTC
+++ src/base/utils/string.cpp
-@@ -37,7 +37,7 @@
+@@ -38,7 +38,7 @@
#ifdef QBT_USES_QT5
#include <QCollator>
#endif
@@ -13,7 +11,7 @@
#include <QThreadStorage>
#endif
-@@ -146,7 +146,8 @@ bool Utils::String::naturalCompareCaseSe
+@@ -147,7 +147,8 @@ bool Utils::String::naturalCompareCaseSe
{
// provide a single `NaturalCompare` instance for easy use
// https://doc.qt.io/qt-5/threads-reentrancy.html
@@ -23,7 +21,7 @@
static QThreadStorage<NaturalCompare> nCmp;
if (!nCmp.hasLocalData()) nCmp.setLocalData(NaturalCompare(true));
return (nCmp.localData())(left, right);
-@@ -160,7 +161,8 @@ bool Utils::String::naturalCompareCaseIn
+@@ -161,7 +162,8 @@ bool Utils::String::naturalCompareCaseIn
{
// provide a single `NaturalCompare` instance for easy use
// https://doc.qt.io/qt-5/threads-reentrancy.html
@@ -33,28 +31,3 @@
static QThreadStorage<NaturalCompare> nCmp;
if (!nCmp.hasLocalData()) nCmp.setLocalData(NaturalCompare(false));
return (nCmp.localData())(left, right);
-@@ -217,6 +219,23 @@ QString Utils::String::toHtmlEscaped(con
- #ifdef QBT_USES_QT5
- return str.toHtmlEscaped();
- #else
-- return Qt::escape(str);
-+ // code from Qt
-+ QString rich;
-+ const int len = str.length();
-+ rich.reserve(int(len * 1.1));
-+ for (int i = 0; i < len; ++i) {
-+ if (str.at(i) == QLatin1Char('<'))
-+ rich += QLatin1String("&lt;");
-+ else if (str.at(i) == QLatin1Char('>'))
-+ rich += QLatin1String("&gt;");
-+ else if (str.at(i) == QLatin1Char('&'))
-+ rich += QLatin1String("&amp;");
-+ else if (str.at(i) == QLatin1Char('"'))
-+ rich += QLatin1String("&quot;");
-+ else
-+ rich += str.at(i);
-+ }
-+ rich.squeeze();
-+ return rich;
- #endif
- }