aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/radarr/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-10-18 06:53:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-10-19 09:36:46 +0000
commit2170798e835f90876b763b641ef2f9bd9f75530a (patch)
tree9f673510cd331b39310cbfe8eea1b5d1daad8203 /net-p2p/radarr/Makefile
parent96891d73b1ed44d983a5296a1510816e6064e2b1 (diff)
downloadports-2170798e835f90876b763b641ef2f9bd9f75530a.tar.gz
ports-2170798e835f90876b763b641ef2f9bd9f75530a.zip
net-p2p/*arr: Switch back to converters/libiconv dependency
In PR 274169 all *arr ports were switched to use 'USES+=libiconv' instead of a hard dependency on the 'converters/libiconv' port. Turns out, this is incorrect. Specifically 'libMonoPosixHelper' (part of .NET) is compiled against the port, and will break when the port is not installed (incompatible with the base version of libiconv) This patch moves all *arr ports back to RUN_DEPENDS on converters/libiconv PR: 274532 Reported by: michiel@vanbaak.eu (maintainer)
Diffstat (limited to 'net-p2p/radarr/Makefile')
-rw-r--r--net-p2p/radarr/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-p2p/radarr/Makefile b/net-p2p/radarr/Makefile
index 26c6bb13964f..08923f35853b 100644
--- a/net-p2p/radarr/Makefile
+++ b/net-p2p/radarr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= radarr
DISTVERSION= 5.0.3.8127
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Radarr/Radarr/releases/download/v${PORTVERSION}/
DISTNAME= Radarr.master.${DISTVERSION}.freebsd-core-x64
@@ -16,10 +17,11 @@ ONLY_FOR_ARCHS= amd64
RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss \
icu>0:devel/icu \
krb5>0:security/krb5 \
+ libiconv>0:converters/libiconv \
libinotify>0:devel/libinotify \
libunwind>0:devel/libunwind
-USES= ssl:run sqlite:3 iconv
+USES= ssl:run sqlite:3
USE_RC_SUBR= ${PORTNAME}