aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-05-17 11:25:22 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-05-17 11:25:22 +0000
commit2802fd279fb35deeb14c4072a12c8d1062640c5a (patch)
tree35a22561086a9c404a18d3617cf72d2e6d5755ed /net-p2p
parent5f18f86e19e667257fb14d2ddf1c7b84a56d4b3e (diff)
downloadports-2802fd279fb35deeb14c4072a12c8d1062640c5a.tar.gz
ports-2802fd279fb35deeb14c4072a12c8d1062640c5a.zip
- Transform libtorrent into a master port.
- Add libtorrent-devel, the development version of libtorrent.
Notes
Notes: svn path=/head/; revision=162643
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/libtorrent-devel/Makefile23
-rw-r--r--net-p2p/libtorrent-devel/distinfo3
-rw-r--r--net-p2p/libtorrent-devel/pkg-plist25
-rw-r--r--net-p2p/libtorrent/Makefile11
5 files changed, 59 insertions, 4 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index a0db23580a5c..6dde0ed98a63 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -52,6 +52,7 @@
SUBDIR += libfreenet
SUBDIR += libpdtp
SUBDIR += libtorrent
+ SUBDIR += libtorrent-devel
SUBDIR += limewire
SUBDIR += linux-agsatellite
SUBDIR += linux-edonkey-core
diff --git a/net-p2p/libtorrent-devel/Makefile b/net-p2p/libtorrent-devel/Makefile
new file mode 100644
index 000000000000..c26125d2cdd3
--- /dev/null
+++ b/net-p2p/libtorrent-devel/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libtorrent-devel
+# Date created: May 17 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtorrent-devel
+PORTVERSION= 0.9.1
+PORTREVISION= 0
+DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= BitTorrent Library written in C++ (development version)
+
+MASTERDIR= ${.CURDIR}/../libtorrent
+MD5_FILE= ${.CURDIR}/distinfo
+PLIST= ${.CURDIR}/pkg-plist
+DESCR= ${MASTERDIR}/pkg-descr
+
+CONFLICTS= libtorrent-[0-9]*
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/libtorrent-devel/distinfo b/net-p2p/libtorrent-devel/distinfo
new file mode 100644
index 000000000000..a6275d524ca9
--- /dev/null
+++ b/net-p2p/libtorrent-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtorrent-0.9.1.tar.gz) = 622c448cd73d1c15963c0ae709d5335d
+SHA256 (libtorrent-0.9.1.tar.gz) = 98a634d361922a7f41b7bd18f21c3c98749908046117b11ca43d414cbcd62e05
+SIZE (libtorrent-0.9.1.tar.gz) = 462098
diff --git a/net-p2p/libtorrent-devel/pkg-plist b/net-p2p/libtorrent-devel/pkg-plist
new file mode 100644
index 000000000000..8ebd31e2b59a
--- /dev/null
+++ b/net-p2p/libtorrent-devel/pkg-plist
@@ -0,0 +1,25 @@
+include/torrent/bitfield.h
+include/torrent/connection_manager.h
+include/torrent/download.h
+include/torrent/event.h
+include/torrent/exceptions.h
+include/torrent/file.h
+include/torrent/file_list.h
+include/torrent/http.h
+include/torrent/object.h
+include/torrent/object_stream.h
+include/torrent/path.h
+include/torrent/peer.h
+include/torrent/piece.h
+include/torrent/poll.h
+include/torrent/poll_epoll.h
+include/torrent/poll_kqueue.h
+include/torrent/poll_select.h
+include/torrent/rate.h
+include/torrent/torrent.h
+include/torrent/tracker.h
+include/torrent/tracker_list.h
+lib/libtorrent.so
+lib/libtorrent.so.7
+libdata/pkgconfig/libtorrent.pc
+@dirrm include/torrent
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 6cf8c02fbba5..ebe8ce62571d 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -5,16 +5,19 @@
# $FreeBSD$
#
-PORTNAME= libtorrent
-PORTVERSION= 0.8.5
+PORTNAME?= libtorrent
+PORTVERSION?= 0.8.5
+PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
-MAINTAINER= flz@FreeBSD.org
-COMMENT= BitTorrent Library written in C++
+MAINTAINER?= flz@FreeBSD.org
+COMMENT?= BitTorrent Library written in C++
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
+CONFLICTS?= libtorrent-devel-[0-9]*
+
USE_GCC= 3.4
USE_GNOME= pkgconfig gnomehack
INSTALLS_SHLIB= yes