aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-23 13:31:05 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-23 13:31:05 +0000
commit37b2f3e7908addca6aa84e3ed4dc853ffc86739d (patch)
tree31cdff87e567e08ece617402d4975111e9f5a1ce /net-p2p
parent6357c3389453fe8595d10c743e4574e02ecbd488 (diff)
downloadports-37b2f3e7908addca6aa84e3ed4dc853ffc86739d.tar.gz
ports-37b2f3e7908addca6aa84e3ed4dc853ffc86739d.zip
net-p2p/bitcoin-daemon: fix deterministic tarball fallout
PR: 230832 Submitted by: kbowling (maintainer)
Notes
Notes: svn path=/head/; revision=477870
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-daemon/Makefile6
-rw-r--r--net-p2p/bitcoin/files/bitcoin.conf23
2 files changed, 26 insertions, 3 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index e9e8ae04c4a6..3b3a9e5a1977 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../bitcoin
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX= -daemon
COMMENT= Virtual Peer-to-Peer Currency (Daemon)
@@ -27,11 +27,11 @@ CONFIGURE_ARGS= --with-daemon \
PLIST_FILES= bin/bitcoind \
man/man1/bitcoind.1.gz \
- %%ETCDIR%%.conf.sample
+ "@sample %%ETCDIR%%.conf.sample"
USE_RC_SUBR= bitcoind
post-install:
- ${INSTALL_DATA} ${WRKSRC}/contrib/init/bitcoind.conf ${STAGEDIR}${PREFIX}/etc/bitcoin.conf.sample
+ ${INSTALL_DATA} ${FILESDIR}/bitcoin.conf ${STAGEDIR}${PREFIX}/etc/bitcoin.conf.sample
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/bitcoin/files/bitcoin.conf b/net-p2p/bitcoin/files/bitcoin.conf
new file mode 100644
index 000000000000..872a64ef57fc
--- /dev/null
+++ b/net-p2p/bitcoin/files/bitcoin.conf
@@ -0,0 +1,23 @@
+# FreeBSD bitcoind configuration file
+
+# This file is used by bitcoind
+# The GUI and CLI will default to generating and using ~/.bitcoin/bitcoin.conf
+#
+# bitcoin has hundreds of config options and there isn't a single mode of
+# operation (mining, client, testnet etc) that can be easily covered by a
+# sample file.
+#
+# A generator for some common configurations exists at
+# https://jlopp.github.io/bitcoin-core-config-generator/
+
+# Bind to given address and always listen on it. Use [host]:port notation for IPv6
+#bind=<addr>
+
+# Specify your own public IP address.
+#externalip=<ip>
+
+# Listen for incoming connections on non-default port.
+#port=<port>
+
+# Connect via a SOCKS5 proxy
+#proxy=127.0.0.1:9050