aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-23 04:46:03 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-23 04:46:03 +0000
commit538ec7056919bf04833d345f5be3d820e2ba008f (patch)
tree8ab023aa17f8c37f86cc0a3655d7bd645fad629e /net-p2p
parent3cca84bffcf2b41c137053ddc510b6010b3238a4 (diff)
downloadports-538ec7056919bf04833d345f5be3d820e2ba008f.tar.gz
ports-538ec7056919bf04833d345f5be3d820e2ba008f.zip
New port lmule version 1.1.11.b: Port of eMule eDonkey P2P client
using wxWindows class library
Notes
Notes: svn path=/head/; revision=77187
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/Makefile44
-rw-r--r--net-p2p/xmule/distinfo1
-rw-r--r--net-p2p/xmule/files/patch-src::CFile.cpp26
-rw-r--r--net-p2p/xmule/files/patch-src::PPgDirectories.cpp25
-rw-r--r--net-p2p/xmule/files/patch-src::PartFile.cpp25
-rw-r--r--net-p2p/xmule/files/patch-src::Preferences.cpp25
-rw-r--r--net-p2p/xmule/files/patch-src::ServerList.cpp25
-rw-r--r--net-p2p/xmule/files/patch-src::SharedFileList.cpp24
-rw-r--r--net-p2p/xmule/files/patch-src::UDPSocket.cpp29
-rw-r--r--net-p2p/xmule/pkg-descr16
-rw-r--r--net-p2p/xmule/pkg-plist12
11 files changed, 252 insertions, 0 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
new file mode 100644
index 000000000000..4f631b9d4dfa
--- /dev/null
+++ b/net-p2p/xmule/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: lmule
+# Date created: Tue Mar 11 05:06:20 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lmule
+PORTVERSION= 1.1.11.b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lmule
+DISTNAME= ${PORTNAME}-1.1.11b
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Port of eMule eDonkey P2P client using wxWindows class library
+
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
+ wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehier \
+ gnomehack \
+ gnomeprefix \
+ gtk12
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-included-gettext \
+ --with-libintl-prefix=${LOCALBASE} \
+ --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+
+WX_CONFIG?= "${X11BASE}/bin/wx-config"
+
+post-patch:
+# it works for FreeBSD as well
+ @${REINPLACE_CMD} -E \
+ -e 's|(Linux)|FreeBSD/\1|' \
+ ${WRKSRC}/src/*.cpp
+
+.include <bsd.port.mk>
diff --git a/net-p2p/xmule/distinfo b/net-p2p/xmule/distinfo
new file mode 100644
index 000000000000..546c6e7e4f68
--- /dev/null
+++ b/net-p2p/xmule/distinfo
@@ -0,0 +1 @@
+MD5 (lmule-1.1.11b.tar.gz) = a29654040188a28ab72e6a31b61461a8
diff --git a/net-p2p/xmule/files/patch-src::CFile.cpp b/net-p2p/xmule/files/patch-src::CFile.cpp
new file mode 100644
index 000000000000..9a93a9788987
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::CFile.cpp
@@ -0,0 +1,26 @@
+--- src/CFile.cpp.orig Sun Mar 23 00:13:37 2003
++++ src/CFile.cpp Sun Mar 23 00:16:34 2003
+@@ -53,6 +53,10 @@
+ #define NOMCX
+ #endif
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #elif (defined(__UNIX__) || defined(__GNUWIN32__))
+ #include <unistd.h>
+ #ifdef __GNUWIN32__
+@@ -116,7 +120,11 @@
+ #endif
+
+ #ifndef MAX_PATH
+- #define MAX_PATH 512
++# if (defined(BSD) && (BSD >= 199103))
++# define MAX_PATH MAXPATHLEN
++# else
++# define MAX_PATH 512
++# endif
+ #endif
+
+ // some broken compilers don't have 3rd argument in open() and creat()
diff --git a/net-p2p/xmule/files/patch-src::PPgDirectories.cpp b/net-p2p/xmule/files/patch-src::PPgDirectories.cpp
new file mode 100644
index 000000000000..62e2220c31e3
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::PPgDirectories.cpp
@@ -0,0 +1,25 @@
+--- src/PPgDirectories.cpp.orig Sun Mar 23 00:10:03 2003
++++ src/PPgDirectories.cpp Sun Mar 23 00:10:42 2003
+@@ -1,6 +1,10 @@
+ // PPgDirectories.cpp : implementation file
+ //
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ //#include "stdafx.h"
+ #include "wintypes.h"
+ #include "emule.h"
+@@ -13,7 +17,11 @@
+ #include "wx/xrc/xmlres.h"
+ #include "wx/xrc/xh_all.h"
+
++#if (defined(BSD) && (BSD >= 199103))
++#define MAX_PATH MAXPATHLEN
++#else
+ #define MAX_PATH 2048
++#endif
+
+ #define GetDlgItem(x,clas) XRCCTRL(*this,#x,clas)
+ #define IsDlgButtonChecked(x) XRCCTRL(*this,#x,wxCheckBox)->GetValue()
diff --git a/net-p2p/xmule/files/patch-src::PartFile.cpp b/net-p2p/xmule/files/patch-src::PartFile.cpp
new file mode 100644
index 000000000000..754ef7fba952
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::PartFile.cpp
@@ -0,0 +1,25 @@
+--- src/PartFile.cpp.orig Sun Mar 23 00:11:08 2003
++++ src/PartFile.cpp Sun Mar 23 00:12:13 2003
+@@ -14,6 +14,10 @@
+ //along with this program; if not, write to the Free Software
+ //Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #include "PartFile.h"
+ #include "emule.h"
+ #include "updownclient.h"
+@@ -177,7 +181,11 @@
+ delete gaplist.GetAt(pos);
+ }
+
++#if (defined(BSD) && (BSD >= 199103))
++#define MAX_PATH MAXPATHLEN
++#else
+ #define MAX_PATH 1024
++#endif
+
+ void CPartFile::CreatePartFile(){
+ // use lowest free partfilenumber for free file (InterCeptor)
diff --git a/net-p2p/xmule/files/patch-src::Preferences.cpp b/net-p2p/xmule/files/patch-src::Preferences.cpp
new file mode 100644
index 000000000000..b5362cd0688a
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::Preferences.cpp
@@ -0,0 +1,25 @@
+--- src/Preferences.cpp.orig Tue Mar 18 19:22:47 2003
++++ src/Preferences.cpp Sun Mar 23 00:58:06 2003
+@@ -22,6 +22,10 @@
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #include "wintypes.h"
+ #include "Preferences.h"
+ #include <time.h>
+@@ -41,7 +45,11 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+
++#if (defined(BSD) && (BSD >= 199103))
++#define MAX_PATH MAXPATHLEN
++#else
+ #define MAX_PATH 2048
++#endif
+
+ extern int sprintf(char *__restrict __s,__const char*__restrict __format,...) __attribute__ ((__format__ (__printf__, 2,3)));
+
diff --git a/net-p2p/xmule/files/patch-src::ServerList.cpp b/net-p2p/xmule/files/patch-src::ServerList.cpp
new file mode 100644
index 000000000000..19e5ae392a9d
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::ServerList.cpp
@@ -0,0 +1,25 @@
+--- src/ServerList.cpp.orig Sun Mar 23 00:12:47 2003
++++ src/ServerList.cpp Sun Mar 23 00:13:13 2003
+@@ -15,6 +15,9 @@
+ //along with this program; if not, write to the Free Software
+ //Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
+
+ //#include "stdafx.h"
+ #include "ServerList.h"
+@@ -346,7 +349,12 @@
+
+ #include <wx/txtstrm.h>
+ #include <wx/wfstream.h>
++
++#if (defined(BSD) && (BSD >= 199103))
++#define MAX_PATH MAXPATHLEN
++#else
+ #define MAX_PATH 1024
++#endif
+
+ void CServerList::AddServersFromTextFile(CString strFilename,bool isstaticserver) {
+ wxString strLine;
diff --git a/net-p2p/xmule/files/patch-src::SharedFileList.cpp b/net-p2p/xmule/files/patch-src::SharedFileList.cpp
new file mode 100644
index 000000000000..1fbeec76fb7c
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::SharedFileList.cpp
@@ -0,0 +1,24 @@
+--- src/SharedFileList.cpp.orig Sun Mar 23 01:02:07 2003
++++ src/SharedFileList.cpp Sun Mar 23 01:02:34 2003
+@@ -15,6 +15,10 @@
+ //along with this program; if not, write to the Free Software
+ //Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ //#include "stdafx.h"
+ #include "emule.h"
+ #include "emuleDlg.h"
+@@ -28,6 +32,10 @@
+ #include "ED2KLink.h"
+ #include "packets.h"
+ #include <time.h>
++
++#if (defined(BSD) && (BSD >= 199103))
++#include <libgen.h>
++#endif
+
+ CSharedFileList::CSharedFileList(CPreferences* in_prefs,CServerConnect* in_server,CKnownFileList* in_filelist){
+ app_prefs = in_prefs;
diff --git a/net-p2p/xmule/files/patch-src::UDPSocket.cpp b/net-p2p/xmule/files/patch-src::UDPSocket.cpp
new file mode 100644
index 000000000000..e3c102da0700
--- /dev/null
+++ b/net-p2p/xmule/files/patch-src::UDPSocket.cpp
@@ -0,0 +1,29 @@
+--- src/UDPSocket.cpp.orig Sun Mar 23 00:20:02 2003
++++ src/UDPSocket.cpp Sun Mar 23 00:22:39 2003
+@@ -25,7 +25,7 @@
+ static pthread_attr_t attr;//=PTHREAD_CREATE_DETACHED;
+
+ #ifdef __FreeBSD__
+-static pthread_mutex_t gethostby_mutex = PTHREAD_MUTEX_INITIALIZER;
++static wxMutex *s_mutexProtectingGetHostByName;
+
+ static int
+ convert (struct hostent *host, struct hostent *result,
+@@ -131,7 +131,7 @@
+ {
+ struct hostent *host;
+
+- pthread_mutex_lock (&gethostby_mutex);
++ s_mutexProtectingGetHostByName->Lock();
+
+ host = gethostbyname (name);
+ if (!host ||
+@@ -140,7 +140,7 @@
+ result = NULL;
+ }
+
+- pthread_mutex_unlock (&gethostby_mutex);
++ s_mutexProtectingGetHostByName->Unlock();
+ return result;
+ }
+
diff --git a/net-p2p/xmule/pkg-descr b/net-p2p/xmule/pkg-descr
new file mode 100644
index 000000000000..92b4da38544a
--- /dev/null
+++ b/net-p2p/xmule/pkg-descr
@@ -0,0 +1,16 @@
+[ from author's website ]
+
+Port of eMule eDonkey P2P client using wxWindows class library.
+
+Features
+
+* Download/Upload works
+* You can search and add ed2k-links
+* Statistics
+* Shared files tab works
+* Messages tab is now implemented
+* You can manage friends
+* LMule can be minimized to systray
+* You can set nearly all preferences
+
+WWW: http://lmule.sourceforge.net/
diff --git a/net-p2p/xmule/pkg-plist b/net-p2p/xmule/pkg-plist
new file mode 100644
index 000000000000..2b82893cc122
--- /dev/null
+++ b/net-p2p/xmule/pkg-plist
@@ -0,0 +1,12 @@
+bin/lmule
+share/gnome/applications/lmule.desktop
+share/gnome/pixmaps/lmule.xpm
+share/locale/de/LC_MESSAGES/lmule.mo
+share/locale/fr/LC_MESSAGES/lmule.mo
+share/locale/tr/LC_MESSAGES/lmule.mo
+@unexec rmdir %D/share/locale/tr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/tr 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr 2>/dev/null || true
+@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/de 2>/dev/null || true