aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-05-01 09:50:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-05-01 09:50:43 +0000
commit5f893fee5f3734e02cf8df3b22fa291e6cad5830 (patch)
treeaaf2f9b1a460f5a71da2c792cf6a772e8f5fb332 /net-p2p
parent0b82b1aaeec21210085c04b88e0f9cfbfb227fcf (diff)
downloadports-5f893fee5f3734e02cf8df3b22fa291e6cad5830.tar.gz
ports-5f893fee5f3734e02cf8df3b22fa291e6cad5830.zip
- Update net-p2p/bitcoin to 0.12.1.
- Enable DBUS option by default. Desktop systems almost always have DBus installed. - Enable UPNP option by default. Many ISP supplied modems contain a NAT these days. - Remove --disable-reduce-exports. It's disabled by default. - Add bitcoind rc.d script. [1] PR: 208937, 209136 Submitted by: xenophon+fbsdports@irtnog.org [1] Approved by: robbak@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=414405
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-daemon/Makefile10
-rw-r--r--net-p2p/bitcoin-utils/Makefile3
-rw-r--r--net-p2p/bitcoin/Makefile20
-rw-r--r--net-p2p/bitcoin/distinfo4
-rw-r--r--net-p2p/bitcoin/files/bitcoind.in15
5 files changed, 37 insertions, 15 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 95b7d429e026..f40e935bb3eb 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../bitcoin
+PORTREVISION= 0
PKGNAMESUFFIX= -daemon
COMMENT= Virtual Peer-to-Peer Currency (Daemon)
@@ -10,16 +11,17 @@ SLAVE_PORT= yes
ONLY_FOR_ARCHS= amd64 i386 ia64
ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
-OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET
-OPTIONS_DEFAULT= HARDENING WALLET
+OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
+OPTIONS_DEFAULT= HARDENING UPNP WALLET
CONFIGURE_ARGS= --with-daemon \
--without-gui \
--without-libs \
--without-qrencode \
- --without-utils \
- --disable-reduce-exports
+ --without-utils
PLIST_FILES= bin/bitcoind
+USE_RC_SUBR= bitcoind
+
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index 9bdd091896af..134d83a1717a 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -18,8 +18,7 @@ CONFIGURE_ARGS= --without-daemon \
--without-libs \
--without-qrencode \
--with-utils \
- --disable-wallet \
- --disable-reduce-exports
+ --disable-wallet
PLIST_FILES= bin/bitcoin-cli bin/bitcoin-tx
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index ff49d9ccff16..6d1b820a05cb 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bitcoin
-PORTVERSION= 0.11.2
+PORTVERSION= 0.12.1
DISTVERSIONPREFIX= v
CATEGORIES= net-p2p finance
@@ -11,7 +11,8 @@ COMMENT?= Virtual Peer-to-Peer Currency Client (QT)
LICENSE= MIT
-LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
+ libevent.so:devel/libevent2
USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix
SHEBANG_FILES= src/test/*.py
@@ -34,14 +35,15 @@ TESTS_PLIST_FILES= %%QT_BINDIR%%/test_bitcoin-qt \
bin/test_bitcoin
.endif
-OPTIONS_DEFINE?= DBUS DEBUG HARDENING QRCODES TESTS UPNP WALLET
-OPTIONS_DEFAULT?= HARDENING QRCODES WALLET
+OPTIONS_DEFINE?= DBUS DEBUG HARDENING QRCODES TESTS UPNP WALLET ZMQ
+OPTIONS_DEFAULT?= DBUS HARDENING QRCODES UPNP WALLET
OPTIONS_SUB= yes
HARDENING_DESC= Attempt to harden binaries (PIE for ASLR, NX Stack)
QRCODES_DESC= Display QR Codes
TESTS_DESC= Build test binary and unit tests
WALLET_DESC= Wallet Management Support
+ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= qtdbus
DBUS_USE= QT4=dbus
@@ -51,10 +53,11 @@ DEBUG_INSTALL_TARGET_OFF= install-strip
HARDENING_CONFIGURE_ENABLE= hardening
-TESTS_CONFIGURE_ENABLE= tests
+TESTS_CONFIGURE_ENABLE= tests bench
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "yes"
TESTS_PLIST_FILES= bin/test_bitcoin
.endif
+TESTS_PLIST_FILES+= bin/bench_bitcoin
UPNP_CONFIGURE_WITH= miniupnpc
UPNP_LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
@@ -69,11 +72,14 @@ WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
WALLET_USE= BDB=48
+ZMQ_CONFIGURE_ENABLE= zmq
+ZMQ_BUILD_DEPENDS= libzmq4>0:net/libzmq4
+ZMQ_RUN_DEPENDS= libzmq4>0:net/libzmq4
+
GH_ACCOUNT= bitcoin
CONFIGURE_ARGS?= --without-libs \
- --disable-reduce-exports \
- --with-gui \
+ --with-gui=qt4 \
--without-daemon \
--without-utils
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index 2ff2f55ce21b..cfd7d66485f9 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitcoin-bitcoin-v0.11.2_GH0.tar.gz) = aab2cd0c4f045970d259cf9fcee5785b43180d20ccbbedc1f90480e697696b25
-SIZE (bitcoin-bitcoin-v0.11.2_GH0.tar.gz) = 5955398
+SHA256 (bitcoin-bitcoin-v0.12.1_GH0.tar.gz) = 7bdc287575067461c123e1afcb48843f9f78eb5e6cac95b413e2e09f1f7fc7bd
+SIZE (bitcoin-bitcoin-v0.12.1_GH0.tar.gz) = 6751284
diff --git a/net-p2p/bitcoin/files/bitcoind.in b/net-p2p/bitcoin/files/bitcoind.in
new file mode 100644
index 000000000000..d4a558e837da
--- /dev/null
+++ b/net-p2p/bitcoin/files/bitcoind.in
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: bitcoind
+# REQUIRE: LOGIN
+
+. /etc/rc.subr
+
+name="bitcoind"
+rcvar=bitcoind_enable
+command="%%PREFIX%%/bin/bitcoind"
+
+load_rc_config $name
+run_rc_command "$1"