aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2024-02-28 10:45:12 +0000
committerVasil Dimov <vd@FreeBSD.org>2024-02-28 10:46:12 +0000
commit76e8026e3415271e09ab5fac130e09efe2b4222d (patch)
treeaacf317f24fc001c1360165b76b0f25e27aa322f /net-p2p
parenta9bb575ce82326572fe5cbccddb0b85a253ffe6f (diff)
downloadports-76e8026e3415271e09ab5fac130e09efe2b4222d.tar.gz
ports-76e8026e3415271e09ab5fac130e09efe2b4222d.zip
net-p2p/c-lightning: upgrade from 23.11.2 to 24.02
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/c-lightning/Makefile25
-rw-r--r--net-p2p/c-lightning/distinfo14
-rw-r--r--net-p2p/c-lightning/files/extra-patch-external_libwally-core_src_ccan_ccan_base64_base64.c29
-rw-r--r--net-p2p/c-lightning/pkg-plist2
4 files changed, 21 insertions, 49 deletions
diff --git a/net-p2p/c-lightning/Makefile b/net-p2p/c-lightning/Makefile
index 46e60ede7156..87450d81dc56 100644
--- a/net-p2p/c-lightning/Makefile
+++ b/net-p2p/c-lightning/Makefile
@@ -1,8 +1,7 @@
PORTNAME= c-lightning
# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
-PORTVERSION= 23.11.2
+PORTVERSION= 24.02
DISTVERSIONPREFIX= v
-PORTREVISION= 1
# and uncomment the following two lines (use for example -git-HEAD or -git-f8d8348c)
#PORTVERSION= 0
#PKGNAMESUFFIX= -git-f8d8348c
@@ -18,17 +17,15 @@ BUILD_DEPENDS= bash:shells/bash \
lowdown:textproc/lowdown \
${PYTHON_PKGNAMEPREFIX}mako>=1.0.14:textproc/py-mako@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mrkd>=0.2.0_1:devel/py-mrkd@${PY_FLAVOR}
-LIB_DEPENDS= libgmp.so:math/gmp \
- libsodium.so:security/libsodium
+LIB_DEPENDS= libsodium.so:security/libsodium
RUN_DEPENDS= bitcoin-cli:net-p2p/bitcoin-utils
USES= autoreconf:build \
compiler:c11 \
cpe \
- gettext \
+ gettext-tools:build \
gmake \
libtool \
- python:build \
shebangfix
CPE_VENDOR= elementsproject
BINARY_ALIAS= python=${PYTHON_CMD} python3=${PYTHON_CMD}
@@ -36,9 +33,6 @@ ALL_TARGET= default
SHEBANG_FILES= plugins/clnrest/clnrest.py \
tools/reckless
-EXTRA_PATCHES_aarch64= ${FILESDIR}/extra-patch-external_libwally-core_src_ccan_ccan_base64_base64.c
-EXTRA_PATCHES= ${EXTRA_PATCHES_${ARCH}}
-
OPTIONS_DEFINE= CLNRESTDEPS COMPATIBILITY DEBUG
OPTIONS_MULTI= STORAGE
OPTIONS_MULTI_STORAGE= POSTGRESQL SQLITE
@@ -46,7 +40,8 @@ OPTIONS_RADIO= TESTING
OPTIONS_RADIO_TESTING= ASAN VALGRIND
CLNRESTDEPS_DESC= Install and depend on packages required by the clnrest plugin
-# for d in `grep -E '^[^[:space:]]' work/lightning-23.11.2/plugins/clnrest/requirements.txt |cut -f 1 -d =` ; do echo "=== $d ===" ; portsearch -n "py.*$d" -o path ; done
+# for d in $(grep -E '^[^[:space:]]' work/lightning-*/plugins/clnrest/requirements.txt |cut -f 1 -d =) ; do if [ -z "$(make -V CLNRESTDEPS_RUN_DEPENDS |grep -i "$(make -V PYTHON_PKGNAMEPREFIX)${d/-/.}>")" ] ; then echo "$d" ; fi ; done
+# ignore cryptography (handled separately via USE_PYTHON+=cryptography) and pkgutil-resolve-name (included in Python 3.9)
CLNRESTDEPS_RUN_DEPENDS=\
${PYTHON_PKGNAMEPREFIX}Flask-Cors>0:www/py-flask-cors@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
@@ -110,7 +105,10 @@ OPTIONS_DEFAULT=COMPATIBILITY SQLITE
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLNRESTDEPS}
+USES+= python:3.9+
USE_PYTHON+= cryptography
+.else
+USES+= python:build
.endif
HAS_CONFIGURE= yes
@@ -126,8 +124,8 @@ GIT_COMMIT= ${PKGNAMESUFFIX:C/-git-//}
GIT_COMMIT= ${DISTVERSIONPREFIX}${PORTVERSION}
.endif
GH_TUPLE= ElementsProject:lightning:${GIT_COMMIT} \
- ElementsProject:libwally-core:bb4cd3ac802c7:ext1/external/libwally-core \
- ElementsProject:secp256k1-zkp:ff33018fe765d:ext2/external/libwally-core/src/secp256k1 \
+ ElementsProject:libwally-core:ec348c884e93a:ext1/external/libwally-core \
+ ElementsProject:secp256k1-zkp:1e04d324476f9:ext2/external/libwally-core/src/secp256k1 \
ianlancetaylor:libbacktrace:2446c66076480ce:ext3/external/libbacktrace \
zserge:jsmn:18e9fe42cbfe21d65076f5c77ae2be3:ext4/external/jsmn \
valyala:gheap:67fc83bc953324f4759e52951921d:ext5/external/gheap
@@ -144,7 +142,7 @@ PLIST_SUB= U="${USERS}" G="${GROUPS}"
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
-CPPFLAGS+= -Wno-error=unused-but-set-variable
+CPPFLAGS+= -Wno-error=unused-but-set-variable
.endif
post-install:
@@ -171,6 +169,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/keysend
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/offers
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/pay
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/recover
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/spenderp
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/sql
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/c-lightning/plugins/topology
diff --git a/net-p2p/c-lightning/distinfo b/net-p2p/c-lightning/distinfo
index 203341264c21..20f22c5d9863 100644
--- a/net-p2p/c-lightning/distinfo
+++ b/net-p2p/c-lightning/distinfo
@@ -1,10 +1,10 @@
-TIMESTAMP = 1707727195
-SHA256 (ElementsProject-lightning-v23.11.2_GH0.tar.gz) = 0a37a8312415de505bc06d5dd04b313ce2157ef6612a26df88cd61d16618a736
-SIZE (ElementsProject-lightning-v23.11.2_GH0.tar.gz) = 6766561
-SHA256 (ElementsProject-libwally-core-bb4cd3ac802c7_GH0.tar.gz) = 730855832586831683363ed93517917b8b1a20b42440f4e119955deac2ef2454
-SIZE (ElementsProject-libwally-core-bb4cd3ac802c7_GH0.tar.gz) = 1009990
-SHA256 (ElementsProject-secp256k1-zkp-ff33018fe765d_GH0.tar.gz) = b9ab83539c89d280d5f34f08e5932430932182bee45481666d78ae1aac738909
-SIZE (ElementsProject-secp256k1-zkp-ff33018fe765d_GH0.tar.gz) = 2606353
+TIMESTAMP = 1709099120
+SHA256 (ElementsProject-lightning-v24.02_GH0.tar.gz) = f6c1b8d1a839e3e4b7872a240dd4493f3e8bf30c1218cf3925e4df61e298bc8c
+SIZE (ElementsProject-lightning-v24.02_GH0.tar.gz) = 7336498
+SHA256 (ElementsProject-libwally-core-ec348c884e93a_GH0.tar.gz) = 6a56dcc73f589951db058eb66a3e95e33890c416492f9d1cdf4c68f0b31847c8
+SIZE (ElementsProject-libwally-core-ec348c884e93a_GH0.tar.gz) = 1037396
+SHA256 (ElementsProject-secp256k1-zkp-1e04d324476f9_GH0.tar.gz) = b987949687db5290fd9cf84029df7ccfecc6787358f9350c7190645969957e0a
+SIZE (ElementsProject-secp256k1-zkp-1e04d324476f9_GH0.tar.gz) = 2769795
SHA256 (ianlancetaylor-libbacktrace-2446c66076480ce_GH0.tar.gz) = 3be5fde76f559cdaef40386c1f2e85e35cc2c8df6fbf0ae98134f80a1c037cf0
SIZE (ianlancetaylor-libbacktrace-2446c66076480ce_GH0.tar.gz) = 665689
SHA256 (zserge-jsmn-18e9fe42cbfe21d65076f5c77ae2be3_GH0.tar.gz) = 2e90b8b42876f384ba229097cd9f8534250683abb135256843b538cb45dd907f
diff --git a/net-p2p/c-lightning/files/extra-patch-external_libwally-core_src_ccan_ccan_base64_base64.c b/net-p2p/c-lightning/files/extra-patch-external_libwally-core_src_ccan_ccan_base64_base64.c
deleted file mode 100644
index d577ba598d09..000000000000
--- a/net-p2p/c-lightning/files/extra-patch-external_libwally-core_src_ccan_ccan_base64_base64.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- external/libwally-core/src/ccan/ccan/base64/base64.c.orig 2023-07-18 11:13:39 UTC
-+++ external/libwally-core/src/ccan/ccan/base64/base64.c
-@@ -34,7 +34,7 @@ static int8_t sixbit_from_b64(const base64_maps_t *map
- int8_t ret;
-
- ret = maps->decode_map[(unsigned char)b64letter];
-- if (ret == (char)0xff) {
-+ if (ret == -1) {
- errno = EDOM;
- return -1;
- }
-@@ -44,7 +44,7 @@ bool base64_char_in_alphabet(const base64_maps_t *maps
-
- bool base64_char_in_alphabet(const base64_maps_t *maps, const char b64char)
- {
-- return (maps->decode_map[(const unsigned char)b64char] != (char)0xff);
-+ return (maps->decode_map[(const unsigned char)b64char] != -1);
- }
-
- void base64_init_maps(base64_maps_t *dest, const char src[64])
-@@ -52,7 +52,7 @@ void base64_init_maps(base64_maps_t *dest, const char
- unsigned char i;
-
- memcpy(dest->encode_map,src,64);
-- memset(dest->decode_map,0xff,256);
-+ memset(dest->decode_map,-1,256);
- for (i=0; i<64; i++) {
- dest->decode_map[(unsigned char)src[i]] = i;
- }
diff --git a/net-p2p/c-lightning/pkg-plist b/net-p2p/c-lightning/pkg-plist
index c55d8fa0d61b..66fcff8feceb 100644
--- a/net-p2p/c-lightning/pkg-plist
+++ b/net-p2p/c-lightning/pkg-plist
@@ -41,6 +41,7 @@ libexec/c-lightning/plugins/funder
libexec/c-lightning/plugins/keysend
libexec/c-lightning/plugins/offers
libexec/c-lightning/plugins/pay
+libexec/c-lightning/plugins/recover
libexec/c-lightning/plugins/spenderp
libexec/c-lightning/plugins/sql
libexec/c-lightning/plugins/topology
@@ -80,6 +81,7 @@ man/man7/lightning-delexpiredinvoice.7.gz
man/man7/lightning-delforward.7.gz
man/man7/lightning-delinvoice.7.gz
man/man7/lightning-delpay.7.gz
+man/man7/lightning-deprecations.7.gz
man/man7/lightning-disableinvoicerequest.7.gz
man/man7/lightning-disableoffer.7.gz
man/man7/lightning-disconnect.7.gz