aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorVidar Karlsen <vidar@karlsen.tech>2024-11-08 13:47:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2024-11-08 13:48:48 +0000
commit882b9da2bd915533c6430b395cc641c91a10cdde (patch)
tree0bde9f0a8460b7f54a6ee35d1b8ee98a21521c63 /net-p2p
parentc70d1de4a1bb2631e37bbcfe311a007c96ab32f3 (diff)
net-p2p/warpinator: New port
Warpinator allows you to easily connect multiple computers on a local area network and share files quickly and securely PR: 257423
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/warpinator/Makefile46
-rw-r--r--net-p2p/warpinator/distinfo3
-rw-r--r--net-p2p/warpinator/pkg-descr2
-rw-r--r--net-p2p/warpinator/pkg-plist117
5 files changed, 169 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 4f847f134953..baed38f9ccb0 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -103,6 +103,7 @@
SUBDIR += udpt
SUBDIR += uhub
SUBDIR += vuze
+ SUBDIR += warpinator
SUBDIR += xbt
SUBDIR += xmrig
diff --git a/net-p2p/warpinator/Makefile b/net-p2p/warpinator/Makefile
new file mode 100644
index 000000000000..4815eaffa31d
--- /dev/null
+++ b/net-p2p/warpinator/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= warpinator
+DISTVERSION= 1.8.5
+CATEGORIES= net-p2p gnome
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= gnome
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Share files across the LAN
+WWW= https://github.com/linuxmint/warpinator
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}grpcio-tools>0:devel/py-grpcio-tools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qrcode>0:textproc/py-qrcode@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}grpcio>=1.16.0:devel/py-grpcio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ifaddr>0:net/py-ifaddr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netifaces>=0:net/py-netifaces@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=0:security/py-pynacl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-xapp>=1.6.0:x11/py-python-xapp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setproctitle>=0:devel/py-setproctitle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zeroconf>=0.27.0:net/py-zeroconf@${PY_FLAVOR} \
+ xapp>=0:x11/xapp
+
+USES= gettext gnome meson python:3.8+ shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+USE_GNOME= glib20 gtk30 pygobject3
+GLIB_SCHEMAS= org.x.Warpinator.gschema.xml
+
+SHEBANG_FILES= bin/warpinator-send.in bin/warpinator.in data/warpinator-send-check \
+ generate-protobuf testing/testrun
+SHEBANG_GLOB= *.py
+MESON_ARGS= -Dbundle-grpc=false \
+ -Dbundle-zeroconf=false \
+ -Dflatpak-build=false \
+ -Dinclude-firewall-mod=false
+BINARY_ALIAS= python3=${PYTHON_CMD}
+NO_ARCH= yes
+
+pre-build:
+ cd ${WRKSRC} && ./generate-protobuf
+
+.include <bsd.port.mk>
diff --git a/net-p2p/warpinator/distinfo b/net-p2p/warpinator/distinfo
new file mode 100644
index 000000000000..11c33d26455c
--- /dev/null
+++ b/net-p2p/warpinator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1720273267
+SHA256 (gnome/linuxmint-warpinator-1.8.5_GH0.tar.gz) = 809462012622bfdbdc6d0f3ae1196c690c8f786e6136c350d30f3eef6edc1f9a
+SIZE (gnome/linuxmint-warpinator-1.8.5_GH0.tar.gz) = 48192108
diff --git a/net-p2p/warpinator/pkg-descr b/net-p2p/warpinator/pkg-descr
new file mode 100644
index 000000000000..35fe6d17250c
--- /dev/null
+++ b/net-p2p/warpinator/pkg-descr
@@ -0,0 +1,2 @@
+Warpinator allows you to easily connect multiple computers on a local area
+network and share files quickly and securely.
diff --git a/net-p2p/warpinator/pkg-plist b/net-p2p/warpinator/pkg-plist
new file mode 100644
index 000000000000..907cf2c3f1b6
--- /dev/null
+++ b/net-p2p/warpinator/pkg-plist
@@ -0,0 +1,117 @@
+bin/warpinator
+bin/warpinator-send
+etc/xdg/autostart/warpinator-autostart.desktop
+libexec/warpinator/auth.py
+libexec/warpinator/config.py
+libexec/warpinator/dbus_service.py
+libexec/warpinator/interceptors.py
+libexec/warpinator/landlock/LICENSE
+libexec/warpinator/landlock/__init__.py
+libexec/warpinator/landlock/plumbing.py
+libexec/warpinator/landlock/porcelain.py
+libexec/warpinator/misc.py
+libexec/warpinator/networkmonitor.py
+libexec/warpinator/notifications.py
+libexec/warpinator/ops.py
+libexec/warpinator/prefs.py
+libexec/warpinator/remote.py
+libexec/warpinator/remote_registration.py
+libexec/warpinator/server.py
+libexec/warpinator/transfers.py
+libexec/warpinator/util.py
+libexec/warpinator/warp_pb2.py
+libexec/warpinator/warp_pb2_grpc.py
+libexec/warpinator/warpinator-launch.py
+libexec/warpinator/warpinator.py
+share/applications/org.x.Warpinator.desktop
+share/icons/hicolor/128x128/apps/org.x.Warpinator.png
+share/icons/hicolor/128x128@2/apps/org.x.Warpinator.png
+share/icons/hicolor/16x16/apps/org.x.Warpinator.png
+share/icons/hicolor/16x16@2/apps/org.x.Warpinator.png
+share/icons/hicolor/22x22/apps/org.x.Warpinator.png
+share/icons/hicolor/22x22@2/apps/org.x.Warpinator.png
+share/icons/hicolor/24x24/apps/org.x.Warpinator.png
+share/icons/hicolor/24x24@2/apps/org.x.Warpinator.png
+share/icons/hicolor/256x256/apps/org.x.Warpinator.png
+share/icons/hicolor/256x256@2/apps/org.x.Warpinator.png
+share/icons/hicolor/32x32/apps/org.x.Warpinator.png
+share/icons/hicolor/32x32@2/apps/org.x.Warpinator.png
+share/icons/hicolor/48x48/apps/org.x.Warpinator.png
+share/icons/hicolor/48x48@2/apps/org.x.Warpinator.png
+share/icons/hicolor/64x64/apps/org.x.Warpinator.png
+share/icons/hicolor/64x64@2/apps/org.x.Warpinator.png
+share/icons/hicolor/96x96/apps/org.x.Warpinator.png
+share/icons/hicolor/96x96@2/apps/org.x.Warpinator.png
+share/icons/hicolor/scalable/apps/org.x.Warpinator-error-symbolic.svg
+share/icons/hicolor/scalable/apps/org.x.Warpinator-symbolic.svg
+share/locale/am/LC_MESSAGES/warpinator.mo
+share/locale/ar/LC_MESSAGES/warpinator.mo
+share/locale/be/LC_MESSAGES/warpinator.mo
+share/locale/bg/LC_MESSAGES/warpinator.mo
+share/locale/bn/LC_MESSAGES/warpinator.mo
+share/locale/ca/LC_MESSAGES/warpinator.mo
+share/locale/cs/LC_MESSAGES/warpinator.mo
+share/locale/cy/LC_MESSAGES/warpinator.mo
+share/locale/da/LC_MESSAGES/warpinator.mo
+share/locale/de/LC_MESSAGES/warpinator.mo
+share/locale/el/LC_MESSAGES/warpinator.mo
+share/locale/en_CA/LC_MESSAGES/warpinator.mo
+share/locale/en_GB/LC_MESSAGES/warpinator.mo
+share/locale/eo/LC_MESSAGES/warpinator.mo
+share/locale/es/LC_MESSAGES/warpinator.mo
+share/locale/et/LC_MESSAGES/warpinator.mo
+share/locale/eu/LC_MESSAGES/warpinator.mo
+share/locale/fa/LC_MESSAGES/warpinator.mo
+share/locale/fi/LC_MESSAGES/warpinator.mo
+share/locale/fr/LC_MESSAGES/warpinator.mo
+share/locale/fr_CA/LC_MESSAGES/warpinator.mo
+share/locale/fy/LC_MESSAGES/warpinator.mo
+share/locale/he/LC_MESSAGES/warpinator.mo
+share/locale/hi/LC_MESSAGES/warpinator.mo
+share/locale/hr/LC_MESSAGES/warpinator.mo
+share/locale/hu/LC_MESSAGES/warpinator.mo
+share/locale/ia/LC_MESSAGES/warpinator.mo
+share/locale/id/LC_MESSAGES/warpinator.mo
+share/locale/ie/LC_MESSAGES/warpinator.mo
+share/locale/is/LC_MESSAGES/warpinator.mo
+share/locale/it/LC_MESSAGES/warpinator.mo
+share/locale/ja/LC_MESSAGES/warpinator.mo
+share/locale/kab/LC_MESSAGES/warpinator.mo
+share/locale/kk/LC_MESSAGES/warpinator.mo
+share/locale/kn/LC_MESSAGES/warpinator.mo
+share/locale/ko/LC_MESSAGES/warpinator.mo
+share/locale/ku/LC_MESSAGES/warpinator.mo
+share/locale/la/LC_MESSAGES/warpinator.mo
+share/locale/lt/LC_MESSAGES/warpinator.mo
+share/locale/ne/LC_MESSAGES/warpinator.mo
+share/locale/nl/LC_MESSAGES/warpinator.mo
+share/locale/oc/LC_MESSAGES/warpinator.mo
+share/locale/pa/LC_MESSAGES/warpinator.mo
+share/locale/pl/LC_MESSAGES/warpinator.mo
+share/locale/pt/LC_MESSAGES/warpinator.mo
+share/locale/pt_BR/LC_MESSAGES/warpinator.mo
+share/locale/ro/LC_MESSAGES/warpinator.mo
+share/locale/ru/LC_MESSAGES/warpinator.mo
+share/locale/sk/LC_MESSAGES/warpinator.mo
+share/locale/sl/LC_MESSAGES/warpinator.mo
+share/locale/sr/LC_MESSAGES/warpinator.mo
+share/locale/sr@latin/LC_MESSAGES/warpinator.mo
+share/locale/sv/LC_MESSAGES/warpinator.mo
+share/locale/tl/LC_MESSAGES/warpinator.mo
+share/locale/tr/LC_MESSAGES/warpinator.mo
+share/locale/uk/LC_MESSAGES/warpinator.mo
+share/locale/uz/LC_MESSAGES/warpinator.mo
+share/locale/vi/LC_MESSAGES/warpinator.mo
+share/locale/zgh/LC_MESSAGES/warpinator.mo
+share/locale/zh_CN/LC_MESSAGES/warpinator.mo
+share/locale/zh_HK/LC_MESSAGES/warpinator.mo
+share/locale/zh_TW/LC_MESSAGES/warpinator.mo
+share/metainfo/org.x.Warpinator.appdata.xml
+share/nemo/actions/warpinator-send-check
+share/nemo/actions/warpinator-send.nemo_action
+%%DATADIR%%/group-code.ui
+%%DATADIR%%/main-window.ui
+%%DATADIR%%/manual-connect.ui
+%%DATADIR%%/op-item.ui
+%%DATADIR%%/overview-button.ui
+%%DATADIR%%/prefs-window.ui