aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-26 16:52:22 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-26 16:52:22 +0000
commitaaf4dfde485e1066338dfe42990210fe718b5dc0 (patch)
tree43d979e7eb9aee41564c9e9592a1e22fee151394 /net-p2p
parentd48ac71bab458d04c725ee76b9f3643a626714cb (diff)
downloadports-aaf4dfde485e1066338dfe42990210fe718b5dc0.tar.gz
ports-aaf4dfde485e1066338dfe42990210fe718b5dc0.zip
net-p2p/deluge: split out CLI part
By popular demand split out deluge onto CLI part and GUI part to let users with headless servers or users who do not want to install all the GTK2 stuff install just deluge with minimal required dependencies. deluge-cli port was introduced, that let user to run in CLI mode and to control the queue via web-interface. This change requires all the users of net-p2p/deluge to deinstall it first and then install the required part: - net-p2p/deluge-cli if GTK2 GUI is not required - net-p2p/deluge to get the graphical client (net-p2p/deluge-cli will be installed as a dependency) Requested by: many
Notes
Notes: svn path=/head/; revision=424719
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/deluge-cli/Makefile68
-rw-r--r--net-p2p/deluge-cli/distinfo (renamed from net-p2p/deluge/distinfo)0
-rw-r--r--net-p2p/deluge-cli/files/deluge_web.in (renamed from net-p2p/deluge/files/deluge_web.in)0
-rw-r--r--net-p2p/deluge-cli/files/deluged.in (renamed from net-p2p/deluge/files/deluged.in)0
-rw-r--r--net-p2p/deluge-cli/files/patch-deluge_core_core.py (renamed from net-p2p/deluge/files/patch-deluge_core_core.py)0
-rw-r--r--net-p2p/deluge-cli/files/patch-setup.py (renamed from net-p2p/deluge/files/patch-setup.py)0
-rw-r--r--net-p2p/deluge-cli/pkg-descr8
-rw-r--r--net-p2p/deluge-cli/pkg-plist (renamed from net-p2p/deluge/pkg-plist)2
-rw-r--r--net-p2p/deluge/Makefile69
10 files changed, 84 insertions, 64 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index efcf92806a52..628bba5c961c 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -19,6 +19,7 @@
SUBDIR += ctorrent
SUBDIR += dclib
SUBDIR += deluge
+ SUBDIR += deluge-cli
SUBDIR += digitalcoin
SUBDIR += dogecoin
SUBDIR += ed2k
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
new file mode 100644
index 000000000000..1d4f01fcc503
--- /dev/null
+++ b/net-p2p/deluge-cli/Makefile
@@ -0,0 +1,68 @@
+# $FreeBSD$
+
+PORTNAME= deluge
+PORTVERSION= 1.3.13
+PKGNAMESUFFIX= -cli
+CATEGORIES= net-p2p python
+MASTER_SITES= http://download.deluge-torrent.org/source/
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= CLI part of bittorrent client using Python and libtorrent-rasterbar
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= intltool-merge:textproc/intltool
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg \
+ ${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0:net-p2p/libtorrent-rasterbar-python \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet \
+ ${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako
+
+USE_RC_SUBR= deluged deluge_web
+SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
+
+NO_ARCH= yes
+USES= gettext python:-2.7 tar:xz twisted:run,web
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= ChangeLog README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/"new_release_check":/s|True,|False,|g ; \
+ /"geoip_db_location":/s|/usr/share/GeoIP/GeoIP.dat|${LOCALBASE}/share/GeoIP/GeoIP.dat|g' \
+ ${WRKSRC}/deluge/core/preferencesmanager.py
+ @${REINPLACE_CMD} -e '/"check_new_releases":/s|True,|False,|g ; \
+ /"show_new_releases":/s|True,|False,|g' \
+ ${WRKSRC}/deluge/ui/gtkui/gtkui.py
+
+post-install:
+# do these by hand, else they wind up in the wrong place
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps ; \
+ ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/scalable/apps/deluge.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+.for size in 16 22 24 32 36 48 64 72 96 128 192 256
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps ; \
+ ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/hicolor/${size}x${size}/apps/deluge.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps
+.endfor
+.for pic in png xpm
+ ${INSTALL_DATA} ${WRKSRC}/deluge/data/pixmaps/deluge.${pic} \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+.endfor
+
+# install man pages
+.for man in deluge.1 deluge-console.1 deluge-gtk.1 deluge-web.1 deluged.1
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/${man} ${STAGEDIR}${MANPREFIX}/man/man1/
+.endfor
+
+ ${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/deluge/distinfo b/net-p2p/deluge-cli/distinfo
index 0b23eeba0e2e..0b23eeba0e2e 100644
--- a/net-p2p/deluge/distinfo
+++ b/net-p2p/deluge-cli/distinfo
diff --git a/net-p2p/deluge/files/deluge_web.in b/net-p2p/deluge-cli/files/deluge_web.in
index 63962d773ac3..63962d773ac3 100644
--- a/net-p2p/deluge/files/deluge_web.in
+++ b/net-p2p/deluge-cli/files/deluge_web.in
diff --git a/net-p2p/deluge/files/deluged.in b/net-p2p/deluge-cli/files/deluged.in
index 67c505852f3c..67c505852f3c 100644
--- a/net-p2p/deluge/files/deluged.in
+++ b/net-p2p/deluge-cli/files/deluged.in
diff --git a/net-p2p/deluge/files/patch-deluge_core_core.py b/net-p2p/deluge-cli/files/patch-deluge_core_core.py
index d7b2e29ba71c..d7b2e29ba71c 100644
--- a/net-p2p/deluge/files/patch-deluge_core_core.py
+++ b/net-p2p/deluge-cli/files/patch-deluge_core_core.py
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge-cli/files/patch-setup.py
index d177e1795802..d177e1795802 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge-cli/files/patch-setup.py
diff --git a/net-p2p/deluge-cli/pkg-descr b/net-p2p/deluge-cli/pkg-descr
new file mode 100644
index 000000000000..e006cdc2016c
--- /dev/null
+++ b/net-p2p/deluge-cli/pkg-descr
@@ -0,0 +1,8 @@
+Deluge is a Bittorrent client written in Python and GTK+. Deluge is intended
+to bring a native, full-featured client to Linux, BSD, and other *nix GTK
+desktop environments such as Gnome and Xfce.
+
+Deluge uses Rasterbar's version of libtorrent as the main ingredient in its
+bittorrent protocol backend.
+
+WWW: http://deluge-torrent.org/
diff --git a/net-p2p/deluge/pkg-plist b/net-p2p/deluge-cli/pkg-plist
index 339458fd9047..bb7ab7cd0428 100644
--- a/net-p2p/deluge/pkg-plist
+++ b/net-p2p/deluge-cli/pkg-plist
@@ -82,7 +82,7 @@ man/man1/deluge-console.1.gz
man/man1/deluge-gtk.1.gz
man/man1/deluge-web.1.gz
man/man1/deluged.1.gz
-%%GTK2%%share/applications/deluge.desktop
+share/applications/deluge.desktop
share/icons/hicolor/128x128/apps/deluge.png
share/icons/hicolor/16x16/apps/deluge.png
share/icons/hicolor/192x192/apps/deluge.png
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 848364020a4e..cd772e3b5673 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -2,78 +2,21 @@
PORTNAME= deluge
PORTVERSION= 1.3.13
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-p2p python
-MASTER_SITES= http://download.deluge-torrent.org/source/
MAINTAINER= rm@FreeBSD.org
COMMENT= Bittorrent client using Python, GTK2, and libtorrent-rasterbar
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg \
- ${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0:net-p2p/libtorrent-rasterbar-python \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet \
- ${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako
-
-USE_RC_SUBR= deluged deluge_web
-SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
-
-NO_ARCH= yes
-USES= gettext python:2.7 tar:xz twisted:run,web
-USE_PYTHON= autoplist distutils
-
-OPTIONS_DEFINE= DOCS GTK2
-OPTIONS_DEFAULT=GTK2
-OPTIONS_SUB= yes
-
-GTK2_RUN_DEPENDS= \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game \
${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify \
- xdg-utils>=1.0.2:devel/xdg-utils
-GTK2_USE= gnome=intltool,librsvg2,pygnome2,pygtk2
-GTK2_USES= desktop-file-utils
-GTK2_VARS= installs_icons=yes
-
-PORTDOCS= ChangeLog README
-
-post-patch:
- @${REINPLACE_CMD} -e '/"new_release_check":/s|True,|False,|g ; \
- /"geoip_db_location":/s|/usr/share/GeoIP/GeoIP.dat|${LOCALBASE}/share/GeoIP/GeoIP.dat|g' \
- ${WRKSRC}/deluge/core/preferencesmanager.py
- @${REINPLACE_CMD} -e '/"check_new_releases":/s|True,|False,|g ; \
- /"show_new_releases":/s|True,|False,|g' \
- ${WRKSRC}/deluge/ui/gtkui/gtkui.py
-
-post-install:
-# do these by hand, else they wind up in the wrong place
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps ; \
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/scalable/apps/deluge.svg \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
-.for size in 16 22 24 32 36 48 64 72 96 128 192 256
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps ; \
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/hicolor/${size}x${size}/apps/deluge.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps
-.endfor
-.for pic in png xpm
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/pixmaps/deluge.${pic} \
- ${STAGEDIR}${PREFIX}/share/pixmaps
-.endfor
-
-# install man pages
-.for man in deluge.1 deluge-console.1 deluge-gtk.1 deluge-web.1 deluged.1
- ${INSTALL_MAN} ${WRKSRC}/docs/man/${man} ${STAGEDIR}${MANPREFIX}/man/man1/
-.endfor
-
-post-install-GTK2-on:
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
- ${STAGEDIR}${PREFIX}/share/applications
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ xdg-utils>=1.0.2:devel/xdg-utils \
+ deluge:net-p2p/deluge-cli
+USE_GNOME= librsvg2 pygtk2
+USES= python:-2.7 metaport
.include <bsd.port.mk>