aboutsummaryrefslogtreecommitdiff
path: root/net/Sockets-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 22:23:18 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 22:23:18 +0000
commit09d20d6267078c02cef1bc1f10bca2bb4da4735f (patch)
tree4bce673d86a1bee64c91fe71df767fa7437748ed /net/Sockets-devel
parentc0db5be67ea11c43f43af68b0c5f5a496acc7274 (diff)
downloadports-09d20d6267078c02cef1bc1f10bca2bb4da4735f.tar.gz
ports-09d20d6267078c02cef1bc1f10bca2bb4da4735f.zip
After repo copy from net/Sockets update to development version 1.9.7
Repo copied by: marcus
Notes
Notes: svn path=/head/; revision=143544
Diffstat (limited to 'net/Sockets-devel')
-rw-r--r--net/Sockets-devel/Makefile12
-rw-r--r--net/Sockets-devel/distinfo4
-rw-r--r--net/Sockets-devel/pkg-plist86
3 files changed, 55 insertions, 47 deletions
diff --git a/net/Sockets-devel/Makefile b/net/Sockets-devel/Makefile
index 26ef85b74c2e..6ef02802090c 100644
--- a/net/Sockets-devel/Makefile
+++ b/net/Sockets-devel/Makefile
@@ -1,14 +1,15 @@
-# New ports collection makefile for: C++ Sockets
-# Date created: Sat Jan 15 16:17:20 UTC 2005
+# New ports collection makefile for: C++ Sockets devel
+# Date created: Sun Sep 25 20:27:06 UTC 2005
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Sockets
-PORTVERSION= 1.8.7
+PORTVERSION= 1.9.7
CATEGORIES= net ipv6
MASTER_SITES= http://www.alhem.net/Sockets/
+PKGNAMESUFFIX?= -devel
MAINTAINER= lioux@FreeBSD.org
COMMENT= A C++ wrapper for BSD-style sockets
@@ -23,11 +24,16 @@ post-patch:
# PREFIX safeness
# CXX safeness
# CXXFLAGS safeness
+# rename files to -devel
@${REINPLACE_CMD} -E \
-e 's|-O2||' \
-e 's|^PREFIX.+$$|PREFIX=${PREFIX}|' \
-e 's|^INCLUDE.+$$|INCLUDE=-I. -I${OPENSSLINC}|' \
-e 's|g\+\+|${CXX}|' \
+ -e 's|libSockets.a|libSockets-devel.a|' \
+ -e 's|libSocketsEx.a|libSocketsEx-devel.a|' \
+ -e 's|Sockets-config|Sockets-devel-config|' \
+ -e 's|include/Sockets|include/Sockets-devel|' \
${BUILD_WRKSRC}/${MAKEFILE}
# fix StdLog.h location
@${FIND} ${WRKSRC} -type f | \
diff --git a/net/Sockets-devel/distinfo b/net/Sockets-devel/distinfo
index d1b8c530a582..b942d400094e 100644
--- a/net/Sockets-devel/distinfo
+++ b/net/Sockets-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (Sockets-1.8.7.tar.gz) = 361cc81cb5eaf5aa77a476de827aee80
-SIZE (Sockets-1.8.7.tar.gz) = 77760
+MD5 (Sockets-1.9.7.tar.gz) = 76d43413f649a93150d837d3787fc32f
+SIZE (Sockets-1.9.7.tar.gz) = 89786
diff --git a/net/Sockets-devel/pkg-plist b/net/Sockets-devel/pkg-plist
index 166f5d5e2e8b..fcf70778878f 100644
--- a/net/Sockets-devel/pkg-plist
+++ b/net/Sockets-devel/pkg-plist
@@ -1,42 +1,44 @@
-bin/Sockets-config
-include/Sockets/Base64.h
-include/Sockets/CTcpSocket.h
-include/Sockets/CircularBuffer.h
-include/Sockets/File.h
-include/Sockets/HTTPSocket.h
-include/Sockets/HttpDebugSocket.h
-include/Sockets/HttpGetSocket.h
-include/Sockets/HttpPostSocket.h
-include/Sockets/HttpPutSocket.h
-include/Sockets/HttpdCookies.h
-include/Sockets/HttpdForm.h
-include/Sockets/HttpdSocket.h
-include/Sockets/HttpsGetSocket.h
-include/Sockets/HttpsSocket.h
-include/Sockets/ICrypt.h
-include/Sockets/IFile.h
-include/Sockets/ListenSocket.h
-include/Sockets/MemFile.h
-include/Sockets/MinderHandler.h
-include/Sockets/MinderSocket.h
-include/Sockets/MinionSocket.h
-include/Sockets/NullCrypt.h
-include/Sockets/Parse.h
-include/Sockets/PoolSocket.h
-include/Sockets/ResolvServer.h
-include/Sockets/ResolvSocket.h
-include/Sockets/SSLSocket.h
-include/Sockets/Socket.h
-include/Sockets/SocketHandler.h
-include/Sockets/SocketThread.h
-include/Sockets/StdLog.h
-include/Sockets/StdoutLog.h
-include/Sockets/TcpSocket.h
-include/Sockets/Thread.h
-include/Sockets/UdpSocket.h
-include/Sockets/Uid.h
-include/Sockets/Utility.h
-include/Sockets/socket_include.h
-lib/libSockets.a
-lib/libSocketsEx.a
-@dirrm include/Sockets
+bin/Sockets-devel-config
+include/Sockets-devel/Base64.h
+include/Sockets-devel/CTcpSocket.h
+include/Sockets-devel/CircularBuffer.h
+include/Sockets-devel/File.h
+include/Sockets-devel/HTTPSocket.h
+include/Sockets-devel/HttpDebugSocket.h
+include/Sockets-devel/HttpGetSocket.h
+include/Sockets-devel/HttpPostSocket.h
+include/Sockets-devel/HttpPutSocket.h
+include/Sockets-devel/HttpdCookies.h
+include/Sockets-devel/HttpdForm.h
+include/Sockets-devel/HttpdSocket.h
+include/Sockets-devel/HttpsGetSocket.h
+include/Sockets-devel/HttpsSocket.h
+include/Sockets-devel/ICrypt.h
+include/Sockets-devel/IFile.h
+include/Sockets-devel/ListenSocket.h
+include/Sockets-devel/Lock.h
+include/Sockets-devel/MemFile.h
+include/Sockets-devel/MinderHandler.h
+include/Sockets-devel/MinderSocket.h
+include/Sockets-devel/MinionSocket.h
+include/Sockets-devel/Mutex.h
+include/Sockets-devel/NullCrypt.h
+include/Sockets-devel/Parse.h
+include/Sockets-devel/PoolSocket.h
+include/Sockets-devel/ResolvServer.h
+include/Sockets-devel/ResolvSocket.h
+include/Sockets-devel/SSLSocket.h
+include/Sockets-devel/Socket.h
+include/Sockets-devel/SocketHandler.h
+include/Sockets-devel/SocketThread.h
+include/Sockets-devel/StdLog.h
+include/Sockets-devel/StdoutLog.h
+include/Sockets-devel/TcpSocket.h
+include/Sockets-devel/Thread.h
+include/Sockets-devel/UdpSocket.h
+include/Sockets-devel/Uid.h
+include/Sockets-devel/Utility.h
+include/Sockets-devel/socket_include.h
+lib/libSockets-devel.a
+lib/libSocketsEx-devel.a
+@dirrm include/Sockets-devel