aboutsummaryrefslogtreecommitdiff
path: root/net/activemq/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-31 12:16:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-31 12:16:25 +0000
commit9beb0398ff1d7925d7e28c613766398de6490b19 (patch)
tree05e199ba872ebe4898068758120277be42ec3b4b /net/activemq/Makefile
parent1a46d6a2fd2c97b8e8716da9fb2d4d4c62778a00 (diff)
downloadports-9beb0398ff1d7925d7e28c613766398de6490b19.tar.gz
ports-9beb0398ff1d7925d7e28c613766398de6490b19.zip
- Add LICENSE_FILE
- Switch to options helpers - Switch to @sample Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=395667
Diffstat (limited to 'net/activemq/Makefile')
-rw-r--r--net/activemq/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/net/activemq/Makefile b/net/activemq/Makefile
index 2e354f3dd0f0..bfc8260aad0f 100644
--- a/net/activemq/Makefile
+++ b/net/activemq/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= tj@FreeBSD.org
COMMENT= Messaging and Integration Patterns provider
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES+= cpe
CPE_VENDOR= apache
@@ -67,26 +68,12 @@ PLIST_SUB= MQUSER="${MQUSER}" \
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|activemq.base}/data|activemq.logs}|g' ${WRKSRC}/conf/log4j.properties
do-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
-.for f in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
-.endfor
-.endif
-
@${MKDIR} ${STAGEDIR}${MQDATA} ${STAGEDIR}${MQDATA}/bin ${STAGEDIR}${ETCDIR}
-.if ${PORT_OPTIONS:MEXAMPLES}
- @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.endif
-
.for f in ${ETC_FILES}
${INSTALL_DATA} ${WRKSRC}/conf/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
.endfor
@@ -107,4 +94,14 @@ do-install:
@${LN} -sf ${EXAMPLESDIR} ${STAGEDIR}${MQDATA}/examples
@${LN} -sf ${DOCSDIR} ${STAGEDIR}${MQDATA}/docs
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
+.for f in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+do-install-EXAMPLES-on:
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>