aboutsummaryrefslogtreecommitdiff
path: root/net/appkonference
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-01 15:07:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-01 15:07:02 +0000
commit00fa54adec94b02853b015bf248309be03e4b7f0 (patch)
tree0286b0213e3b82eb32d7da31715d32504438171c /net/appkonference
parent5a4f078dc0a79cd243f14c8433408932c2db51b6 (diff)
downloadports-00fa54adec94b02853b015bf248309be03e4b7f0.tar.gz
ports-00fa54adec94b02853b015bf248309be03e4b7f0.zip
- Fix build with clang
Notes
Notes: svn path=/head/; revision=380202
Diffstat (limited to 'net/appkonference')
-rw-r--r--net/appkonference/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net/appkonference/Makefile b/net/appkonference/Makefile
index 9cc108725058..d7470b1c6bfa 100644
--- a/net/appkonference/Makefile
+++ b/net/appkonference/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
USE_CSTD= gnu89
-USES= gmake
+USES= compiler:features gmake
WRKSRC= ${WRKDIR}/${PORTNAME}/konference
PLIST_FILES= lib/asterisk/modules/app_konference.so
@@ -22,4 +22,11 @@ PLIST_FILES= lib/asterisk/modules/app_konference.so
ONLY_FOR_ARCHS= amd64 arm i386 ia64
ONLY_FOR_ARCHS_REASON= not yet ported to this architecture
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} < 36
+post-patch:
+ @${REINPLACE_CMD} -e 's|-fsingle-precision-constant||' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>